Upstream information

CVE-2010-5110 at MITRE

Description

DCTStream.cc in Poppler before 0.13.3 allows remote attackers to cause a denial of service (crash) via a crafted PDF file.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 845765 [CLOSED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
sledsp3-libpoppler-devel
SUSE Linux Enterprise Server 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
slessp3-libpoppler-devel
SUSE Linux Enterprise Server 11 SP4
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libpoppler-glib4
SUSE Linux Enterprise Server for SAP Applications 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
slessp3-libpoppler-devel
SUSE Linux Enterprise Server for VMWare 11 SP3
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
slessp3-libpoppler-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
sdksp3-libpoppler-devel
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libpoppler-devel
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Builds
SAT Patch Nr: 9284
SUSE Linux Enterprise Software Development Kit 11 SP3
  • libpoppler-devel >= 0.12.3-1.10.1
  • libpoppler-glib-devel >= 0.12.3-1.10.1
  • libpoppler-qt2 >= 0.12.3-1.10.1
  • libpoppler-qt3-devel >= 0.12.3-1.10.1
  • libpoppler-qt4-devel >= 0.12.3-1.10.1
Builds
SAT Patch Nr: 9284
SUSE Linux Enterprise Desktop 11 SP3
SUSE Linux Enterprise Server 11 SP3
SUSE Linux Enterprise Server 11 SP3 for VMware
  • libpoppler-glib4 >= 0.12.3-1.10.1
  • libpoppler-qt4-3 >= 0.12.3-1.10.1
  • libpoppler5 >= 0.12.3-1.10.1
  • poppler-tools >= 0.12.3-1.10.1
Builds
SAT Patch Nr: 9284