Upstream information

CVE-2010-4159 at MITRE

Description

Untrusted search path vulnerability in metadata/loader.c in Mono 2.8 and earlier allows local users to gain privileges via a Trojan horse shared library in the current working directory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 648086 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • mono-core >= 2.0.1-1.34.1
  • mono-data >= 2.0.1-1.34.1
  • mono-data-postgresql >= 2.0.1-1.34.1
  • mono-data-sqlite >= 2.0.1-1.34.1
  • mono-locale-extras >= 2.0.1-1.34.1
  • mono-nunit >= 2.0.1-1.34.1
  • mono-web >= 2.0.1-1.34.1
  • mono-winforms >= 2.0.1-1.34.1
Patchnames:
slessp1-bytefx-data-mysql
SUSE Linux Enterprise Server 11 SP2
SUSE Linux Enterprise Server 11 SP3
  • mono-core >= 2.6.7-0.7.19
  • mono-data >= 2.6.7-0.7.19
  • mono-data-postgresql >= 2.6.7-0.7.19
  • mono-data-sqlite >= 2.6.7-0.7.19
  • mono-locale-extras >= 2.6.7-0.7.19
  • mono-nunit >= 2.6.7-0.7.19
  • mono-web >= 2.6.7-0.7.19
  • mono-winforms >= 2.6.7-0.7.19
SUSE Linux Enterprise Server 11 SP4
  • mono-core >= 2.6.7-0.13.1
  • mono-data >= 2.6.7-0.13.1
  • mono-data-postgresql >= 2.6.7-0.13.1
  • mono-data-sqlite >= 2.6.7-0.13.1
  • mono-locale-extras >= 2.6.7-0.13.1
  • mono-nunit >= 2.6.7-0.13.1
  • mono-web >= 2.6.7-0.13.1
  • mono-winforms >= 2.6.7-0.13.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • bytefx-data-mysql >= 2.6.7-0.13.1
  • mono-core >= 2.6.7-0.13.1
  • mono-data >= 2.6.7-0.13.1
  • mono-data-firebird >= 2.6.7-0.13.1
  • mono-data-oracle >= 2.6.7-0.13.1
  • mono-data-postgresql >= 2.6.7-0.13.1
  • mono-data-sqlite >= 2.6.7-0.13.1
  • mono-data-sybase >= 2.6.7-0.13.1
  • mono-devel >= 2.6.7-0.13.1
  • mono-extras >= 2.6.7-0.13.1
  • mono-jscript >= 2.6.7-0.13.1
  • mono-locale-extras >= 2.6.7-0.13.1
  • mono-nunit >= 2.6.7-0.13.1
  • mono-wcf >= 2.6.7-0.13.1
  • mono-web >= 2.6.7-0.13.1
  • mono-winforms >= 2.6.7-0.13.1
  • mono-winfxcore >= 2.6.7-0.13.1
  • monodoc-core >= 2.6.7-0.13.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 mono-core Released
SLED-10-SP4 mono-core Released
SLES-10-SP3 mono-core Released
SLES-10-SP4 mono-core Released
SLES_LTSS-10-SP4 mono-core Released
SUSE Linux Enterprise Desktop 11 mono-core Released
SUSE Linux Enterprise Desktop 11 SP1 mono-core Released
SUSE Linux Enterprise Server 11 SP1 mono-core Released
SUSE Linux Enterprise Server 11 SP1 LTSS mono-core Released
SUSE Linux Enterprise Server for SAP Business All-in-One mono-core Released
SUSE Linux Enterprise Software Development Kit 11 mono-core Released
SUSE Linux Enterprise Software Development Kit 11 SP1 mono-core Released