Upstream information

CVE-2010-3775 at MITRE

Description

Mozilla Firefox before 3.5.16 and 3.6.x before 3.6.13, and SeaMonkey before 2.0.11, does not properly handle certain redirections involving data: URLs and Java LiveConnect scripts, which allows remote attackers to start processes, read arbitrary local files, and establish network connections via vectors involving a refresh value in the http-equiv attribute of a META element, which causes the wrong security principal to be used.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 657016 [VERIFIED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • MozillaFirefox >= 3.6.13-0.7.1
  • MozillaFirefox-translations >= 3.6.13-0.7.1
  • libfreebl3 >= 3.13.5-0.4.2
  • libfreebl3-32bit >= 3.13.5-0.4.2
  • libfreebl3-x86 >= 3.13.5-0.4.2
  • mozilla-nspr >= 4.9.1-0.5.1
  • mozilla-nspr-32bit >= 4.9.1-0.5.1
  • mozilla-nspr-x86 >= 4.9.1-0.5.1
  • mozilla-nss >= 3.13.5-0.4.2
  • mozilla-nss-32bit >= 3.13.5-0.4.2
  • mozilla-nss-tools >= 3.13.5-0.4.2
  • mozilla-nss-x86 >= 3.13.5-0.4.2
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-32bit >= 1.9.1.19-0.2.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-x86 >= 1.9.1.19-0.2.1
  • mozilla-xulrunner192 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-32bit >= 1.9.2.24-0.3.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-x86 >= 1.9.2.24-0.3.1
Patchnames:
slessp1-MozillaFirefox
slessp1-mozilla-xulrunner191
SUSE Linux Enterprise Server 11 SP2
  • MozillaFirefox >= 10.0-0.3.2
  • MozillaFirefox-translations >= 10.0-0.3.2
  • mozilla-xulrunner192 >= 1.9.2.24-0.3.1
  • mozilla-xulrunner192-32bit >= 1.9.2.24-0.3.2
  • mozilla-xulrunner192-gnome >= 1.9.2.24-0.3.1
  • mozilla-xulrunner192-translations >= 1.9.2.24-0.3.1
  • mozilla-xulrunner192-x86 >= 1.9.2.24-0.3.1
SUSE Linux Enterprise Server 11 SP3
  • MozillaFirefox >= 17.0.4esr-0.10.42
  • MozillaFirefox-translations >= 17.0.4esr-0.10.42
  • mozilla-xulrunner192 >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-32bit >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-gnome >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-translations >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-x86 >= 1.9.2.27-0.2.1
SUSE Linux Enterprise Server 11 SP4
  • MozillaFirefox >= 31.7.0esr-0.8.1
  • MozillaFirefox-translations >= 31.7.0esr-0.8.1
  • mozilla-xulrunner192 >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-32bit >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-gnome >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-translations >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-x86 >= 1.9.2.27-0.2.1
SUSE Linux Enterprise Software Development Kit 11 SP4
  • MozillaFirefox-devel >= 31.7.0esr-0.8.1
  • mozilla-xulrunner192-devel >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.27-0.2.1
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.27-0.2.1
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner192-devel >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner192-devel >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome-x86 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations-x86 >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner192-devel >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • MozillaFirefox >= 3.6.13-0.7.1
  • MozillaFirefox-translations >= 3.6.13-0.7.1
  • mozilla-xulrunner192 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Desktop 11 SP1
  • MozillaFirefox >= 3.6.13-0.7.1
  • MozillaFirefox-translations >= 3.6.13-0.7.1
  • mozilla-xulrunner192 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-32bit >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations-32bit >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • MozillaFirefox >= 3.6.13-0.7.1
  • MozillaFirefox-translations >= 3.6.13-0.7.1
  • mozilla-xulrunner192 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-32bit >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Server 11 SP1
  • MozillaFirefox >= 3.6.13-0.7.1
  • MozillaFirefox-translations >= 3.6.13-0.7.1
  • mozilla-xulrunner192 >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-translations >= 1.9.2.13-1.7.1
  • mozilla-xulrunner192-x86 >= 1.9.2.13-1.7.1
Builds
SAT Patch Nr: 3693
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • MozillaFirefox >= 3.5.16-0.4.1
  • MozillaFirefox-translations >= 3.5.16-0.4.1
  • mozilla-xulrunner191 >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.4.1
Builds
ZYPP Patch Nr: 7280
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • MozillaFirefox >= 3.5.16-0.4.1
  • MozillaFirefox-translations >= 3.5.16-0.4.1
  • mozilla-xulrunner191 >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-32bit >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.4.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.16-0.4.1
Builds
ZYPP Patch Nr: 7280
SUSE Linux Enterprise SDK 10 SP3
  • MozillaFirefox-branding-upstream >= 3.5.16-0.4.1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.4.1
  • python-xpcom191 >= 1.9.1.16-0.4.1
Builds
ZYPP Patch Nr: 7280
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs-x86 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations-x86 >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Software Development Kit 11 SP1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Desktop 11 SP1
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations-32bit >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
SUSE Linux Enterprise Server 11 SP1
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-x86 >= 1.9.1.16-0.1.1
Builds
SAT Patch Nr: 3694
openSUSE 11.1
  • MozillaThunderbird-debuginfo >= 3.0.11-0.6.1
  • MozillaThunderbird-debugsource >= 3.0.11-0.6.1
openSUSE 11.1
  • MozillaThunderbird >= 3.0.11-0.6.1
  • MozillaThunderbird-devel >= 3.0.11-0.6.1
  • MozillaThunderbird-translations-common >= 3.0.11-0.6.1
  • MozillaThunderbird-translations-other >= 3.0.11-0.6.1
  • enigmail >= 1.0.1-6.6.1
openSUSE 11.2
  • MozillaThunderbird-debuginfo >= 3.0.11-0.5.1
  • MozillaThunderbird-debugsource >= 3.0.11-0.5.1
  • MozillaThunderbird-devel-debuginfo >= 3.0.11-0.5.1
  • enigmail-debuginfo >= 1.0.1-3.5.1
openSUSE 11.2
  • MozillaThunderbird >= 3.0.11-0.5.1
  • MozillaThunderbird-devel >= 3.0.11-0.5.1
  • MozillaThunderbird-translations-common >= 3.0.11-0.5.1
  • MozillaThunderbird-translations-other >= 3.0.11-0.5.1
  • enigmail >= 1.0.1-3.5.1
openSUSE 11.3
  • MozillaThunderbird-debuginfo >= 3.0.11-0.5.1
  • MozillaThunderbird-debugsource >= 3.0.11-0.5.1
  • MozillaThunderbird-devel-debuginfo >= 3.0.11-0.5.1
  • enigmail-debuginfo >= 1.0.1-4.5.1
openSUSE 11.3
  • MozillaThunderbird >= 3.0.11-0.5.1
  • MozillaThunderbird-devel >= 3.0.11-0.5.1
  • MozillaThunderbird-translations-common >= 3.0.11-0.5.1
  • MozillaThunderbird-translations-other >= 3.0.11-0.5.1
  • enigmail >= 1.0.1-4.5.1
openSUSE 11.1
  • mozilla-xulrunner191-debuginfo >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-debuginfo-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-debugsource >= 1.9.1.16-0.1.1
openSUSE 11.1
  • mozilla-xulrunner191 >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations-common >= 1.9.1.16-0.1.1
  • mozilla-xulrunner191-translations-other >= 1.9.1.16-0.1.1
  • python-xpcom191 >= 1.9.1.16-0.1.1
openSUSE 11.2
openSUSE 11.3
  • mozilla-xulrunner191-debuginfo >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-debuginfo-32bit >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-debugsource >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-devel-debuginfo >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-gnomevfs-debuginfo >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-gnomevfs-debuginfo-32bit >= 1.9.1.16-0.2.1
  • python-xpcom191-debuginfo >= 1.9.1.16-0.2.1
openSUSE 11.2
openSUSE 11.3
  • mozilla-xulrunner191 >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-32bit >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-devel >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-gnomevfs-32bit >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-translations-common >= 1.9.1.16-0.2.1
  • mozilla-xulrunner191-translations-other >= 1.9.1.16-0.2.1
  • python-xpcom191 >= 1.9.1.16-0.2.1
openSUSE 11.1
  • MozillaFirefox-debuginfo >= 3.6.13-0.1.1
  • MozillaFirefox-debugsource >= 3.6.13-0.1.1
  • mozilla-xulrunner192-debuginfo >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-debuginfo-32bit >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-debugsource >= 1.9.2.13-0.1.1
openSUSE 11.1
  • MozillaFirefox >= 3.6.13-0.1.1
  • MozillaFirefox-branding-upstream >= 3.6.13-0.1.1
  • MozillaFirefox-translations-common >= 3.6.13-0.1.1
  • MozillaFirefox-translations-other >= 3.6.13-0.1.1
  • mozilla-js192 >= 1.9.2.13-0.1.1
  • mozilla-js192-32bit >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192 >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-32bit >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-buildsymbols >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-devel >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-translations-common >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-translations-common-32bit >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-translations-other >= 1.9.2.13-0.1.1
  • mozilla-xulrunner192-translations-other-32bit >= 1.9.2.13-0.1.1
openSUSE 11.2
openSUSE 11.3
  • MozillaFirefox-debuginfo >= 3.6.13-0.2.1
  • MozillaFirefox-debugsource >= 3.6.13-0.2.1
  • mozilla-js192-debuginfo >= 1.9.2.13-0.2.1
  • mozilla-js192-debuginfo-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-debuginfo >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-debuginfo-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-debugsource >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-devel-debuginfo >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-gnome-debuginfo >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-gnome-debuginfo-32bit >= 1.9.2.13-0.2.1
openSUSE 11.2
openSUSE 11.3
  • MozillaFirefox >= 3.6.13-0.2.1
  • MozillaFirefox-branding-upstream >= 3.6.13-0.2.1
  • MozillaFirefox-translations-common >= 3.6.13-0.2.1
  • MozillaFirefox-translations-other >= 3.6.13-0.2.1
  • mozilla-js192 >= 1.9.2.13-0.2.1
  • mozilla-js192-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192 >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-buildsymbols >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-devel >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-gnome >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-gnome-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-translations-common >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-translations-common-32bit >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-translations-other >= 1.9.2.13-0.2.1
  • mozilla-xulrunner192-translations-other-32bit >= 1.9.2.13-0.2.1
openSUSE 11.1
  • seamonkey-debuginfo >= 2.0.11-0.1.1
  • seamonkey-debugsource >= 2.0.11-0.1.1
openSUSE 11.1
  • seamonkey >= 2.0.11-0.1.1
  • seamonkey-dom-inspector >= 2.0.11-0.1.1
  • seamonkey-irc >= 2.0.11-0.1.1
  • seamonkey-venkman >= 2.0.11-0.1.1
openSUSE 11.2
openSUSE 11.3
  • seamonkey-debuginfo >= 2.0.11-0.2.1
  • seamonkey-debugsource >= 2.0.11-0.2.1
openSUSE 11.2
  • seamonkey >= 2.0.11-0.2.1
  • seamonkey-dom-inspector >= 2.0.11-0.2.1
  • seamonkey-irc >= 2.0.11-0.2.1
  • seamonkey-venkman >= 2.0.11-0.2.1
openSUSE 11.3
  • seamonkey >= 2.0.11-0.2.1
  • seamonkey-dom-inspector >= 2.0.11-0.2.1
  • seamonkey-irc >= 2.0.11-0.2.1
  • seamonkey-translations-common >= 2.0.11-0.2.1
  • seamonkey-translations-other >= 2.0.11-0.2.1
  • seamonkey-venkman >= 2.0.11-0.2.1
openSUSE Tumbleweed
  • seamonkey >= 2.40-6.1
  • seamonkey-dom-inspector >= 2.40-6.1
  • seamonkey-irc >= 2.40-6.1
  • seamonkey-translations-common >= 2.40-6.1
  • seamonkey-translations-other >= 2.40-6.1
Patchnames:
openSUSE Tumbleweed GA seamonkey