Upstream information

CVE-2010-3434 at MITRE

Description

Buffer overflow in the find_stream_bounds function in pdf.c in libclamav in ClamAV before 0.96.3 allows remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted PDF document. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 640812 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • clamav >= 0.96.4-0.2.1
  • libgcc43 >= 4.3.3_20081022-11.18
  • libgcc43-32bit >= 4.3.3_20081022-11.18
  • libgcc43-x86 >= 4.3.3_20081022-11.18
  • libstdc++43 >= 4.3.3_20081022-11.18
  • libstdc++43-32bit >= 4.3.3_20081022-11.18
  • libstdc++43-x86 >= 4.3.3_20081022-11.18
Patchnames:
slessp0-clamav
SUSE Linux Enterprise Server 11 SP1
  • clamav >= 0.96.4-0.2.1
Patchnames:
slessp1-clamav
SUSE Linux Enterprise Server for SAP Applications 11
  • clamav >= 0.96.4-0.2.1
  • libgcc43 >= 4.3.3_20081022-11.18
  • libgcc43-32bit >= 4.3.3_20081022-11.18
  • libgcc43-x86 >= 4.3.3_20081022-11.18
  • libstdc++43 >= 4.3.3_20081022-11.18
  • libstdc++43-32bit >= 4.3.3_20081022-11.18
  • libstdc++43-x86 >= 4.3.3_20081022-11.18
Patchnames:
slessp0-clamav
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • clamav >= 0.96.4-0.2.1
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.ppc
sles11-sp1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1-vmware.x86-64
SAT Patch Nr: 3441
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • clamav >= 0.96.4-0.2.1
sles11.x86-64
sles11.ia64
sled11.x86-64
sles11.ppc
sles11.s390x
sles11.x86
sled11.x86
SAT Patch Nr: 3440
openSUSE 11.1
openSUSE 11.2
openSUSE 11.3
  • clamav-debuginfo >= 0.96.3-0.1.1
  • clamav-debugsource >= 0.96.3-0.1.1
openSUSE 11.1
openSUSE 11.2
openSUSE 11.3
  • clamav >= 0.96.3-0.1.1
  • clamav-db >= 0.96.3-0.1.1
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • clamav >= 0.96.4-0.4.1
sles10-sp3.ia64
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86
sled10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3.ppc
sles10-sp3.x86-64
sled10-sp3.x86-64
sle10-sp3-sdk.x86-64
sles10-sp3.s390x
sles10-sp3.x86
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7209
Open Enterprise Server
  • clamav >= 0.96.4-0.1
sles9-nlpos.x86
core9.x86
core9.x86-64
sles9-oes.x86
core9.ia64
core9.s390
core9.s390x
core9.ppc
YOU Patch Nr: 12662


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 clamav Affected
SUSE Linux Enterprise Desktop 10 SP4 clamav Affected
SUSE Linux Enterprise Desktop 11 GA clamav Affected
SUSE Linux Enterprise Desktop 11 SP1 clamav Affected
SUSE Linux Enterprise Desktop 11 SP2 clamav Affected
SUSE Linux Enterprise Desktop 11 SP3 clamav Affected
SUSE Linux Enterprise Desktop 11 SP4 clamav Affected
SUSE Linux Enterprise Server 10 SP3 clamav Affected
SUSE Linux Enterprise Server 10 SP4 clamav Affected
SUSE Linux Enterprise Server 10 SP4 LTSS clamav Affected
SUSE Linux Enterprise Server 11 SP1 clamav Affected
SUSE Linux Enterprise Server 11 SP1 LTSS clamav Affected
SUSE Linux Enterprise Server 11 SP2 clamav Affected
SUSE Linux Enterprise Server 11 SP2 LTSS clamav Affected
SUSE Linux Enterprise Server 11 SP3 clamav Affected
SUSE Linux Enterprise Server 11 SP3 LTSS clamav Affected
SUSE Linux Enterprise Server 11 SP4 clamav Affected
SUSE Linux Enterprise Server for SAP AIO 11 SP1 clamav Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP2 clamav Affected
SUSE Linux Enterprise Server for SAP Applications 11 SP3 clamav Affected
SUSE Linux Enterprise Server for SAP ES 11 SP1 clamav Affected
SUSE Linux Enterprise Server for VMWare 11 SP2 clamav Affected
SUSE Linux Enterprise Server for VMWare 11 SP3 clamav Affected