Upstream information

CVE-2010-3430 at MITRE

Description

The privilege-dropping implementation in the (1) pam_env and (2) pam_mail modules in Linux-PAM (aka pam) 1.1.2 does not perform the required setfsgid and setgroups system calls, which might allow local users to obtain sensitive information by leveraging unintended group permissions, as demonstrated by a symlink attack on the .pam_environment file in a user's home directory. NOTE: this vulnerability exists because of an incomplete fix for CVE-2010-3435.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.7
Vector AV:L/AC:M/Au:N/C:C/I:N/A:N
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 623457 [RESOLVED / FIXED], 631802 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • pam >= 1.1.8-11.57
  • pam-32bit >= 1.1.8-11.57
  • pam-doc >= 1.1.8-11.57
Patchnames:
SUSE Linux Enterprise Desktop 12 GA pam
SUSE Linux Enterprise Desktop 12 SP1
  • pam >= 1.1.8-14.1
  • pam-32bit >= 1.1.8-14.1
  • pam-doc >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA pam
SUSE Linux Enterprise Desktop 12 SP2
  • pam >= 1.1.8-14.1
  • pam-32bit >= 1.1.8-14.1
  • pam-doc >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA pam
SUSE Linux Enterprise Desktop 12 SP3
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA pam
SUSE Linux Enterprise Module for Basesystem 15
  • pam >= 1.3.0-4.10
  • pam-32bit >= 1.3.0-4.10
  • pam-devel >= 1.3.0-4.10
  • pam-doc >= 1.3.0-4.10
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA pam
SUSE Linux Enterprise Module for Development Tools 15
  • pam-devel-32bit >= 1.3.0-4.10
Patchnames:
SUSE Linux Enterprise Module for Development Tools 15 GA pam-devel-32bit
SUSE Linux Enterprise Server 12
  • pam >= 1.1.8-11.57
  • pam-32bit >= 1.1.8-11.57
  • pam-doc >= 1.1.8-11.57
Patchnames:
SUSE Linux Enterprise Server 12 GA pam
SUSE Linux Enterprise Server 12 SP1
  • pam >= 1.1.8-14.1
  • pam-32bit >= 1.1.8-14.1
  • pam-doc >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA pam
SUSE Linux Enterprise Server 12 SP2
  • pam >= 1.1.8-14.1
  • pam-32bit >= 1.1.8-14.1
  • pam-doc >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA pam
SUSE Linux Enterprise Server 12 SP3
  • pam >= 1.1.8-23.1
  • pam-32bit >= 1.1.8-23.1
  • pam-doc >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA pam
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • pam >= 1.1.8-14.1
  • pam-doc >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA pam
SUSE Linux Enterprise Software Development Kit 12
  • pam-devel >= 1.1.8-11.57
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA pam-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • pam-devel >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA pam-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • pam-devel >= 1.1.8-14.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA pam-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • pam-devel >= 1.1.8-23.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA pam-devel
openSUSE Leap 15.0
  • pam >= 1.3.0-lp150.4.6
  • pam-32bit >= 1.3.0-lp150.4.6
Patchnames:
openSUSE Leap 15.0 GA pam
openSUSE Leap 42.1
  • pam >= 1.1.8-12.4
  • pam-32bit >= 1.1.8-12.4
  • pam-devel >= 1.1.8-12.4
Patchnames:
openSUSE Leap 42.1 GA pam
openSUSE Leap 42.2
  • pam >= 1.3.0-1.9
  • pam-32bit >= 1.3.0-1.9
  • pam-devel >= 1.3.0-1.9
Patchnames:
openSUSE Leap 42.2 GA pam
openSUSE Leap 42.3
  • pam >= 1.3.0-3.15
  • pam-32bit >= 1.3.0-3.15
  • pam-devel >= 1.3.0-3.15
Patchnames:
openSUSE Leap 42.3 GA pam
openSUSE Tumbleweed
  • pam >= 1.3.0-3.4
  • pam-32bit >= 1.3.0-3.4
  • pam-devel >= 1.3.0-3.4
  • pam-devel-32bit >= 1.3.0-3.4
  • pam-doc >= 1.3.0-3.4
Patchnames:
openSUSE Tumbleweed GA pam