Upstream information

CVE-2010-2891 at MITRE

Description

Buffer overflow in the smiGetNode function in lib/smi.c in libsmi 0.4.8 allows context-dependent attackers to execute arbitrary code via an Object Identifier (aka OID) represented as a numerical string containing many components separated by . (dot) characters.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 649867 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libsmi
SUSE Linux Enterprise Desktop 12 SP1
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libsmi
SUSE Linux Enterprise Desktop 12 SP2
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libsmi
SUSE Linux Enterprise Desktop 12 SP3
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libsmi
SUSE Linux Enterprise Module for Basesystem 15
  • libsmi >= 0.4.8-1.29
  • libsmi2 >= 0.4.8-1.29
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libsmi
SUSE Linux Enterprise Module for Desktop Applications 15
  • libsmi-devel >= 0.4.8-1.29
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA libsmi-devel
SUSE Linux Enterprise Server 12
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Server 12 GA libsmi
SUSE Linux Enterprise Server 12 SP1
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libsmi
SUSE Linux Enterprise Server 12 SP2
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libsmi
SUSE Linux Enterprise Server 12 SP3
  • libsmi >= 0.4.8-18.63
  • libsmi2 >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libsmi
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libsmi >= 0.4.8-18.55
  • libsmi2 >= 0.4.8-18.55
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libsmi
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libsmi >= 0.4.5-2.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libsmi
SUSE Linux Enterprise Software Development Kit 12
  • libsmi-devel >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libsmi-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libsmi-devel >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libsmi-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libsmi-devel >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libsmi-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libsmi-devel >= 0.4.8-18.63
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libsmi-devel
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libsmi >= 0.4.5-2.7.1
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3518
openSUSE 11.1
  • libsmi-debuginfo >= 0.4.5-1.91.2
  • libsmi-debugsource >= 0.4.5-1.91.2
openSUSE 11.1
  • libsmi >= 0.4.5-1.91.2
  • libsmi-devel >= 0.4.5-1.91.2
openSUSE 11.2
  • libsmi-debuginfo >= 0.4.5-127.3.1
  • libsmi-debugsource >= 0.4.5-127.3.1
openSUSE 11.2
  • libsmi >= 0.4.5-127.3.1
  • libsmi-devel >= 0.4.5-127.3.1
openSUSE 11.3
  • libsmi-debuginfo >= 0.4.5-131.3.1
  • libsmi-debugsource >= 0.4.5-131.3.1
openSUSE 11.3
  • libsmi >= 0.4.5-131.3.1
  • libsmi-devel >= 0.4.5-131.3.1
SUSE Linux Enterprise SDK 10 SP3
  • libsmi >= 0.4.3-17.8.1
  • libsmi-devel >= 0.4.3-17.8.1
sle10-sp3-sdk.ia64
sle10-sp3-sdk.ppc
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7226
openSUSE Leap 42.1
  • libsmi >= 0.4.8-20.1
  • libsmi2 >= 0.4.8-20.1
Patchnames:
openSUSE Leap 42.1 GA libsmi
openSUSE Leap 42.2
  • libsmi >= 0.4.8-21.5
  • libsmi2 >= 0.4.8-21.5
Patchnames:
openSUSE Leap 42.2 GA libsmi
openSUSE Leap 42.3
  • libsmi >= 0.4.8-23.1
  • libsmi2 >= 0.4.8-23.1
Patchnames:
openSUSE Leap 42.3 GA libsmi
openSUSE Tumbleweed
  • libsmi >= 0.4.8-24.8
  • libsmi-devel >= 0.4.8-24.8
  • libsmi2 >= 0.4.8-24.8
Patchnames:
openSUSE Tumbleweed GA libsmi


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 GA libsmi Affected
SUSE Linux Enterprise SDK 11 SP1 libsmi Affected
SUSE Linux Enterprise SDK 11 SP2 libsmi Affected
SUSE Linux Enterprise SDK 11 SP3 libsmi Affected
SUSE Linux Enterprise SDK 11 SP4 libsmi Affected
SUSE Linux Enterprise Server 11 SP3 LTSS libsmi Affected
SUSE Linux Enterprise Server 11 SP4 libsmi Affected