Upstream information

CVE-2010-2801 at MITRE

Description

Integer signedness error in the Quantum decompressor in cabextract before 1.3, when archive test mode is used, allows user-assisted remote attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a crafted Quantum archive in a .cab file, related to the libmspack library.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.1
Vector AV:N/AC:H/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 627753 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 11 SP3
  • cabextract >= 1.2-2.10.1
Patchnames:
sledsp3-cabextract
SUSE Linux Enterprise Desktop 12
  • libmspack0 >= 0.4-3.64
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libmspack0
SUSE Linux Enterprise Desktop 12 SP1
  • libmspack0 >= 0.4-10.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libmspack0
SUSE Linux Enterprise Desktop 12 SP2
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libmspack0
SUSE Linux Enterprise Desktop 12 SP3
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libmspack0
SUSE Linux Enterprise Desktop 12 SP4
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Desktop 12 SP4 GA libmspack0
SUSE Linux Enterprise Module for Basesystem 15
  • libmspack-devel >= 0.6-1.17
  • libmspack0 >= 0.6-1.17
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libmspack-devel
SUSE Linux Enterprise Server 12
  • libmspack0 >= 0.4-3.64
Patchnames:
SUSE Linux Enterprise Server 12 GA libmspack0
SUSE Linux Enterprise Server 12 SP1
  • libmspack0 >= 0.4-10.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libmspack0
SUSE Linux Enterprise Server 12 SP2
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libmspack0
SUSE Linux Enterprise Server 12 SP3
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libmspack0
SUSE Linux Enterprise Server 12 SP4
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libmspack0
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libmspack0 >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libmspack0
SUSE Linux Enterprise Software Development Kit 12
  • libmspack-devel >= 0.4-3.64
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libmspack-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libmspack-devel >= 0.4-10.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libmspack-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libmspack-devel >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libmspack-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libmspack-devel >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libmspack-devel
SUSE Linux Enterprise Software Development Kit 12 SP4
  • libmspack-devel >= 0.4-14.4
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP4 GA libmspack-devel
SUSE Linux Enterprise Desktop 11 SP3
  • cabextract >= 1.2-2.10.1
Builds
SAT Patch Nr: 9437
openSUSE Leap 15.0
  • libmspack0 >= 0.6-lp150.1.3
Patchnames:
openSUSE Leap 15.0 GA libmspack0
openSUSE Leap 42.1
  • libmspack0 >= 0.5-4.2
Patchnames:
openSUSE Leap 42.1 GA libmspack0
openSUSE Leap 42.2
  • libmspack0 >= 0.5-5.4
Patchnames:
openSUSE Leap 42.2 GA libmspack0
openSUSE Leap 42.3
  • libmspack0 >= 0.5-7.3
Patchnames:
openSUSE Leap 42.3 GA libmspack0
openSUSE Tumbleweed
  • libmspack-devel >= 0.5-2.8
  • libmspack0 >= 0.5-2.8
  • libmspack0-32bit >= 0.5-2.8
Patchnames:
openSUSE Tumbleweed GA libmspack-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 cabextract Released
SUSE Linux Enterprise Desktop 10 SP4 cabextract Released
SUSE Linux Enterprise Desktop 11 SP3 cabextract Released
SUSE Linux Enterprise Server 10 SP3 cabextract Released
SUSE Linux Enterprise Server 10 SP4 cabextract Released
SUSE Linux Enterprise Server 10 SP4 LTSS cabextract Released