Upstream information

CVE-2010-2713 at MITRE

Description

The vte_sequence_handler_window_manipulation function in vteseq.c in libvte (aka libvte9) in VTE 0.25.1 and earlier, as used in gnome-terminal, does not properly handle escape sequences, which allows remote attackers to execute arbitrary commands or obtain potentially sensitive information via a (1) window title or (2) icon title sequence. NOTE: this issue exists because of a CVE-2003-0070 regression.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 621097 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • vte >= 0.22.5-0.2.1
  • vte-doc >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
Patchnames:
slessp1-vte
SUSE Linux Enterprise Server 11 SP2
  • vte >= 0.22.5-0.2.1
  • vte-doc >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA vte
SUSE Linux Enterprise Server 11 SP3
  • vte >= 0.22.5-0.2.1
  • vte-doc >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA vte
SUSE Linux Enterprise Server 11 SP4
  • vte >= 0.22.5-0.2.1
  • vte-doc >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA vte
SUSE Linux Enterprise Software Development Kit 11 SP4
  • vte-devel >= 0.22.5-0.2.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA vte-devel
SUSE Linux Enterprise Software Development Kit 11 SP1
  • vte-devel >= 0.22.5-0.2.1
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sled11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.ia64
sles11-sp1.x86
sles11-sp1.s390x
SAT Patch Nr: 2718
SUSE Linux Enterprise Desktop 11 SP1
  • vte >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sled11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.ia64
sles11-sp1.x86
sles11-sp1.s390x
SAT Patch Nr: 2718
SUSE Linux Enterprise Server 11 SP1
  • vte >= 0.22.5-0.2.1
  • vte-doc >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
sle11-sp1-sdk.ppc
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sled11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86
sle11-sp1-sdk.x86-64
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.ia64
sles11-sp1.x86
sles11-sp1.s390x
SAT Patch Nr: 2718
openSUSE 11.2
  • vte-debuginfo >= 0.22.5-0.2.1
  • vte-debugsource >= 0.22.5-0.2.1
openSUSE 11.2
  • vte >= 0.22.5-0.2.1
  • vte-devel >= 0.22.5-0.2.1
  • vte-lang >= 0.22.5-0.2.1
openSUSE 11.3
  • vte-debuginfo >= 0.24.1-2.1.1
  • vte-debugsource >= 0.24.1-2.1.1
openSUSE 11.3
  • vte >= 0.24.1-2.1.1
  • vte-devel >= 0.24.1-2.1.1
  • vte-lang >= 0.24.1-2.1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 SP1 vte Released
SUSE Linux Enterprise SDK 11 SP1 vte Released
SUSE Linux Enterprise Server 11 SP1 vte Released
SUSE Linux Enterprise Server 11 SP1 LTSS vte Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 vte Released