Upstream information

CVE-2010-2526 at MITRE

Description

The cluster logical volume manager daemon (clvmd) in lvm2-cluster in LVM2 before 2.02.72, as used in Red Hat Global File System (GFS) and other products, does not verify client credentials upon a socket connection, which allows local users to cause a denial of service (daemon exit or logical-volume change) or possibly have unspecified other impact via crafted control commands.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 622537 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • lvm2 >= 2.02.39-18.26.3
Patchnames:
slessp0-lvm2
SUSE Linux Enterprise Server 11 SP1
  • lvm2 >= 2.02.39-18.31.2
Patchnames:
slessp1-lvm2-clvm2
SUSE Linux Enterprise Server 11 SP2
  • lvm2 >= 2.02.84-3.25.5
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA lvm2
SUSE Linux Enterprise Server 11 SP3
  • lvm2 >= 2.02.98-0.25.3
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA lvm2
SUSE Linux Enterprise Server 11 SP4
  • lvm2 >= 2.02.98-0.33.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA lvm2
SUSE Linux Enterprise Server for SAP Applications 11
  • lvm2 >= 2.02.39-18.26.3
Patchnames:
slessp0-lvm2
SUSE Linux Enterprise High Availability Extension 11
  • lvm2-clvm >= 2.02.39-18.26.3
sle11-hae.x86-64
sle11-hae.x86
sled11.x86-64
sles11.ppc
sles11.x86
sles11.s390x
sled11.x86
sle11-hae.ppc
sle11-hae.s390x
sles11.x86-64
sle11-hae.ia64
sles11.ia64
SAT Patch Nr: 2849
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • lvm2 >= 2.02.39-18.26.3
sle11-hae.x86-64
sle11-hae.x86
sled11.x86-64
sles11.ppc
sles11.x86
sles11.s390x
sled11.x86
sle11-hae.ppc
sle11-hae.s390x
sles11.x86-64
sle11-hae.ia64
sles11.ia64
SAT Patch Nr: 2849
openSUSE 11.1
  • lvm2-debuginfo >= 2.02.39-8.14.1
  • lvm2-debugsource >= 2.02.39-8.14.1
openSUSE 11.1
  • lvm2 >= 2.02.39-8.14.1
  • lvm2-clvm >= 2.02.39-8.14.1
SUSE Linux Enterprise High Availability Extension 11 SP1
  • lvm2-clvm >= 2.02.39-18.31.5
sles11-sp1.x86-64
sle11-sp1-hae.s390x
sles11-sp1.x86
sles11-sp1-vmware.x86
sle11-sp1-hae.ppc
sle11-sp1-hae.x86
sles11-sp1.s390x
sle11-sp1-hae.x86-64
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sle11-sp1-hae.ia64
sles11-sp1.ppc
SAT Patch Nr: 2982
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • lvm2 >= 2.02.39-18.31.2
sles11-sp1.x86-64
sle11-sp1-hae.s390x
sles11-sp1.x86
sles11-sp1-vmware.x86
sle11-sp1-hae.ppc
sle11-sp1-hae.x86
sles11-sp1.s390x
sle11-sp1-hae.x86-64
sled11-sp1.x86
sles11-sp1-vmware.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sle11-sp1-hae.ia64
sles11-sp1.ppc
SAT Patch Nr: 2982


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise High Availability Extension 11 GA lvm2-clvm Released
SUSE Linux Enterprise High Availability Extension 11 SP1 lvm2-clvm Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 lvm2-clvm Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 lvm2-clvm Released