Upstream information

CVE-2010-2244 at MITRE

Description

The AvahiDnsPacket function in avahi-core/socket.c in avahi-daemon in Avahi 0.6.16 and 0.6.25 allows remote attackers to cause a denial of service (assertion failure and daemon exit) via a DNS packet with an invalid checksum followed by a DNS packet with a valid checksum, a different vulnerability than CVE-2008-5081.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 603289 [RESOLVED / FIXED], 646961 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • avahi >= 0.6.31-20.59
  • avahi-lang >= 0.6.31-20.59
  • libavahi-client3 >= 0.6.31-20.59
  • libavahi-client3-32bit >= 0.6.31-20.59
  • libavahi-common3 >= 0.6.31-20.59
  • libavahi-common3-32bit >= 0.6.31-20.59
  • libavahi-core7 >= 0.6.31-20.59
  • libdns_sd >= 0.6.31-20.59
  • libdns_sd-32bit >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Desktop 12 GA avahi
SUSE Linux Enterprise Desktop 12 SP1
  • avahi >= 0.6.31-20.59
  • avahi-lang >= 0.6.31-20.59
  • libavahi-client3 >= 0.6.31-20.59
  • libavahi-client3-32bit >= 0.6.31-20.59
  • libavahi-common3 >= 0.6.31-20.59
  • libavahi-common3-32bit >= 0.6.31-20.59
  • libavahi-core7 >= 0.6.31-20.59
  • libdns_sd >= 0.6.31-20.59
  • libdns_sd-32bit >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA avahi
SUSE Linux Enterprise Desktop 12 SP2
  • avahi >= 0.6.32-30.36
  • avahi-lang >= 0.6.32-30.36
  • libavahi-client3 >= 0.6.32-30.36
  • libavahi-client3-32bit >= 0.6.32-30.36
  • libavahi-common3 >= 0.6.32-30.36
  • libavahi-common3-32bit >= 0.6.32-30.36
  • libavahi-core7 >= 0.6.32-30.36
  • libdns_sd >= 0.6.32-30.36
  • libdns_sd-32bit >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA avahi
SUSE Linux Enterprise Desktop 12 SP3
  • avahi >= 0.6.32-30.36
  • avahi-lang >= 0.6.32-30.36
  • libavahi-client3 >= 0.6.32-30.36
  • libavahi-client3-32bit >= 0.6.32-30.36
  • libavahi-common3 >= 0.6.32-30.36
  • libavahi-common3-32bit >= 0.6.32-30.36
  • libavahi-core7 >= 0.6.32-30.36
  • libdns_sd >= 0.6.32-30.36
  • libdns_sd-32bit >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA avahi
SUSE Linux Enterprise Module for Basesystem 15
  • avahi >= 0.6.32-3.7
  • avahi-compat-howl-devel >= 0.6.32-3.7
  • avahi-compat-mDNSResponder-devel >= 0.6.32-3.7
  • avahi-lang >= 0.6.32-3.7
  • avahi-utils >= 0.6.32-3.7
  • libavahi-client3 >= 0.6.32-3.7
  • libavahi-common3 >= 0.6.32-3.7
  • libavahi-core7 >= 0.6.32-3.7
  • libavahi-devel >= 0.6.32-3.7
  • libdns_sd >= 0.6.32-3.7
  • libhowl0 >= 0.6.32-3.7
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA avahi
SUSE Linux Enterprise Module for Desktop Applications 15
  • avahi-autoipd >= 0.6.32-3.7
  • libavahi-client3-32bit >= 0.6.32-3.7
  • libavahi-common3-32bit >= 0.6.32-3.7
Patchnames:
SUSE Linux Enterprise Module for Desktop Applications 15 GA avahi-autoipd
SUSE Linux Enterprise Server 12
  • avahi >= 0.6.31-20.59
  • avahi-lang >= 0.6.31-20.59
  • avahi-utils >= 0.6.31-20.59
  • libavahi-client3 >= 0.6.31-20.59
  • libavahi-client3-32bit >= 0.6.31-20.59
  • libavahi-common3 >= 0.6.31-20.59
  • libavahi-common3-32bit >= 0.6.31-20.59
  • libavahi-core7 >= 0.6.31-20.59
  • libdns_sd >= 0.6.31-20.59
  • libdns_sd-32bit >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Server 12 GA avahi
SUSE Linux Enterprise Server 12 SP1
  • avahi >= 0.6.31-20.59
  • avahi-lang >= 0.6.31-20.59
  • avahi-utils >= 0.6.31-20.59
  • libavahi-client3 >= 0.6.31-20.59
  • libavahi-client3-32bit >= 0.6.31-20.59
  • libavahi-common3 >= 0.6.31-20.59
  • libavahi-common3-32bit >= 0.6.31-20.59
  • libavahi-core7 >= 0.6.31-20.59
  • libdns_sd >= 0.6.31-20.59
  • libdns_sd-32bit >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA avahi
SUSE Linux Enterprise Server 12 SP2
  • avahi >= 0.6.32-30.36
  • avahi-lang >= 0.6.32-30.36
  • avahi-utils >= 0.6.32-30.36
  • libavahi-client3 >= 0.6.32-30.36
  • libavahi-client3-32bit >= 0.6.32-30.36
  • libavahi-common3 >= 0.6.32-30.36
  • libavahi-common3-32bit >= 0.6.32-30.36
  • libavahi-core7 >= 0.6.32-30.36
  • libdns_sd >= 0.6.32-30.36
  • libdns_sd-32bit >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA avahi
SUSE Linux Enterprise Server 12 SP3
  • avahi >= 0.6.32-30.36
  • avahi-lang >= 0.6.32-30.36
  • avahi-utils >= 0.6.32-30.36
  • libavahi-client3 >= 0.6.32-30.36
  • libavahi-client3-32bit >= 0.6.32-30.36
  • libavahi-common3 >= 0.6.32-30.36
  • libavahi-common3-32bit >= 0.6.32-30.36
  • libavahi-core7 >= 0.6.32-30.36
  • libdns_sd >= 0.6.32-30.36
  • libdns_sd-32bit >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA avahi
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • avahi >= 0.6.32-30.36
  • avahi-lang >= 0.6.32-30.36
  • avahi-utils >= 0.6.32-30.36
  • libavahi-client3 >= 0.6.32-30.36
  • libavahi-common3 >= 0.6.32-30.36
  • libavahi-core7 >= 0.6.32-30.36
  • libdns_sd >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA avahi
SUSE Linux Enterprise Software Development Kit 12
  • avahi-compat-howl-devel >= 0.6.31-20.59
  • avahi-compat-mDNSResponder-devel >= 0.6.31-20.59
  • libavahi-devel >= 0.6.31-20.59
  • libhowl0 >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA avahi-compat-howl-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • avahi-compat-howl-devel >= 0.6.31-20.59
  • avahi-compat-mDNSResponder-devel >= 0.6.31-20.59
  • libavahi-devel >= 0.6.31-20.59
  • libhowl0 >= 0.6.31-20.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA avahi-compat-howl-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • avahi-compat-howl-devel >= 0.6.32-30.36
  • avahi-compat-mDNSResponder-devel >= 0.6.32-30.36
  • libavahi-devel >= 0.6.32-30.36
  • libhowl0 >= 0.6.32-30.36
  • python-avahi >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA avahi-compat-howl-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • avahi-compat-howl-devel >= 0.6.32-30.36
  • avahi-compat-mDNSResponder-devel >= 0.6.32-30.36
  • libavahi-devel >= 0.6.32-30.36
  • libhowl0 >= 0.6.32-30.36
  • python-avahi >= 0.6.32-30.36
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA avahi-compat-howl-devel
openSUSE Leap 15.0
  • avahi >= 0.6.32-lp150.3.2
  • avahi-lang >= 0.6.32-lp150.3.2
  • libavahi-client3 >= 0.6.32-lp150.3.2
  • libavahi-common3 >= 0.6.32-lp150.3.2
  • libavahi-core7 >= 0.6.32-lp150.3.2
Patchnames:
openSUSE Leap 15.0 GA avahi
openSUSE Leap 42.1
  • avahi >= 0.6.31-24.1
  • avahi-autoipd >= 0.6.31-24.1
  • avahi-compat-mDNSResponder-devel >= 0.6.31-24.1
  • avahi-lang >= 0.6.31-24.1
  • libavahi-client3 >= 0.6.31-24.1
  • libavahi-client3-32bit >= 0.6.31-24.1
  • libavahi-common3 >= 0.6.31-24.1
  • libavahi-common3-32bit >= 0.6.31-24.1
  • libavahi-core7 >= 0.6.31-24.1
  • libavahi-devel >= 0.6.31-24.1
  • libdns_sd >= 0.6.31-24.1
Patchnames:
openSUSE Leap 42.1 GA avahi
openSUSE Leap 42.2
  • avahi >= 0.6.32-1.2
  • avahi-autoipd >= 0.6.32-1.2
  • avahi-compat-mDNSResponder-devel >= 0.6.32-1.2
  • avahi-lang >= 0.6.32-1.2
  • libavahi-client3 >= 0.6.32-1.2
  • libavahi-client3-32bit >= 0.6.32-1.2
  • libavahi-common3 >= 0.6.32-1.2
  • libavahi-common3-32bit >= 0.6.32-1.2
  • libavahi-core7 >= 0.6.32-1.2
  • libavahi-devel >= 0.6.32-1.2
  • libdns_sd >= 0.6.32-1.2
Patchnames:
openSUSE Leap 42.2 GA avahi
openSUSE Leap 42.3
  • avahi >= 0.6.32-3.5
  • avahi-autoipd >= 0.6.32-3.5
  • avahi-compat-mDNSResponder-devel >= 0.6.32-3.5
  • avahi-lang >= 0.6.32-3.5
  • libavahi-client3 >= 0.6.32-3.5
  • libavahi-client3-32bit >= 0.6.32-3.5
  • libavahi-common3 >= 0.6.32-3.5
  • libavahi-common3-32bit >= 0.6.32-3.5
  • libavahi-core7 >= 0.6.32-3.5
  • libavahi-devel >= 0.6.32-3.5
  • libdns_sd >= 0.6.32-3.5
Patchnames:
openSUSE Leap 42.3 GA avahi
openSUSE Tumbleweed
  • avahi >= 0.6.32-2.3
  • avahi-autoipd >= 0.6.32-2.3
  • avahi-compat-howl-devel >= 0.6.32-2.3
  • avahi-compat-mDNSResponder-devel >= 0.6.32-2.3
  • avahi-lang >= 0.6.32-2.3
  • avahi-utils >= 0.6.32-2.3
  • libavahi-client3 >= 0.6.32-2.3
  • libavahi-client3-32bit >= 0.6.32-2.3
  • libavahi-common3 >= 0.6.32-2.3
  • libavahi-common3-32bit >= 0.6.32-2.3
  • libavahi-core7 >= 0.6.32-2.3
  • libavahi-devel >= 0.6.32-2.3
  • libdns_sd >= 0.6.32-2.3
  • libdns_sd-32bit >= 0.6.32-2.3
  • libhowl0 >= 0.6.32-2.3
  • python-avahi >= 0.6.32-2.3
Patchnames:
openSUSE Tumbleweed GA avahi