Upstream information

CVE-2010-2089 at MITRE

Description

The audioop module in Python 2.7 and 3.2 does not verify the relationships between size arguments and byte string lengths, which allows context-dependent attackers to cause a denial of service (memory corruption and application crash) via crafted arguments, as demonstrated by a call to audioop.reverse with a one-byte string, a different vulnerability than CVE-2010-1634.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 609761 [RESOLVED / FIXED], 666027 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libpython2_6-1_0 >= 2.6.0-8.10.1
  • libpython2_6-1_0-32bit >= 2.6.8-0.15.1
  • libpython2_6-1_0-x86 >= 2.6.8-0.15.1
  • python >= 2.6.0-8.10.1
  • python-32bit >= 2.6.8-0.15.1
  • python-base >= 2.6.0-8.10.1
  • python-base-32bit >= 2.6.8-0.15.1
  • python-base-x86 >= 2.6.8-0.15.1
  • python-curses >= 2.6.0-8.10.1
  • python-demo >= 2.6.0-8.10.1
  • python-gdbm >= 2.6.0-8.10.1
  • python-idle >= 2.6.0-8.10.1
  • python-tk >= 2.6.0-8.10.1
  • python-x86 >= 2.6.8-0.15.1
  • python-xml >= 2.6.0-8.10.1
Patchnames:
slessp1-libpython2_6-1_0
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • libpython2_6-1_0 >= 2.6.0-8.8.6.1
  • libpython2_6-1_0-32bit >= 2.6.0-8.8.6.1
  • libpython2_6-1_0-x86 >= 2.6.0-8.8.6.1
  • python >= 2.6.0-8.9.6.2
  • python-32bit >= 2.6.0-8.9.6.2
  • python-base >= 2.6.0-8.8.6.1
  • python-base-32bit >= 2.6.0-8.8.6.1
  • python-base-x86 >= 2.6.0-8.8.6.1
  • python-curses >= 2.6.0-8.9.6.2
  • python-demo >= 2.6.0-8.9.6.2
  • python-gdbm >= 2.6.0-8.9.6.2
  • python-idle >= 2.6.0-8.9.6.2
  • python-tk >= 2.6.0-8.9.6.2
  • python-x86 >= 2.6.0-8.9.6.2
  • python-xml >= 2.6.0-8.8.6.1
Patchnames:
slessp0-libpython2_6-1_0


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 python Released
SLES-10-SP3 python Released
SUSE Linux Enterprise Desktop 11 python Released
SUSE Linux Enterprise Desktop 11 SP1 python Released
SUSE Linux Enterprise Server 11 python Released
SUSE Linux Enterprise Server 11 SP1 python Released
SUSE Linux Enterprise Server 11 SP1 LTSS python Released
SUSE Linux Enterprise Server for SAP Business All-in-One python Released
SUSE Linux Enterprise Software Development Kit 11 python Released
SUSE Linux Enterprise Software Development Kit 11 SP1 python Released