Upstream information

CVE-2010-1975 at MITRE

Description

PostgreSQL 7.4 before 7.4.29, 8.0 before 8.0.25, 8.1 before 8.1.21, 8.2 before 8.2.17, 8.3 before 8.3.11, and 8.4 before 8.4.4 does not properly check privileges during certain RESET ALL operations, which allows remote authenticated users to remove arbitrary parameter settings via a (1) ALTER USER or (2) ALTER DATABASE statement.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.5
Vector AV:N/AC:L/Au:S/C:P/I:P/A:N
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 607778 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
  • postgresql-libs-x86 >= 8.3.7-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
Patchnames:
slessp0-postgresql
SUSE Linux Enterprise Server 11 SP1
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-init >= 9.1-0.6.10.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
  • postgresql-libs-x86 >= 8.3.18-0.3.1
  • postgresql-server >= 8.3.11-0.1.1
Patchnames:
slessp1-postgresql
SUSE Linux Enterprise Server for SAP Applications 11
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
  • postgresql-libs-x86 >= 8.3.7-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
Patchnames:
slessp0-postgresql
SUSE Linux Enterprise SDK 11 GA
  • postgresql-devel >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Desktop 11 GA
  • postgresql >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Desktop 11 GA
  • postgresql >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Server 11 GA
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Server 11 GA
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-x86 >= 8.3.11-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Server 11 GA
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
sles11.x86
sles11.s390x
sle11-sdk.x86
sle11-sdk.ppc
sles11.x86-64
sled11.x86-64
sle11-sdk.s390x
sled11.x86
sles11.ia64
sles11.ppc
sle11-sdk.x86-64
sle11-sdk.ia64
SAT Patch Nr: 2457
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
  • postgresql >= 8.3.11-0.1.1
sles11-sp1.x86-64
sles11-sp1-vmware.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.x86
sles11-sp1.x86-64
sled11-sp1.x86
sled11-sp1.x86-64
sles11-sp1-vmware.x86-64
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.x86
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.s390x
sled11-sp1.x86-64
sles11-sp1.x86
sles11-sp1.x86-64
sles11-sp1.ia64
sles11-sp1.s390x
sles11-sp1.s390x
sled11-sp1.x86
sles11-sp1.ppc
sled11-sp1.x86
sles11-sp1.ia64
sles11-sp1.ppc
sles11-sp1.x86
SAT Patch Nr: 2458
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
  • postgresql-libs-32bit >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • postgresql >= 8.1.21-0.4.1
  • postgresql-contrib >= 8.1.21-0.4.1
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-docs >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
  • postgresql-libs-32bit >= 8.1.21-0.4.1
  • postgresql-pl >= 8.1.21-0.4.1
  • postgresql-server >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise SDK 10 SP3
  • postgresql >= 8.1.21-0.4.1
  • postgresql-contrib >= 8.1.21-0.4.1
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-docs >= 8.1.21-0.4.1
  • postgresql-pl >= 8.1.21-0.4.1
  • postgresql-server >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise Server 10 SP3
  • postgresql >= 8.1.21-0.4.1
  • postgresql-contrib >= 8.1.21-0.4.1
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-docs >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
  • postgresql-pl >= 8.1.21-0.4.1
  • postgresql-server >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise Server 10 SP3
  • postgresql >= 8.1.21-0.4.1
  • postgresql-contrib >= 8.1.21-0.4.1
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-docs >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
  • postgresql-libs-x86 >= 8.1.21-0.4.1
  • postgresql-pl >= 8.1.21-0.4.1
  • postgresql-server >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
SUSE Linux Enterprise Server 10 SP3
  • postgresql >= 8.1.21-0.4.1
  • postgresql-contrib >= 8.1.21-0.4.1
  • postgresql-devel >= 8.1.21-0.4.1
  • postgresql-docs >= 8.1.21-0.4.1
  • postgresql-libs >= 8.1.21-0.4.1
  • postgresql-libs-64bit >= 8.1.21-0.4.1
  • postgresql-pl >= 8.1.21-0.4.1
  • postgresql-server >= 8.1.21-0.4.1
sle10-sp3-sdk.s390x
sles10-sp3.ppc
sle10-sp3-sdk.ia64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.x86
sles10-sp3.ia64
sles10-sp3.s390x
sled10-sp3.x86-64
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.x86-64
ZYPP Patch Nr: 7053
openSUSE 11.0
  • postgresql-debuginfo >= 8.3.11-0.1
  • postgresql-debugsource >= 8.3.11-0.1
openSUSE 11.0
  • postgresql >= 8.3.11-0.1
  • postgresql-contrib >= 8.3.11-0.1
  • postgresql-devel >= 8.3.11-0.1
  • postgresql-docs >= 8.3.11-0.1
  • postgresql-libs >= 8.3.11-0.1
  • postgresql-libs-32bit >= 8.3.11-0.1
  • postgresql-libs-64bit >= 8.3.11-0.1
  • postgresql-plperl >= 8.3.11-0.1
  • postgresql-plpython >= 8.3.11-0.1
  • postgresql-pltcl >= 8.3.11-0.1
  • postgresql-server >= 8.3.11-0.1
openSUSE 11.1
  • postgresql-debuginfo >= 8.3.11-0.1.1
  • postgresql-debugsource >= 8.3.11-0.1.1
openSUSE 11.1
  • postgresql >= 8.3.11-0.1.1
  • postgresql-contrib >= 8.3.11-0.1.1
  • postgresql-devel >= 8.3.11-0.1.1
  • postgresql-docs >= 8.3.11-0.1.1
  • postgresql-libs >= 8.3.11-0.1.1
  • postgresql-libs-32bit >= 8.3.11-0.1.1
  • postgresql-libs-64bit >= 8.3.11-0.1.1
  • postgresql-plperl >= 8.3.11-0.1.1
  • postgresql-plpython >= 8.3.11-0.1.1
  • postgresql-pltcl >= 8.3.11-0.1.1
  • postgresql-server >= 8.3.11-0.1.1
openSUSE 11.2
  • postgresql-contrib-debuginfo >= 8.4.4-0.1.1
  • postgresql-debuginfo >= 8.4.4-0.1.1
  • postgresql-debugsource >= 8.4.4-0.1.1
  • postgresql-devel-debuginfo >= 8.4.4-0.1.1
  • postgresql-libs-debuginfo >= 8.4.4-0.1.1
  • postgresql-libs-debuginfo-32bit >= 8.4.4-0.1.1
  • postgresql-server-debuginfo >= 8.4.4-0.1.1
openSUSE 11.2
  • postgresql >= 8.4.4-0.1.1
  • postgresql-contrib >= 8.4.4-0.1.1
  • postgresql-devel >= 8.4.4-0.1.1
  • postgresql-docs >= 8.4.4-0.1.1
  • postgresql-libs >= 8.4.4-0.1.1
  • postgresql-libs-32bit >= 8.4.4-0.1.1
  • postgresql-plperl >= 8.4.4-0.1.1
  • postgresql-plpython >= 8.4.4-0.1.1
  • postgresql-pltcl >= 8.4.4-0.1.1
  • postgresql-server >= 8.4.4-0.1.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 postgresql Released
SUSE Linux Enterprise Desktop 10 SP4 postgresql Released
SUSE Linux Enterprise Desktop 11 GA postgresql Released
SUSE Linux Enterprise Desktop 11 SP1 postgresql Released
SUSE Linux Enterprise Desktop 11 SP2 postgresql Released
SUSE Linux Enterprise Desktop 11 SP3 postgresql Released
SUSE Linux Enterprise Desktop 11 SP4 postgresql Released
SUSE Linux Enterprise Server 10 SP3 postgresql Released
SUSE Linux Enterprise Server 10 SP4 postgresql Released
SUSE Linux Enterprise Server 10 SP4 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP1 postgresql Released
SUSE Linux Enterprise Server 11 SP1 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP2 postgresql Released
SUSE Linux Enterprise Server 11 SP2 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP3 postgresql Released
SUSE Linux Enterprise Server 11 SP3 LTSS postgresql Released
SUSE Linux Enterprise Server 11 SP4 postgresql Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 postgresql Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 postgresql Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 postgresql Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 postgresql Released
SUSE Linux Enterprise Server for VMWare 11 SP2 postgresql Released
SUSE Linux Enterprise Server for VMWare 11 SP3 postgresql Released