Upstream information

CVE-2010-1628 at MITRE

Description

Ghostscript 8.64, 8.70, and possibly other versions allows context-dependent attackers to execute arbitrary code via a PostScript file containing unlimited recursive procedure invocations, which trigger memory corruption in the stack of the interpreter.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 605043 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • ghostscript-fonts-other >= 8.62-32.27.26.1
  • ghostscript-fonts-rus >= 8.62-32.27.26.1
  • ghostscript-fonts-std >= 8.62-32.27.26.1
  • ghostscript-library >= 8.62-32.27.26.1
  • ghostscript-omni >= 8.62-32.27.26.1
  • ghostscript-x11 >= 8.62-32.27.26.1
  • libgimpprint >= 4.2.7-32.27.26.1
Patchnames:
slessp0-ghostscript-devel
SUSE Linux Enterprise Server 11 SP1
  • ghostscript-fonts-other >= 8.62-32.28.1
  • ghostscript-fonts-rus >= 8.62-32.28.1
  • ghostscript-fonts-std >= 8.62-32.28.1
  • ghostscript-library >= 8.62-32.28.1
  • ghostscript-omni >= 8.62-32.28.1
  • ghostscript-x11 >= 8.62-32.28.1
  • libgimpprint >= 4.2.7-32.28.1
Patchnames:
slessp1-ghostscript-devel
SUSE Linux Enterprise Server for SAP Applications 11
  • ghostscript-fonts-other >= 8.62-32.27.26.1
  • ghostscript-fonts-rus >= 8.62-32.27.26.1
  • ghostscript-fonts-std >= 8.62-32.27.26.1
  • ghostscript-library >= 8.62-32.27.26.1
  • ghostscript-omni >= 8.62-32.27.26.1
  • ghostscript-x11 >= 8.62-32.27.26.1
  • libgimpprint >= 4.2.7-32.27.26.1
Patchnames:
slessp0-ghostscript-devel
SUSE Linux Enterprise Software Development Kit 11 SP1
  • ghostscript-devel >= 8.62-32.28.1
  • ghostscript-ijs-devel >= 8.62-32.28.1
  • libgimpprint-devel >= 4.2.7-32.28.1
sles11-sp1.s390x
sle11-sp1-sdk.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.ia64
SAT Patch Nr: 2708
SUSE Linux Enterprise Desktop 11 SP1
SUSE Linux Enterprise Server 11 SP1
  • ghostscript-fonts-other >= 8.62-32.28.1
  • ghostscript-fonts-rus >= 8.62-32.28.1
  • ghostscript-fonts-std >= 8.62-32.28.1
  • ghostscript-library >= 8.62-32.28.1
  • ghostscript-omni >= 8.62-32.28.1
  • ghostscript-x11 >= 8.62-32.28.1
  • libgimpprint >= 4.2.7-32.28.1
sles11-sp1.s390x
sle11-sp1-sdk.x86
sle11-sp1-sdk.ppc
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sle11-sp1-sdk.ia64
sles11-sp1.ppc
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.s390x
sles11-sp1.ia64
SAT Patch Nr: 2708
SUSE Linux Enterprise 11 Moblin 2.0
  • ghostscript-library-debuginfo >= 8.62-32.27.26.1
  • ghostscript-library-debugsource >= 8.62-32.27.26.1
SAT Patch Nr: 2710
SUSE Linux Enterprise 11 Moblin 2.0
  • ghostscript-fonts-other >= 8.62-32.27.26.1
  • ghostscript-fonts-std >= 8.62-32.27.26.1
  • ghostscript-library >= 8.62-32.27.26.1
  • ghostscript-x11 >= 8.62-32.27.26.1
  • libgimpprint >= 4.2.7-32.27.26.1
SAT Patch Nr: 2710
openSUSE 11.1
  • ghostscript-library-debuginfo >= 8.62-31.44.1
  • ghostscript-library-debugsource >= 8.62-31.44.1
openSUSE 11.1
  • ghostscript-devel >= 8.62-31.44.1
  • ghostscript-fonts-other >= 8.62-31.44.1
  • ghostscript-fonts-rus >= 8.62-31.44.1
  • ghostscript-fonts-std >= 8.62-31.44.1
  • ghostscript-ijs-devel >= 8.62-31.44.1
  • ghostscript-library >= 8.62-31.44.1
  • ghostscript-omni >= 8.62-31.44.1
  • ghostscript-x11 >= 8.62-31.44.1
  • libgimpprint >= 4.2.7-31.44.1
  • libgimpprint-devel >= 4.2.7-31.44.1
openSUSE 11.2
  • ghostscript-library-debuginfo >= 8.64-6.3.1
  • ghostscript-library-debugsource >= 8.64-6.3.1
  • ghostscript-omni-debuginfo >= 8.64-6.3.1
  • ghostscript-x11-debuginfo >= 8.64-6.3.1
  • libgimpprint-debuginfo >= 4.2.7-6.3.1
openSUSE 11.2
  • ghostscript-devel >= 8.64-6.3.1
  • ghostscript-fonts-other >= 8.64-6.3.1
  • ghostscript-fonts-rus >= 8.64-6.3.1
  • ghostscript-fonts-std >= 8.64-6.3.1
  • ghostscript-ijs-devel >= 8.64-6.3.1
  • ghostscript-library >= 8.64-6.3.1
  • ghostscript-omni >= 8.64-6.3.1
  • ghostscript-x11 >= 8.64-6.3.1
  • libgimpprint >= 4.2.7-6.3.1
  • libgimpprint-devel >= 4.2.7-6.3.1
SUSE Linux Enterprise SDK 11 GA
  • ghostscript-devel >= 8.62-32.27.26.1
  • ghostscript-ijs-devel >= 8.62-32.27.26.1
  • libgimpprint-devel >= 4.2.7-32.27.26.1
sled11.x86
sle11-sdk.x86
sles11.ppc
sle11-sdk.ppc
sle11-sdk.s390x
sles11.s390x
sle11-sdk.ia64
sles11.x86-64
sled11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.x86-64
SAT Patch Nr: 2709
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • ghostscript-fonts-other >= 8.62-32.27.26.1
  • ghostscript-fonts-rus >= 8.62-32.27.26.1
  • ghostscript-fonts-std >= 8.62-32.27.26.1
  • ghostscript-library >= 8.62-32.27.26.1
  • ghostscript-omni >= 8.62-32.27.26.1
  • ghostscript-x11 >= 8.62-32.27.26.1
  • libgimpprint >= 4.2.7-32.27.26.1
sled11.x86
sle11-sdk.x86
sles11.ppc
sle11-sdk.ppc
sle11-sdk.s390x
sles11.s390x
sle11-sdk.ia64
sles11.x86-64
sled11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.x86-64
SAT Patch Nr: 2709
openSUSE 11.0
  • ghostscript-library-debuginfo >= 8.62-17.8
  • ghostscript-library-debugsource >= 8.62-17.8
openSUSE 11.0
  • ghostscript-devel >= 8.62-17.8
  • ghostscript-fonts-other >= 8.62-17.8
  • ghostscript-fonts-rus >= 8.62-17.8
  • ghostscript-fonts-std >= 8.62-17.8
  • ghostscript-ijs-devel >= 8.62-17.8
  • ghostscript-library >= 8.62-17.8
  • ghostscript-omni >= 8.62-17.8
  • ghostscript-x11 >= 8.62-17.8
  • libgimpprint >= 4.2.7-258.8
  • libgimpprint-devel >= 4.2.7-258.8
SUSE Linux Enterprise 11 Moblin 2.1
  • ghostscript-fonts-other >= 8.62-32.27.26.1
  • ghostscript-fonts-std >= 8.62-32.27.26.1
  • ghostscript-library >= 8.62-32.27.26.1
  • ghostscript-x11 >= 8.62-32.27.26.1
  • libgimpprint >= 4.2.7-32.27.26.1
SAT Patch Nr: 2711


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Desktop 11 SP4 ghostscript-library Released
SUSE Linux Enterprise SDK 11 GA ghostscript-library Released
SUSE Linux Enterprise SDK 11 SP1 ghostscript-library Released
SUSE Linux Enterprise SDK 11 SP2 ghostscript-library Released
SUSE Linux Enterprise SDK 11 SP3 ghostscript-library Released
SUSE Linux Enterprise SDK 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Server 11 GA ghostscript-library Released
SUSE Linux Enterprise Server 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP1 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP2 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Server 11 SP3 LTSS ghostscript-library Released
SUSE Linux Enterprise Server 11 SP4 ghostscript-library Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ghostscript-library Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 ghostscript-library Released
SUSE Linux Enterprise Server for VMWare 11 SP2 ghostscript-library Released
SUSE Linux Enterprise Server for VMWare 11 SP3 ghostscript-library Released