Upstream information

CVE-2010-1459 at MITRE

Description

The default configuration of ASP.NET in Mono before 2.6.4 has a value of FALSE for the EnableViewStateMac property, which allows remote attackers to conduct cross-site scripting (XSS) attacks, as demonstrated by the __VIEWSTATE parameter to 2.0/menu/menu1.aspx in the XSP sample project.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entry: 592428 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
Patchnames:
slessp0-bytefx-data-mysql
SUSE Linux Enterprise Server 11 SP1
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
Patchnames:
slessp1-bytefx-data-mysql
SUSE Linux Enterprise Server 11 SP2
  • mono-core >= 2.6.7-0.7.19
  • mono-data >= 2.6.7-0.7.19
  • mono-data-postgresql >= 2.6.7-0.7.19
  • mono-data-sqlite >= 2.6.7-0.7.19
  • mono-locale-extras >= 2.6.7-0.7.19
  • mono-nunit >= 2.6.7-0.7.19
  • mono-web >= 2.6.7-0.7.19
  • mono-winforms >= 2.6.7-0.7.19
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA mono-core
SUSE Linux Enterprise Server 11 SP3
  • mono-core >= 2.6.7-0.7.19
  • mono-data >= 2.6.7-0.7.19
  • mono-data-postgresql >= 2.6.7-0.7.19
  • mono-data-sqlite >= 2.6.7-0.7.19
  • mono-locale-extras >= 2.6.7-0.7.19
  • mono-nunit >= 2.6.7-0.7.19
  • mono-web >= 2.6.7-0.7.19
  • mono-winforms >= 2.6.7-0.7.19
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA mono-core
SUSE Linux Enterprise Server 11 SP4
  • mono-core >= 2.6.7-0.13.1
  • mono-data >= 2.6.7-0.13.1
  • mono-data-postgresql >= 2.6.7-0.13.1
  • mono-data-sqlite >= 2.6.7-0.13.1
  • mono-locale-extras >= 2.6.7-0.13.1
  • mono-nunit >= 2.6.7-0.13.1
  • mono-web >= 2.6.7-0.13.1
  • mono-winforms >= 2.6.7-0.13.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA mono-core
SUSE Linux Enterprise Server for SAP Applications 11
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
Patchnames:
slessp0-bytefx-data-mysql
SUSE Linux Enterprise Software Development Kit 11 SP4
  • bytefx-data-mysql >= 2.6.7-0.13.1
  • mono-core >= 2.6.7-0.13.1
  • mono-data >= 2.6.7-0.13.1
  • mono-data-firebird >= 2.6.7-0.13.1
  • mono-data-oracle >= 2.6.7-0.13.1
  • mono-data-postgresql >= 2.6.7-0.13.1
  • mono-data-sqlite >= 2.6.7-0.13.1
  • mono-data-sybase >= 2.6.7-0.13.1
  • mono-devel >= 2.6.7-0.13.1
  • mono-extras >= 2.6.7-0.13.1
  • mono-jscript >= 2.6.7-0.13.1
  • mono-locale-extras >= 2.6.7-0.13.1
  • mono-nunit >= 2.6.7-0.13.1
  • mono-wcf >= 2.6.7-0.13.1
  • mono-web >= 2.6.7-0.13.1
  • mono-winforms >= 2.6.7-0.13.1
  • mono-winfxcore >= 2.6.7-0.13.1
  • monodoc-core >= 2.6.7-0.13.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA bytefx-data-mysql
SUSE Linux Enterprise SDK 11 GA
  • bytefx-data-mysql >= 2.0.1-1.20.1
  • mono-data-firebird >= 2.0.1-1.20.1
  • mono-data-oracle >= 2.0.1-1.20.1
  • mono-data-sybase >= 2.0.1-1.20.1
  • mono-devel >= 2.0.1-1.20.1
  • mono-extras >= 2.0.1-1.20.1
  • mono-jscript >= 2.0.1-1.20.1
sles11.s390x
sles11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86
sled11.x86-64
sle11-sdk.ppc
sle11-sdk.x86-64
sles11.ppc
sled11.x86
SAT Patch Nr: 2326
SUSE Linux Enterprise SDK 11 GA
  • bytefx-data-mysql >= 2.0.1-1.20.1
  • mono-core >= 2.0.1-1.20.1
  • mono-data >= 2.0.1-1.20.1
  • mono-data-firebird >= 2.0.1-1.20.1
  • mono-data-oracle >= 2.0.1-1.20.1
  • mono-data-postgresql >= 2.0.1-1.20.1
  • mono-data-sqlite >= 2.0.1-1.20.1
  • mono-data-sybase >= 2.0.1-1.20.1
  • mono-devel >= 2.0.1-1.20.1
  • mono-extras >= 2.0.1-1.20.1
  • mono-jscript >= 2.0.1-1.20.1
  • mono-locale-extras >= 2.0.1-1.20.1
  • mono-nunit >= 2.0.1-1.20.1
  • mono-web >= 2.0.1-1.20.1
  • mono-winforms >= 2.0.1-1.20.1
sles11.s390x
sles11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86
sled11.x86-64
sle11-sdk.ppc
sle11-sdk.x86-64
sles11.ppc
sled11.x86
SAT Patch Nr: 2326
SUSE Linux Enterprise Desktop 11 GA
  • bytefx-data-mysql >= 2.0.1-1.20.1
  • ibm-data-db2 >= 2.0.1-1.20.1
  • mono-core >= 2.0.1-1.20.1
  • mono-data >= 2.0.1-1.20.1
  • mono-data-firebird >= 2.0.1-1.20.1
  • mono-data-oracle >= 2.0.1-1.20.1
  • mono-data-postgresql >= 2.0.1-1.20.1
  • mono-data-sqlite >= 2.0.1-1.20.1
  • mono-data-sybase >= 2.0.1-1.20.1
  • mono-devel >= 2.0.1-1.20.1
  • mono-extras >= 2.0.1-1.20.1
  • mono-jscript >= 2.0.1-1.20.1
  • mono-locale-extras >= 2.0.1-1.20.1
  • mono-nunit >= 2.0.1-1.20.1
  • mono-web >= 2.0.1-1.20.1
  • mono-winforms >= 2.0.1-1.20.1
sles11.s390x
sles11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86
sled11.x86-64
sle11-sdk.ppc
sle11-sdk.x86-64
sles11.ppc
sled11.x86
SAT Patch Nr: 2326
SUSE Linux Enterprise Server 11 GA
  • mono-core >= 2.0.1-1.20.1
  • mono-data >= 2.0.1-1.20.1
  • mono-data-postgresql >= 2.0.1-1.20.1
  • mono-data-sqlite >= 2.0.1-1.20.1
  • mono-locale-extras >= 2.0.1-1.20.1
  • mono-nunit >= 2.0.1-1.20.1
  • mono-web >= 2.0.1-1.20.1
  • mono-winforms >= 2.0.1-1.20.1
sles11.s390x
sles11.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ia64
sle11-sdk.s390x
sle11-sdk.x86
sled11.x86-64
sle11-sdk.ppc
sle11-sdk.x86-64
sles11.ppc
sled11.x86
SAT Patch Nr: 2326
openSUSE 11.0
  • mono-core-debuginfo >= 1.9.1-6.8
  • mono-core-debugsource >= 1.9.1-6.8
openSUSE 11.0
  • bytefx-data-mysql >= 1.9.1-6.8
  • ibm-data-db2 >= 1.9.1-6.8
  • mono-complete >= 1.9.1-6.8
  • mono-core >= 1.9.1-6.8
  • mono-core-32bit >= 1.9.1-6.8
  • mono-data >= 1.9.1-6.8
  • mono-data-firebird >= 1.9.1-6.8
  • mono-data-oracle >= 1.9.1-6.8
  • mono-data-postgresql >= 1.9.1-6.8
  • mono-data-sqlite >= 1.9.1-6.8
  • mono-data-sybase >= 1.9.1-6.8
  • mono-devel >= 1.9.1-6.8
  • mono-extras >= 1.9.1-6.8
  • mono-jscript >= 1.9.1-6.8
  • mono-locale-extras >= 1.9.1-6.8
  • mono-nunit >= 1.9.1-6.8
  • mono-web >= 1.9.1-6.8
  • mono-winforms >= 1.9.1-6.8
  • monodoc-core >= 1.9-18.1
openSUSE 11.1
  • mono-core-debuginfo >= 2.0.1-1.23.1
  • mono-core-debuginfo-32bit >= 2.0.1-1.23.1
  • mono-core-debugsource >= 2.0.1-1.23.1
openSUSE 11.1
  • bytefx-data-mysql >= 2.0.1-1.23.1
  • ibm-data-db2 >= 2.0.1-1.23.1
  • mono-complete >= 2.0.1-1.23.1
  • mono-core >= 2.0.1-1.23.1
  • mono-core-32bit >= 2.0.1-1.23.1
  • mono-data >= 2.0.1-1.23.1
  • mono-data-firebird >= 2.0.1-1.23.1
  • mono-data-oracle >= 2.0.1-1.23.1
  • mono-data-postgresql >= 2.0.1-1.23.1
  • mono-data-sqlite >= 2.0.1-1.23.1
  • mono-data-sybase >= 2.0.1-1.23.1
  • mono-devel >= 2.0.1-1.23.1
  • mono-extras >= 2.0.1-1.23.1
  • mono-jscript >= 2.0.1-1.23.1
  • mono-locale-extras >= 2.0.1-1.23.1
  • mono-nunit >= 2.0.1-1.23.1
  • mono-web >= 2.0.1-1.23.1
  • mono-winforms >= 2.0.1-1.23.1
  • monodoc-core >= 2.0-1.42.1
openSUSE 11.2
  • mono-core-debuginfo >= 2.4.2.3-2.7.1
  • mono-core-debugsource >= 2.4.2.3-2.7.1
  • mono-devel-debuginfo >= 2.4.2.3-2.7.1
openSUSE 11.2
  • bytefx-data-mysql >= 2.4.2.3-2.7.1
  • ibm-data-db2 >= 2.4.2.3-2.7.1
  • mono-complete >= 2.4.2.3-2.7.1
  • mono-core >= 2.4.2.3-2.7.1
  • mono-data >= 2.4.2.3-2.7.1
  • mono-data-firebird >= 2.4.2.3-2.7.1
  • mono-data-oracle >= 2.4.2.3-2.7.1
  • mono-data-postgresql >= 2.4.2.3-2.7.1
  • mono-data-sqlite >= 2.4.2.3-2.7.1
  • mono-data-sybase >= 2.4.2.3-2.7.1
  • mono-devel >= 2.4.2.3-2.7.1
  • mono-extras >= 2.4.2.3-2.7.1
  • mono-jscript >= 2.4.2.3-2.7.1
  • mono-locale-extras >= 2.4.2.3-2.7.1
  • mono-nunit >= 2.4.2.3-2.7.1
  • mono-wcf >= 2.4.2.3-2.7.1
  • mono-web >= 2.4.2.3-2.7.1
  • mono-winforms >= 2.4.2.3-2.7.1
  • monodoc-core >= 2.4.2.3-2.7.1
SUSE Linux Enterprise 10 SP2 Mono Extension
  • mono-addon-bytefx-data-mysql >= 2.4.2.3-0.4.8
  • mono-addon-core >= 2.4.2.3-0.4.8
  • mono-addon-core-debuginfo >= 2.4.2.3-0.4.8
  • mono-addon-data >= 2.4.2.3-0.4.8
  • mono-addon-data-firebird >= 2.4.2.3-0.4.8
  • mono-addon-data-oracle >= 2.4.2.3-0.4.8
  • mono-addon-data-postgresql >= 2.4.2.3-0.4.8
  • mono-addon-data-sqlite >= 2.4.2.3-0.4.8
  • mono-addon-data-sybase >= 2.4.2.3-0.4.8
  • mono-addon-devel >= 2.4.2.3-0.4.8
  • mono-addon-extras >= 2.4.2.3-0.4.8
  • mono-addon-ibm-data-db2 >= 2.4.2.3-0.4.8
  • mono-addon-jscript >= 2.4.2.3-0.4.8
  • mono-addon-locale-extras >= 2.4.2.3-0.4.8
  • mono-addon-nunit >= 2.4.2.3-0.4.8
  • mono-addon-wcf >= 2.4.2.3-0.4.8
  • mono-addon-web >= 2.4.2.3-0.4.8
  • mono-addon-winforms >= 2.4.2.3-0.4.8
  • monodoc-addon-core >= 2.4.2.3-0.4.8
sle-mono-debuginfo.x86-64
sle-mono-debuginfo.s390x
sle-mono-debuginfo.x86
ZYPP Patch Nr: 6996
SUSE Linux Enterprise Software Development Kit 11 SP1
  • bytefx-data-mysql >= 2.0.1-1.26.1
  • mono-data-firebird >= 2.0.1-1.26.1
  • mono-data-oracle >= 2.0.1-1.26.1
  • mono-data-sybase >= 2.0.1-1.26.1
  • mono-devel >= 2.0.1-1.26.1
  • mono-extras >= 2.0.1-1.26.1
  • mono-jscript >= 2.0.1-1.26.1
sles11-sp1.ia64
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.ppc
sles11-sp1.x86-64
sled11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.s390x
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
SAT Patch Nr: 2474
SUSE Linux Enterprise Software Development Kit 11 SP1
  • bytefx-data-mysql >= 2.0.1-1.26.1
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-firebird >= 2.0.1-1.26.1
  • mono-data-oracle >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-data-sybase >= 2.0.1-1.26.1
  • mono-devel >= 2.0.1-1.26.1
  • mono-extras >= 2.0.1-1.26.1
  • mono-jscript >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
sles11-sp1.ia64
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.ppc
sles11-sp1.x86-64
sled11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.s390x
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
SAT Patch Nr: 2474
SUSE Linux Enterprise Desktop 11 SP1
  • bytefx-data-mysql >= 2.0.1-1.26.1
  • ibm-data-db2 >= 2.0.1-1.26.1
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-firebird >= 2.0.1-1.26.1
  • mono-data-oracle >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-data-sybase >= 2.0.1-1.26.1
  • mono-devel >= 2.0.1-1.26.1
  • mono-extras >= 2.0.1-1.26.1
  • mono-jscript >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
sles11-sp1.ia64
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.ppc
sles11-sp1.x86-64
sled11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.s390x
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
SAT Patch Nr: 2474
SUSE Linux Enterprise Server 11 SP1
  • mono-core >= 2.0.1-1.26.1
  • mono-data >= 2.0.1-1.26.1
  • mono-data-postgresql >= 2.0.1-1.26.1
  • mono-data-sqlite >= 2.0.1-1.26.1
  • mono-locale-extras >= 2.0.1-1.26.1
  • mono-nunit >= 2.0.1-1.26.1
  • mono-web >= 2.0.1-1.26.1
  • mono-winforms >= 2.0.1-1.26.1
sles11-sp1.ia64
sle11-sp1-sdk.x86-64
sled11-sp1.x86-64
sles11-sp1.ia64
sled11-sp1.x86
sle11-sp1-sdk.s390x
sles11-sp1.ppc
sles11-sp1.x86-64
sled11-sp1.x86
sle11-sp1-sdk.x86
sle11-sp1-sdk.ia64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.s390x
sle11-sp1-sdk.s390x
sles11-sp1.s390x
sle11-sp1-sdk.ia64
sles11-sp1.x86-64
sles11-sp1.ppc
sled11-sp1.x86-64
sles11-sp1.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86
sle11-sp1-sdk.x86
SAT Patch Nr: 2474


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 mono-core Affected
SUSE Linux Enterprise Desktop 10 SP4 mono-core Affected
SUSE Linux Enterprise Desktop 11 GA mono-core Released
SUSE Linux Enterprise Desktop 11 SP1 mono-core Released
SUSE Linux Enterprise SDK 11 GA mono-core Released
SUSE Linux Enterprise SDK 11 SP1 mono-core Released
SUSE Linux Enterprise Server 10 SP3 mono-core Affected
SUSE Linux Enterprise Server 10 SP4 mono-core Affected
SUSE Linux Enterprise Server 10 SP4 LTSS mono-core Affected
SUSE Linux Enterprise Server 11 SP1 mono-core Released
SUSE Linux Enterprise Server 11 SP1 LTSS mono-core Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 mono-core Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 mono-core Released