Upstream information

CVE-2009-4492 at MITRE

Description

WEBrick 1.3.1 in Ruby 1.8.6 through patchlevel 383, 1.8.7 through patchlevel 248, 1.8.8dev, 1.9.1 through patchlevel 376, and 1.9.2dev writes data to a log file without sanitizing non-printable characters, which might allow remote attackers to modify a window's title, or possibly execute arbitrary commands or overwrite files, via an HTTP request containing an escape sequence for a terminal emulator.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 570616 [RESOLVED / FIXED], 580482 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Desktop 12 GA ruby
SUSE Linux Enterprise Desktop 12 SP1
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA ruby
SUSE Linux Enterprise Desktop 12 SP2
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA ruby
SUSE Linux Enterprise Desktop 12 SP3
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA ruby
SUSE Linux Enterprise Server 11 SP1
  • ruby >= 1.8.7.p72-5.28.1
  • ruby-doc-html >= 1.8.7.p72-5.28.1
  • ruby-tk >= 1.8.7.p72-5.28.1
Patchnames:
slessp1-ruby
SUSE Linux Enterprise Server 11 SP2
  • ruby >= 1.8.7.p357-0.7.1
  • ruby-doc-html >= 1.8.7.p357-0.7.1
  • ruby-tk >= 1.8.7.p357-0.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ruby
SUSE Linux Enterprise Server 11 SP3
  • ruby >= 1.8.7.p357-0.9.9.1
  • ruby-doc-html >= 1.8.7.p357-0.9.9.1
  • ruby-tk >= 1.8.7.p357-0.9.9.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ruby
SUSE Linux Enterprise Server 11 SP4
  • ruby >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ruby
SUSE Linux Enterprise Server 12
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Server 12 GA ruby
SUSE Linux Enterprise Server 12 SP1
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA ruby
SUSE Linux Enterprise Server 12 SP2
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA ruby
SUSE Linux Enterprise Server 12 SP3
  • ruby >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA ruby
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • ruby >= 2.1-1.4
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA ruby
SUSE Linux Enterprise Software Development Kit 11 SP4
  • ruby-devel >= 1.8.7.p357-0.9.17.1
  • ruby-doc-html >= 1.8.7.p357-0.9.17.1
  • ruby-doc-ri >= 1.8.7.p357-0.9.17.1
  • ruby-examples >= 1.8.7.p357-0.9.17.1
  • ruby-test-suite >= 1.8.7.p357-0.9.17.1
  • ruby-tk >= 1.8.7.p357-0.9.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA ruby-devel
SUSE Linux Enterprise Software Development Kit 12
  • ruby-devel >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA ruby-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • ruby-devel >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA ruby-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • ruby-devel >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA ruby-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • ruby-devel >= 2.1-1.6
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA ruby-devel
SUSE Linux Enterprise Software Development Kit 11 SP1
  • ruby-devel >= 1.8.7.p72-5.28.1
  • ruby-doc-html >= 1.8.7.p72-5.28.1
  • ruby-doc-ri >= 1.8.7.p72-5.28.1
  • ruby-examples >= 1.8.7.p72-5.28.1
  • ruby-test-suite >= 1.8.7.p72-5.28.1
  • ruby-tk >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
SUSE Linux Enterprise Software Development Kit 11 SP1
  • ruby-devel >= 1.8.7.p72-5.28.1
  • ruby-doc-ri >= 1.8.7.p72-5.28.1
  • ruby-examples >= 1.8.7.p72-5.28.1
  • ruby-test-suite >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
SUSE Lifecycle Management Server 1.1 [Appliance - Tools]
  • ruby >= 1.8.7.p72-5.28.1
  • ruby-devel >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
SUSE Studio Onsite 1.1 [Appliance - Studio]
  • ruby-devel >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
SUSE Linux Enterprise Desktop 11 SP1
  • ruby >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • ruby >= 1.8.7.p72-5.28.1
  • ruby-doc-html >= 1.8.7.p72-5.28.1
  • ruby-tk >= 1.8.7.p72-5.28.1
studioonsite1.1.x86-64
sle11-sp1-sdk.ia64
sle11-sp1-sdk.s390x
sles11-sp1-vmware.x86-64
sles11-sp1-vmware.x86
sles11-sp1.s390x
webyast11.x86-64
sle11-sp1-sdk.x86
webyast11.x86
sle11-sp1-sdk.ppc
sles11-sp1.x86-64
sled11-sp1.x86
slms1.1.x86-64
sles11-sp1.x86
sled11-sp1.x86-64
sle11-sp1-sdk.x86-64
sles11-sp1.ppc
sles11-sp1.ia64
SAT Patch Nr: 4585
openSUSE Leap 42.1
  • ruby >= 2.1-3.2
  • ruby-devel >= 2.1-3.2
Patchnames:
openSUSE Leap 42.1 GA ruby
openSUSE Leap 42.2
  • ruby >= 2.1-4.2
  • ruby-devel >= 2.1-4.2
Patchnames:
openSUSE Leap 42.2 GA ruby
openSUSE Leap 42.3
  • ruby >= 2.1-6.4
  • ruby-devel >= 2.1-6.4
Patchnames:
openSUSE Leap 42.3 GA ruby


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Lifecycle Management Server 1.3 ruby Released
SUSE Linux Enterprise Desktop 10 SP3 ruby Affected
SUSE Linux Enterprise Desktop 10 SP4 ruby Released
SUSE Linux Enterprise Desktop 11 GA ruby Affected
SUSE Linux Enterprise Desktop 11 SP1 ruby Released
SUSE Linux Enterprise SDK 11 GA ruby Affected
SUSE Linux Enterprise SDK 11 SP1 ruby Released
SUSE Linux Enterprise Server 11 GA ruby Affected
SUSE Linux Enterprise Server 11 SP1 ruby Released
SUSE Linux Enterprise Server 11 SP1 LTSS ruby Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ruby Released
SUSE Studio Onsite 1.3 ruby Released