Upstream information

CVE-2009-4355 at MITRE

Description

Memory leak in the zlib_stateful_finish function in crypto/comp/c_zlib.c in OpenSSL 0.9.8l and earlier and 1.0.0 Beta through Beta 4 allows remote attackers to cause a denial of service (memory consumption) via vectors that trigger incorrect calls to the CRYPTO_cleanup_all_ex_data function, as demonstrated by use of SSLv3 and PHP with the Apache HTTP Server, a related issue to CVE-2008-1678.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entries: 459468 [RESOLVED / FIXED], 552497 [CLOSED / DUPLICATE], 566238 [RESOLVED / FIXED], 629905 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libopenssl0_9_8 >= 0.9.8j-59.11
  • libopenssl0_9_8-32bit >= 0.9.8j-59.11
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libopenssl0_9_8
SUSE Linux Enterprise Desktop 12 SP1
  • libopenssl0_9_8 >= 0.9.8j-81.1
  • libopenssl0_9_8-32bit >= 0.9.8j-81.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libopenssl0_9_8
SUSE Linux Enterprise Desktop 12 SP2
  • libopenssl0_9_8 >= 0.9.8j-102.1
  • libopenssl0_9_8-32bit >= 0.9.8j-102.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libopenssl0_9_8
SUSE Linux Enterprise Desktop 12 SP3
  • libopenssl0_9_8 >= 0.9.8j-105.1
  • libopenssl0_9_8-32bit >= 0.9.8j-105.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libopenssl0_9_8
SUSE Linux Enterprise Module for Legacy Software 12
  • libopenssl0_9_8 >= 0.9.8j-59.11
  • libopenssl0_9_8-32bit >= 0.9.8j-59.11
Patchnames:
SUSE Linux Enterprise Module for Legacy Software 12 GA libopenssl0_9_8
SUSE Linux Enterprise Server 11
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.18.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
  • openssl-doc >= 0.9.8h-30.18.1
Patchnames:
slessp0-openssl-CVE-2009-4355.patch
SUSE Linux Enterprise Server 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.27.11
  • libopenssl0_9_8-32bit >= 0.9.8h-30.27.11
  • libopenssl0_9_8-x86 >= 0.9.8h-30.27.11
  • openssl >= 0.9.8h-30.27.11
  • openssl-doc >= 0.9.8h-30.27.11
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libopenssl0_9_8
SUSE Linux Enterprise Server 11 SP2
  • libopenssl0_9_8 >= 0.9.8j-0.26.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.26.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.26.1
  • openssl >= 0.9.8j-0.26.1
  • openssl-doc >= 0.9.8j-0.26.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libopenssl0_9_8
SUSE Linux Enterprise Server 11 SP3
  • libopenssl0_9_8 >= 0.9.8j-0.50.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.50.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.50.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.50.1
  • openssl >= 0.9.8j-0.50.1
  • openssl-doc >= 0.9.8j-0.50.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libopenssl0_9_8
SUSE Linux Enterprise Server 11 SP4
  • libopenssl0_9_8 >= 0.9.8j-0.70.1
  • libopenssl0_9_8-32bit >= 0.9.8j-0.70.1
  • libopenssl0_9_8-hmac >= 0.9.8j-0.70.1
  • libopenssl0_9_8-hmac-32bit >= 0.9.8j-0.70.1
  • libopenssl0_9_8-x86 >= 0.9.8j-0.70.1
  • openssl >= 0.9.8j-0.70.1
  • openssl-doc >= 0.9.8j-0.70.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libopenssl0_9_8
SUSE Linux Enterprise Server for SAP Applications 11
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.18.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
  • openssl-doc >= 0.9.8h-30.18.1
Patchnames:
slessp0-openssl-CVE-2009-4355.patch
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libopenssl-devel >= 0.9.8j-0.70.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libopenssl-devel
openSUSE 11.1
  • openssl-debuginfo >= 0.9.8h-28.13.1
  • openssl-debugsource >= 0.9.8h-28.13.1
openSUSE 11.1
  • libopenssl-devel >= 0.9.8h-28.13.1
  • libopenssl0_9_8 >= 0.9.8h-28.13.1
  • libopenssl0_9_8-32bit >= 0.9.8h-28.13.1
  • libopenssl0_9_8-64bit >= 0.9.8h-28.13.1
  • openssl >= 0.9.8h-28.13.1
  • openssl-doc >= 0.9.8h-28.13.1
SUSE Linux Enterprise SDK 11 GA
  • libopenssl-devel >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
  • openssl-doc >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
  • openssl-doc >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.18.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.18.1
  • openssl >= 0.9.8h-30.18.1
  • openssl-doc >= 0.9.8h-30.18.1
sle11-sdk.s390x
sle11-debuginfo.s390x
sled11.x86-64
sles11.x86
sles11.ppc
sle11-debuginfo.x86
sles11.x86-64
sled11.x86
sle11-debuginfo.x86-64
sle11-sdk.ia64
sles11.ia64
sle11-sdk.x86
sle11-sdk.x86-64
sle11-sdk.ppc
sle11-debuginfo.ppc
sle11-debuginfo.ia64
sles11.s390x
SAT Patch Nr: 1810
SUSE Linux Enterprise Server for SAP 10 SP2
  • openssl >= 0.9.8a-18.39.3
  • openssl-32bit >= 0.9.8a-18.39.3
  • openssl-devel >= 0.9.8a-18.39.3
  • openssl-devel-32bit >= 0.9.8a-18.39.3
  • openssl-doc >= 0.9.8a-18.39.3
sle10-sp2-sdk.ia64
sles10-sp2.ia64
sled10-sp2.x86-64
sled10-sp2.x86
sles10-sp2.s390x
sles10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ia64
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.s390x
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.x86-64
sles10-sp2.ppc
sles10-sp2-debuginfo.x86
sle10-sp2-sdk.x86
sles10-sp2.x86
ZYPP Patch Nr: 6784
SUSE Linux Enterprise SDK 10 SP2
  • openssl-doc >= 0.9.8a-18.39.3
sle10-sp2-sdk.ia64
sles10-sp2.ia64
sled10-sp2.x86-64
sled10-sp2.x86
sles10-sp2.s390x
sles10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ia64
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.s390x
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.x86-64
sles10-sp2-debuginfo.x86-64
sles10-sp2.ppc
sles10-sp2-debuginfo.x86
sle10-sp2-sdk.x86
sles10-sp2.x86
ZYPP Patch Nr: 6784
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • openssl >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.40.1
  • openssl-32bit >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
  • openssl-devel-32bit >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise SDK 10 SP3
  • openssl-doc >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
  • openssl-doc >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
  • openssl-doc >= 0.9.8a-18.40.1
  • openssl-x86 >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.40.1
  • openssl-64bit >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
  • openssl-devel-64bit >= 0.9.8a-18.40.1
  • openssl-doc >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.40.1
  • openssl-32bit >= 0.9.8a-18.40.1
  • openssl-devel >= 0.9.8a-18.40.1
  • openssl-devel-32bit >= 0.9.8a-18.40.1
  • openssl-doc >= 0.9.8a-18.40.1
sle10-sp3-sdk.s390x
sles10-sp3.ia64
sles10-sp3-debuginfo.x86-64
sled10-sp3.x86
sle10-sp3-sdk.x86-64
sle10-sp3-sdk.x86
sles10-sp3-debuginfo.ppc
sles10-sp3.ppc
sled10-sp3.x86-64
sles10-sp3.x86
sle10-sp3-sdk.ppc
sles10-sp3.x86-64
sle10-sp3-sdk.ia64
sles10-sp3.s390x
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86
sles10-sp3-debuginfo.ia64
ZYPP Patch Nr: 6783
openSUSE 11.0
  • openssl-debuginfo >= 0.9.8g-47.12
  • openssl-debugsource >= 0.9.8g-47.12
openSUSE 11.0
  • libopenssl-devel >= 0.9.8g-47.12
  • libopenssl0_9_8 >= 0.9.8g-47.12
  • libopenssl0_9_8-32bit >= 0.9.8g-47.12
  • libopenssl0_9_8-64bit >= 0.9.8g-47.12
  • openssl >= 0.9.8g-47.12
  • openssl-certs >= 0.9.8g-47.12
  • openssl-doc >= 0.9.8g-47.12
openSUSE 11.2
  • libopenssl0_9_8-debuginfo >= 0.9.8k-3.6.1
  • libopenssl0_9_8-debuginfo-32bit >= 0.9.8k-3.6.1
  • openssl-debuginfo >= 0.9.8k-3.6.1
  • openssl-debugsource >= 0.9.8k-3.6.1
openSUSE 11.2
  • libopenssl-devel >= 0.9.8k-3.6.1
  • libopenssl0_9_8 >= 0.9.8k-3.6.1
  • libopenssl0_9_8-32bit >= 0.9.8k-3.6.1
  • openssl >= 0.9.8k-3.6.1
  • openssl-certs >= 0.9.8h-28.2.1
  • openssl-doc >= 0.9.8k-3.6.1


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 openssl Released
SUSE Linux Enterprise Desktop 11 GA openssl Released
SUSE Linux Enterprise SDK 11 GA openssl Released
SUSE Linux Enterprise Server 10 SP3 openssl Released
SUSE Linux Enterprise Server 11 GA openssl Released