Upstream information

CVE-2009-4009 at MITRE

Description

Buffer overflow in PowerDNS Recursor before 3.1.7.2 allows remote attackers to cause a denial of service (daemon crash) or possibly execute arbitrary code via crafted packets.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 567990 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • pdns-recursor-debuginfo >= 3.1.5-14.4
  • pdns-recursor-debugsource >= 3.1.5-14.4
openSUSE 11.0
  • pdns-recursor >= 3.1.5-14.4
openSUSE 11.1
  • pdns-recursor-debuginfo >= 3.1.7-6.10.1
  • pdns-recursor-debugsource >= 3.1.7-6.10.1
openSUSE 11.1
  • pdns-recursor >= 3.1.7-6.10.1
openSUSE 11.2
  • pdns-recursor-debuginfo >= 3.1.7-8.4.1
  • pdns-recursor-debugsource >= 3.1.7-8.4.1
openSUSE 11.2
  • pdns-recursor >= 3.1.7-8.4.1
openSUSE Tumbleweed
  • pdns-recursor >= 4.0.3-1.2
Patchnames:
openSUSE Tumbleweed GA pdns-recursor