Upstream information

CVE-2009-3996 at MITRE

Description

Heap-based buffer overflow in IN_MOD.DLL (aka the Module Decoder Plug-in) in Winamp before 5.57, and libmikmod 3.1.12, might allow remote attackers to execute arbitrary code via an Ultratracker file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 577875 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libmikmod3
SUSE Linux Enterprise Desktop 12 SP1
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libmikmod3
SUSE Linux Enterprise Desktop 12 SP2
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libmikmod3
SUSE Linux Enterprise Desktop 12 SP3
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libmikmod3
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libmikmod >= 3.1.11a-116.2.1
  • libmikmod-devel >= 3.1.11a-116.2.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libmikmod
SUSE Linux Enterprise Software Development Kit 12
  • libmikmod-devel >= 3.2.0-4.59
  • libmikmod3 >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libmikmod-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libmikmod-devel >= 3.2.0-4.59
  • libmikmod3 >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libmikmod-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libmikmod-devel >= 3.2.0-4.59
  • libmikmod3 >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libmikmod-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libmikmod-devel >= 3.2.0-4.59
  • libmikmod3 >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libmikmod-devel
SUSE Linux Enterprise Workstation Extension 12
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 GA libmikmod3
SUSE Linux Enterprise Workstation Extension 12 SP1
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP1 GA libmikmod3
SUSE Linux Enterprise Workstation Extension 12 SP2
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP2 GA libmikmod3
SUSE Linux Enterprise Workstation Extension 12 SP3
  • libmikmod3 >= 3.2.0-4.59
  • libmikmod3-32bit >= 3.2.0-4.59
Patchnames:
SUSE Linux Enterprise Workstation Extension 12 SP3 GA libmikmod3
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • libmikmod >= 3.1.11-14.10.1
sles10-sp3.ppc
sles10-sp3.ia64
sles10-sp3.x86
sled10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7004
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • libmikmod >= 3.1.11-14.10.1
  • libmikmod-32bit >= 3.1.11-14.10.1
sles10-sp3.ppc
sles10-sp3.ia64
sles10-sp3.x86
sled10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7004
SUSE Linux Enterprise Server 10 SP3
  • libmikmod >= 3.1.11-14.10.1
  • libmikmod-x86 >= 3.1.11-14.10.1
sles10-sp3.ppc
sles10-sp3.ia64
sles10-sp3.x86
sled10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7004
SUSE Linux Enterprise Server 10 SP3
  • libmikmod >= 3.1.11-14.10.1
  • libmikmod-64bit >= 3.1.11-14.10.1
sles10-sp3.ppc
sles10-sp3.ia64
sles10-sp3.x86
sled10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3.x86-64
sled10-sp3.x86
ZYPP Patch Nr: 7004
SUSE Linux Enterprise SDK 11 GA
  • libmikmod >= 3.1.11a-116.2.1
  • libmikmod-devel >= 3.1.11a-116.2.1
sle11-sdk.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.s390x
sled11.x86-64
sled11.x86
sle11-sdk.ia64
SAT Patch Nr: 2354
SUSE Linux Enterprise Desktop 11 GA
  • libmikmod >= 3.1.11a-116.2.1
sle11-sdk.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.s390x
sled11.x86-64
sled11.x86
sle11-sdk.ia64
SAT Patch Nr: 2354
SUSE Linux Enterprise Desktop 11 GA
  • libmikmod >= 3.1.11a-116.2.1
  • libmikmod-32bit >= 3.1.11a-116.2.1
sle11-sdk.x86-64
sle11-sdk.x86
sle11-sdk.ppc
sle11-sdk.s390x
sled11.x86-64
sled11.x86
sle11-sdk.ia64
SAT Patch Nr: 2354
openSUSE 11.0
  • libmikmod-debuginfo >= 3.1.11a-84.5
  • libmikmod-debugsource >= 3.1.11a-84.5
openSUSE 11.0
  • libmikmod >= 3.1.11a-84.5
  • libmikmod-32bit >= 3.1.11a-84.5
  • libmikmod-64bit >= 3.1.11a-84.5
  • libmikmod-devel >= 3.1.11a-84.5
openSUSE 11.1
  • libmikmod-debuginfo >= 3.1.11a-71.57.1
  • libmikmod-debuginfo-32bit >= 3.1.11a-71.57.1
  • libmikmod-debuginfo-64bit >= 3.1.11a-71.57.1
  • libmikmod-debugsource >= 3.1.11a-71.57.1
openSUSE 11.1
  • libmikmod >= 3.1.11a-71.57.1
  • libmikmod-32bit >= 3.1.11a-71.57.1
  • libmikmod-64bit >= 3.1.11a-71.57.1
  • libmikmod-devel >= 3.1.11a-71.57.1
openSUSE 11.2
  • libmikmod-debuginfo >= 3.1.11a-118.2.1
  • libmikmod-debuginfo-32bit >= 3.1.11a-118.2.1
  • libmikmod-debugsource >= 3.1.11a-118.2.1
openSUSE 11.2
  • libmikmod >= 3.1.11a-118.2.1
  • libmikmod-32bit >= 3.1.11a-118.2.1
  • libmikmod-devel >= 3.1.11a-118.2.1
openSUSE Leap 42.1
  • libmikmod3 >= 3.3.7-3.2
Patchnames:
openSUSE Leap 42.1 GA libmikmod3
openSUSE Leap 42.2
  • libmikmod3 >= 3.3.7-4.5
Patchnames:
openSUSE Leap 42.2 GA libmikmod3
openSUSE Leap 42.3
  • libmikmod3 >= 3.3.7-6.3
Patchnames:
openSUSE Leap 42.3 GA libmikmod3
openSUSE Tumbleweed
  • libmikmod-devel >= 3.3.7-1.7
  • libmikmod3 >= 3.3.7-1.7
  • libmikmod3-32bit >= 3.3.7-1.7
Patchnames:
openSUSE Tumbleweed GA libmikmod-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 libmikmod Released
SUSE Linux Enterprise Desktop 10 SP4 libmikmod Released
SUSE Linux Enterprise Desktop 11 GA libmikmod Released
SUSE Linux Enterprise Desktop 11 SP1 libmikmod Released
SUSE Linux Enterprise Desktop 11 SP2 libmikmod Released
SUSE Linux Enterprise Desktop 11 SP3 libmikmod Released
SUSE Linux Enterprise Desktop 11 SP4 libmikmod Released
SUSE Linux Enterprise SDK 11 GA libmikmod Released
SUSE Linux Enterprise SDK 11 SP1 libmikmod Released
SUSE Linux Enterprise SDK 11 SP2 libmikmod Released
SUSE Linux Enterprise SDK 11 SP3 libmikmod Released
SUSE Linux Enterprise SDK 11 SP4 libmikmod Released
SUSE Linux Enterprise Server 10 SP3 libmikmod Released
SUSE Linux Enterprise Server 10 SP4 libmikmod Released
SUSE Linux Enterprise Server 10 SP4 LTSS libmikmod Released