Upstream information

CVE-2009-3889 at MITRE

Description

The dbg_lvl file for the megaraid_sas driver in the Linux kernel before 2.6.27 has world-writable permissions, which allows local users to change the (1) behavior and (2) logging level of the driver by modifying this file.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.6
Vector AV:L/AC:L/Au:N/C:N/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 555173 [RESOLVED / FIXED], 557180 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise SDK 10 SP2
  • kernel-kdump >= 2.6.16.60-0.42.8
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ppc
sles10-sp2.ppc
ZYPP Patch Nr: 6728
SUSE Linux Enterprise SDK 10 SP2
  • kernel-debug >= 2.6.16.60-0.42.8
sle10-sp2-sdk.ia64
sles10-sp2.ia64
sles10-sp2-debuginfo.ia64
ZYPP Patch Nr: 6727
Open Enterprise Server
  • kernel-bigsmp >= 2.6.5-7.322
  • kernel-debug >= 2.6.5-7.322
  • kernel-default >= 2.6.5-7.322
  • kernel-smp >= 2.6.5-7.322
  • kernel-source >= 2.6.5-7.322
  • kernel-syms >= 2.6.5-7.322
  • kernel-um >= 2.6.5-7.322
  • kernel-xen >= 2.6.5-7.322
  • kernel-xenpae >= 2.6.5-7.322
  • um-host-install-initrd >= 1.0-48.35
  • um-host-kernel >= 2.6.5-7.322
  • xen-kmp >= 3.0.4_2.6.5_7.322-0.2
sles9-oes.x86
YOU Patch Nr: 12584
SUSE Linux Enterprise SDK 10 SP2
  • kernel-debug >= 2.6.16.60-0.42.8
  • kernel-kdump >= 2.6.16.60-0.42.8
  • kernel-xen >= 2.6.16.60-0.42.8
  • kernel-xenpae >= 2.6.16.60-0.42.8
sles10-sp2-debuginfo.x86
sle10-sp2-sdk.x86
sled10-sp2.x86
sles10-sp2.x86
ZYPP Patch Nr: 6726
SUSE Linux Enterprise Server for SAP 10 SP2
  • kernel-debug >= 2.6.16.60-0.42.8
  • kernel-default >= 2.6.16.60-0.42.8
  • kernel-kdump >= 2.6.16.60-0.42.8
  • kernel-smp >= 2.6.16.60-0.42.8
  • kernel-source >= 2.6.16.60-0.42.8
  • kernel-syms >= 2.6.16.60-0.42.8
  • kernel-xen >= 2.6.16.60-0.42.8
sled10-sp2.x86-64
sles10-sp2-debuginfo.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.x86-64
ZYPP Patch Nr: 6730
SUSE Linux Enterprise SDK 10 SP2
  • kernel-debug >= 2.6.16.60-0.42.8
  • kernel-kdump >= 2.6.16.60-0.42.8
  • kernel-xen >= 2.6.16.60-0.42.8
sled10-sp2.x86-64
sles10-sp2-debuginfo.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.x86-64
ZYPP Patch Nr: 6730