Upstream information

CVE-2009-3617 at MITRE

Description

Format string vulnerability in the AbstractCommand::onAbort function in src/AbstractCommand.cc in aria2 before 1.6.2, when logging is enabled, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via format string specifiers in a download URI. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.6
Vector AV:N/AC:H/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 547318 [RESOLVED / FIXED], 573072 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Leap 42.1
  • aria2 >= 1.19.0-7.4
  • aria2-lang >= 1.19.0-7.4
Patchnames:
openSUSE Leap 42.1 GA aria2
openSUSE Leap 42.2
  • aria2 >= 1.24.0-1.1
  • aria2-lang >= 1.24.0-1.1
  • libaria2-0 >= 1.24.0-1.1
Patchnames:
openSUSE Leap 42.2 GA aria2
openSUSE Leap 42.3
  • aria2 >= 1.24.0-3.2
  • aria2-lang >= 1.24.0-3.2
  • libaria2-0 >= 1.24.0-3.2
Patchnames:
openSUSE Leap 42.3 GA aria2
openSUSE Tumbleweed
  • aria2 >= 1.29.0-1.1
  • aria2-devel >= 1.29.0-1.1
  • aria2-lang >= 1.29.0-1.1
  • libaria2-0 >= 1.29.0-1.1
Patchnames:
openSUSE Tumbleweed GA aria2