Upstream information

CVE-2009-3229 at MITRE


The core server component in PostgreSQL 8.4 before 8.4.1, 8.3 before 8.3.8, and 8.2 before 8.2.14 allows remote authenticated users to cause a denial of service (backend shutdown) by "re-LOAD-ing" libraries from a certain plugins directory.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4
Vector AV:N/AC:L/Au:S/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication Single
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 537706 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • postgresql >= 8.3.8-0.1.1
  • postgresql-contrib >= 8.3.8-0.1.1
  • postgresql-docs >= 8.3.8-0.1.1
  • postgresql-libs >= 8.3.8-0.1.1
  • postgresql-libs-32bit >= 8.3.8-0.1.1
  • postgresql-libs-x86 >= 8.3.8-0.1.1
  • postgresql-server >= 8.3.8-0.1.1

Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 postgresql Released
SLES-10-SP3 postgresql Released
SUSE Linux Enterprise Desktop 11 postgresql Released