Upstream information

CVE-2009-2474 at MITRE

Description

neon before 0.28.6, when OpenSSL or GnuTLS is used, does not properly handle a '\0' character in a domain name in the subject's Common Name (CN) field of an X.509 certificate, which allows man-in-the-middle attackers to spoof arbitrary SSL servers via a crafted certificate issued by a legitimate Certification Authority, a related issue to CVE-2009-2408.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 528370 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • libneon27 >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Desktop 12 GA libneon27
SUSE Linux Enterprise Desktop 12 SP1
  • libneon27 >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA libneon27
SUSE Linux Enterprise Desktop 12 SP2
  • libneon27 >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA libneon27
SUSE Linux Enterprise Desktop 12 SP3
  • libneon27 >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA libneon27
SUSE Linux Enterprise Module for Basesystem 15
  • libneon-devel >= 0.30.2-2.15
  • libneon27 >= 0.30.2-2.15
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA libneon-devel
SUSE Linux Enterprise Server 11 SP1
  • libneon27 >= 0.28.3-2.12.1
  • libneon27-32bit >= 0.28.3-2.12.1
  • libneon27-x86 >= 0.28.3-2.12.1
  • neon >= 0.28.3-2.12.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libneon27
SUSE Linux Enterprise Server 11 SP2
  • libneon27 >= 0.29.6-6.7.1
  • libneon27-32bit >= 0.29.6-6.7.1
  • libneon27-x86 >= 0.29.6-6.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libneon27
SUSE Linux Enterprise Server 11 SP3
  • libneon27 >= 0.29.6-6.7.1
  • libneon27-32bit >= 0.29.6-6.7.1
  • libneon27-x86 >= 0.29.6-6.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libneon27
SUSE Linux Enterprise Server 11 SP4
  • libneon27 >= 0.29.6-6.7.1
  • libneon27-32bit >= 0.29.6-6.7.1
  • libneon27-x86 >= 0.29.6-6.7.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libneon27
SUSE Linux Enterprise Server 12
  • libneon27 >= 0.30.0-3.65
  • libneon27-32bit >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Server 12 GA libneon27
SUSE Linux Enterprise Server 12 SP1
  • libneon27 >= 0.30.0-3.65
  • libneon27-32bit >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA libneon27
SUSE Linux Enterprise Server 12 SP2
  • libneon27 >= 0.30.0-3.65
  • libneon27-32bit >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA libneon27
SUSE Linux Enterprise Server 12 SP3
  • libneon27 >= 0.30.0-3.65
  • libneon27-32bit >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA libneon27
SUSE Linux Enterprise Server 12 SP4
  • libneon27 >= 0.30.0-3.65
  • libneon27-32bit >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Server 12 SP4 GA libneon27
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • libneon27 >= 0.30.0-3.64
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA libneon27
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libneon-devel >= 0.29.6-6.7.1
  • libneon27-32bit >= 0.29.6-6.7.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libneon-devel
SUSE Linux Enterprise Software Development Kit 12
  • libneon-devel >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libneon-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libneon-devel >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libneon-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libneon-devel >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libneon-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libneon-devel >= 0.30.0-3.65
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libneon-devel
openSUSE Leap 15.0
  • libneon27 >= 0.30.2-lp150.2.2
Patchnames:
openSUSE Leap 15.0 GA libneon27
openSUSE Leap 42.1
  • libneon27 >= 0.30.1-2.9
Patchnames:
openSUSE Leap 42.1 GA libneon27
openSUSE Leap 42.2
  • libneon27 >= 0.30.1-3.30
Patchnames:
openSUSE Leap 42.2 GA libneon27
openSUSE Leap 42.3
  • libneon27 >= 0.30.1-5.6
Patchnames:
openSUSE Leap 42.3 GA libneon27
openSUSE Tumbleweed
  • libneon-devel >= 0.30.1-1.11
  • libneon27 >= 0.30.1-1.11
  • libneon27-32bit >= 0.30.1-1.11
Patchnames:
openSUSE Tumbleweed GA libneon-devel


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 neon Released
SUSE Linux Enterprise Desktop 10 SP4 neon Released
SUSE Linux Enterprise Desktop 11 GA neon Released
SUSE Linux Enterprise SDK 11 GA neon Released
SUSE Linux Enterprise Server 10 SP3 neon Released
SUSE Linux Enterprise Server 10 SP4 neon Released
SUSE Linux Enterprise Server 10 SP4 LTSS neon Released
SUSE Linux Enterprise Server 11 GA neon Released