Upstream information

CVE-2009-1932 at MITRE

Description

Multiple integer overflows in the (1) user_info_callback, (2) user_endrow_callback, and (3) gst_pngdec_task functions (ext/libpng/gstpngdec.c) in GStreamer Good Plug-ins (aka gst-plugins-good or gstreamer-plugins-good) 0.10.15 allow remote attackers to cause a denial of service and possibly execute arbitrary code via a crafted PNG file, which triggers a buffer overflow.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 510292 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • gstreamer-0_10-plugins-good >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-4.9.1
Patchnames:
slessp0-gstreamer-0_10-plugins-good
SUSE Linux Enterprise Server 11 SP1
  • gstreamer-0_10-plugins-good >= 0.10.17-1.1.126
  • gstreamer-0_10-plugins-good-doc >= 0.10.17-1.1.126
  • gstreamer-0_10-plugins-good-lang >= 0.10.17-1.1.126
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA gstreamer-0_10-plugins-good
SUSE Linux Enterprise Server 11 SP2
  • gstreamer-0_10-plugins-good >= 0.10.30-5.8.11
  • gstreamer-0_10-plugins-good-doc >= 0.10.30-5.8.11
  • gstreamer-0_10-plugins-good-lang >= 0.10.30-5.8.11
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA gstreamer-0_10-plugins-good
SUSE Linux Enterprise Server 11 SP3
  • gstreamer-0_10-plugins-good >= 0.10.30-5.8.11
  • gstreamer-0_10-plugins-good-doc >= 0.10.30-5.8.11
  • gstreamer-0_10-plugins-good-lang >= 0.10.30-5.8.11
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA gstreamer-0_10-plugins-good
SUSE Linux Enterprise Server 11 SP4
  • gstreamer-0_10-plugins-good >= 0.10.30-5.12.15
  • gstreamer-0_10-plugins-good-doc >= 0.10.30-5.12.15
  • gstreamer-0_10-plugins-good-lang >= 0.10.30-5.12.15
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA gstreamer-0_10-plugins-good
SUSE Linux Enterprise Server for SAP Applications 11
  • gstreamer-0_10-plugins-good >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-4.9.1
Patchnames:
slessp0-gstreamer-0_10-plugins-good
SUSE Linux Enterprise SDK 10 SP2
  • gstreamer010-plugins-good-doc >= 0.10.2-16.23
  • gstreamer010-plugins-good-extra >= 0.10.2-16.23
sles10-sp2.x86-64
sles10-sp2.ppc
sles10-sp2-debuginfo.x86-64
sles10-sp2.ia64
sles10-sp2.s390x
sle10-sp2-sdk.s390x
sled10-sp2.x86-64
sled10-sp2.x86
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.x86
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.ia64
sles10-sp2-debuginfo.x86
sles10-sp2.x86
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.ppc
ZYPP Patch Nr: 6293
openSUSE 11.2
  • gstreamer-0_10-plugins-good-debuginfo >= 0.10.15-3.3.1
  • gstreamer-0_10-plugins-good-debugsource >= 0.10.15-3.3.1
openSUSE 11.2
  • gstreamer-0_10-plugins-good >= 0.10.15-3.3.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.15-3.3.1
  • gstreamer-0_10-plugins-good-extra >= 0.10.15-3.3.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.15-3.3.1
SUSE Linux Enterprise Desktop 11 GA
  • gstreamer-0_10-plugins-good >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-4.9.1
sles11.s390x
sle11-debuginfo.ppc
sles11.x86-64
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sles11.ppc
sle11-debuginfo.s390x
sled11.x86
sled11.x86-64
sles11.x86
sles11.ia64
sle11-debuginfo.ia64
SAT Patch Nr: 984
SUSE Linux Enterprise Server 11 GA
  • gstreamer-0_10-plugins-good >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.10-4.9.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-4.9.1
sles11.s390x
sle11-debuginfo.ppc
sles11.x86-64
sle11-debuginfo.x86
sle11-debuginfo.x86-64
sles11.ppc
sle11-debuginfo.s390x
sled11.x86
sled11.x86-64
sles11.x86
sles11.ia64
sle11-debuginfo.ia64
SAT Patch Nr: 984
openSUSE 11.0
  • gstreamer-0_10-plugins-good-debuginfo >= 0.10.7-38.4
  • gstreamer-0_10-plugins-good-debugsource >= 0.10.7-38.4
openSUSE 11.0
  • gstreamer-0_10-plugins-good >= 0.10.7-38.4
  • gstreamer-0_10-plugins-good-doc >= 0.10.7-38.4
  • gstreamer-0_10-plugins-good-extra >= 0.10.7-38.4
  • gstreamer-0_10-plugins-good-lang >= 0.10.7-38.4
openSUSE 11.1
  • gstreamer-0_10-plugins-good-debuginfo >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good-debuginfo >= 0.10.10-3.22.2
  • gstreamer-0_10-plugins-good-debugsource >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good-debugsource >= 0.10.10-3.22.2
openSUSE 11.1
  • gstreamer-0_10-plugins-good >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good >= 0.10.10-3.22.2
  • gstreamer-0_10-plugins-good-doc >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good-doc >= 0.10.10-3.22.2
  • gstreamer-0_10-plugins-good-extra >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good-extra >= 0.10.10-3.22.2
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-3.22.1
  • gstreamer-0_10-plugins-good-lang >= 0.10.10-3.22.2


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA gstreamer-0_10-plugins-good Released
SUSE Linux Enterprise Server 11 GA gstreamer-0_10-plugins-good Released