Upstream information

CVE-2009-1882 at MITRE

Description

Integer overflow in the XMakeImage function in magick/xwindow.c in ImageMagick 6.5.2-8, and GraphicsMagick, allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted TIFF file, which triggers a buffer overflow. NOTE: some of these details are obtained from third party information.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 507728 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • libMagickCore1 >= 6.4.3.6-7.19.1
  • libMagickCore1-32bit >= 6.4.3.6-7.19.1
Patchnames:
slessp0-ImageMagick
SUSE Linux Enterprise Server for SAP Applications 11
  • libMagickCore1 >= 6.4.3.6-7.19.1
  • libMagickCore1-32bit >= 6.4.3.6-7.19.1
Patchnames:
slessp0-ImageMagick
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • ImageMagick >= 5.5.7-225.41
  • ImageMagick-devel >= 5.5.7-225.41
core9.x86-64
core9.ia64
sles9-nld.x86-64
core9.s390
core9.s390x
sles9-nld.x86
core9.ppc
core9.x86
YOU Patch Nr: 12437
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • ImageMagick >= 5.5.7-225.41
  • ImageMagick-Magick++ >= 5.5.7-225.41
  • ImageMagick-devel >= 5.5.7-225.41
  • perl-PerlMagick >= 5.5.7-225.41
core9.x86-64
core9.ia64
sles9-nld.x86-64
core9.s390
core9.s390x
sles9-nld.x86
core9.ppc
core9.x86
YOU Patch Nr: 12437
openSUSE 11.0
  • ImageMagick-debuginfo >= 6.4.0.4-20.2
  • ImageMagick-debugsource >= 6.4.0.4-20.2
openSUSE 11.0
  • ImageMagick >= 6.4.0.4-20.2
  • ImageMagick-devel >= 6.4.0.4-20.2
  • ImageMagick-extra >= 6.4.0.4-20.2
  • libMagick++-devel >= 6.4.0.4-20.2
  • libMagick++1 >= 6.4.0.4-20.2
  • libMagickCore1 >= 6.4.0.4-20.2
  • libMagickWand1 >= 6.4.0.4-20.2
  • perl-PerlMagick >= 6.4.0.4-20.2
openSUSE 11.1
  • ImageMagick-debuginfo >= 6.4.3.6-5.4.1
  • ImageMagick-debugsource >= 6.4.3.6-5.4.1
openSUSE 11.1
  • ImageMagick >= 6.4.3.6-5.4.1
  • ImageMagick-devel >= 6.4.3.6-5.4.1
  • ImageMagick-extra >= 6.4.3.6-5.4.1
  • libMagick++-devel >= 6.4.3.6-5.4.1
  • libMagick++1 >= 6.4.3.6-5.4.1
  • libMagickCore1 >= 6.4.3.6-5.4.1
  • libMagickCore1-32bit >= 6.4.3.6-5.4.1
  • libMagickCore1-64bit >= 6.4.3.6-5.4.1
  • libMagickWand1 >= 6.4.3.6-5.4.1
  • libMagickWand1-32bit >= 6.4.3.6-5.4.1
  • libMagickWand1-64bit >= 6.4.3.6-5.4.1
  • perl-PerlMagick >= 6.4.3.6-5.4.1
openSUSE 11.0
  • GraphicsMagick-debuginfo >= 1.1.11-29.5
  • GraphicsMagick-debugsource >= 1.1.11-29.5
openSUSE 11.0
  • GraphicsMagick >= 1.1.11-29.5
  • GraphicsMagick-devel >= 1.1.11-29.5
  • libGraphicsMagick++-devel >= 1.1.11-29.5
  • libGraphicsMagick++1 >= 1.1.11-29.5
  • libGraphicsMagick1 >= 1.1.11-29.5
  • libGraphicsMagickWand0 >= 1.1.11-29.5
  • perl-GraphicsMagick >= 1.1.11-29.5
openSUSE 11.1
  • GraphicsMagick-debuginfo >= 1.2.5-4.25.2
  • GraphicsMagick-debugsource >= 1.2.5-4.25.2
openSUSE 11.1
  • GraphicsMagick >= 1.2.5-4.25.2
  • GraphicsMagick-devel >= 1.2.5-4.25.2
  • libGraphicsMagick++-devel >= 1.2.5-4.25.2
  • libGraphicsMagick++2 >= 1.2.5-4.25.2
  • libGraphicsMagick2 >= 1.2.5-4.25.2
  • libGraphicsMagickWand1 >= 1.2.5-4.25.2
  • perl-GraphicsMagick >= 1.2.5-4.25.2
SUSE Linux Enterprise SDK 10 SP2
  • ImageMagick >= 6.2.5-16.31
  • ImageMagick-Magick++ >= 6.2.5-16.31
  • ImageMagick-Magick++-devel >= 6.2.5-16.31
  • ImageMagick-devel >= 6.2.5-16.31
  • perl-PerlMagick >= 6.2.5-16.31
sled10-sp2.x86-64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sled10-sp2.x86
sle10-sp2-sdk.s390x
sle10-sp2-sdk.x86
sle10-sp2-sdk.x86-64
ZYPP Patch Nr: 6284
SUSE Linux Enterprise SDK 11 GA
  • GraphicsMagick >= 1.2.5-4.31.1
  • libGraphicsMagick2 >= 1.2.5-4.31.1
  • perl-GraphicsMagick >= 1.2.5-4.31.1
sle11-debuginfo.x86
sle11-debuginfo.ppc
sle11-sdk.ia64
sle11-debuginfo.s390x
sle11-sdk.x86
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sle11-debuginfo.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 979
SUSE Linux Enterprise SDK 11 GA
  • ImageMagick >= 6.4.3.6-7.19.1
  • ImageMagick-devel >= 6.4.3.6-7.19.1
  • libMagick++-devel >= 6.4.3.6-7.19.1
  • libMagick++1 >= 6.4.3.6-7.19.1
  • libMagickWand1 >= 6.4.3.6-7.19.1
  • perl-PerlMagick >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
SUSE Linux Enterprise SDK 11 GA
  • ImageMagick >= 6.4.3.6-7.19.1
  • ImageMagick-devel >= 6.4.3.6-7.19.1
  • libMagick++-devel >= 6.4.3.6-7.19.1
  • libMagick++1 >= 6.4.3.6-7.19.1
  • libMagickWand1 >= 6.4.3.6-7.19.1
  • libMagickWand1-32bit >= 6.4.3.6-7.19.1
  • perl-PerlMagick >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
SUSE Linux Enterprise Desktop 11 GA
  • ImageMagick >= 6.4.3.6-7.19.1
  • libMagick++1 >= 6.4.3.6-7.19.1
  • libMagickCore1 >= 6.4.3.6-7.19.1
  • libMagickWand1 >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
SUSE Linux Enterprise Desktop 11 GA
  • ImageMagick >= 6.4.3.6-7.19.1
  • libMagick++1 >= 6.4.3.6-7.19.1
  • libMagickCore1 >= 6.4.3.6-7.19.1
  • libMagickCore1-32bit >= 6.4.3.6-7.19.1
  • libMagickWand1 >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
SUSE Linux Enterprise Server 11 GA
  • libMagickCore1 >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
SUSE Linux Enterprise Server 11 GA
  • libMagickCore1 >= 6.4.3.6-7.19.1
  • libMagickCore1-32bit >= 6.4.3.6-7.19.1
sles11.s390x
sle11-sdk.x86
sles11.x86-64
sle11-sdk.ia64
sled11.x86-64
sles11.x86
sle11-debuginfo.ia64
sled11.x86
sles11.ppc
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-debuginfo.ppc
sles11.ia64
sle11-sdk.x86-64
sle11-sdk.s390x
sle11-debuginfo.x86-64
sle11-sdk.ppc
SAT Patch Nr: 963
openSUSE Leap 42.1
  • GraphicsMagick-devel >= 1.3.21-3.10
  • libGraphicsMagick-Q16-3 >= 1.3.21-3.10
  • libGraphicsMagick3-config >= 1.3.21-3.10
  • libGraphicsMagickWand-Q16-2 >= 1.3.21-3.10
Patchnames:
openSUSE Leap 42.1 GA GraphicsMagick-devel
openSUSE Leap 42.2
  • GraphicsMagick-devel >= 1.3.25-1.4
  • libGraphicsMagick-Q16-3 >= 1.3.25-1.4
  • libGraphicsMagick3-config >= 1.3.25-1.4
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-1.4
Patchnames:
openSUSE Leap 42.2 GA GraphicsMagick-devel
openSUSE Leap 42.3
  • GraphicsMagick-devel >= 1.3.25-15.2
  • libGraphicsMagick-Q16-3 >= 1.3.25-15.2
  • libGraphicsMagick3-config >= 1.3.25-15.2
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-15.2
Patchnames:
openSUSE Leap 42.3 GA GraphicsMagick-devel
openSUSE Tumbleweed
  • GraphicsMagick >= 1.3.25-1.1
  • GraphicsMagick-devel >= 1.3.25-1.1
  • libGraphicsMagick++-Q16-12 >= 1.3.25-1.1
  • libGraphicsMagick++-devel >= 1.3.25-1.1
  • libGraphicsMagick-Q16-3 >= 1.3.25-1.1
  • libGraphicsMagick3-config >= 1.3.25-1.1
  • libGraphicsMagickWand-Q16-2 >= 1.3.25-1.1
  • perl-GraphicsMagick >= 1.3.25-1.1
Patchnames:
openSUSE Tumbleweed GA GraphicsMagick


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA ImageMagick Released
SUSE Linux Enterprise Desktop 11 SP1 ImageMagick Released
SUSE Linux Enterprise Desktop 11 SP2 ImageMagick Released
SUSE Linux Enterprise Desktop 11 SP3 ImageMagick Released
SUSE Linux Enterprise Desktop 11 SP4 ImageMagick Released
SUSE Linux Enterprise SDK 11 GA ImageMagick Released
SUSE Linux Enterprise SDK 11 SP1 ImageMagick Released
SUSE Linux Enterprise SDK 11 SP2 ImageMagick Released
SUSE Linux Enterprise SDK 11 SP3 ImageMagick Released
SUSE Linux Enterprise SDK 11 SP4 ImageMagick Released
SUSE Linux Enterprise Server 11 SP1 ImageMagick Released
SUSE Linux Enterprise Server 11 SP1 LTSS ImageMagick Released
SUSE Linux Enterprise Server 11 SP2 ImageMagick Released
SUSE Linux Enterprise Server 11 SP2 LTSS ImageMagick Released
SUSE Linux Enterprise Server 11 SP3 ImageMagick Released
SUSE Linux Enterprise Server 11 SP3 LTSS ImageMagick Released
SUSE Linux Enterprise Server 11 SP4 ImageMagick Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 ImageMagick Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 ImageMagick Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 ImageMagick Released
SUSE Linux Enterprise Server for VMWare 11 SP2 ImageMagick Released
SUSE Linux Enterprise Server for VMWare 11 SP3 ImageMagick Released