Upstream information

CVE-2009-1194 at MITRE

Description

Integer overflow in the pango_glyph_string_set_size function in pango/glyphstring.c in Pango before 1.24 allows context-dependent attackers to cause a denial of service (application crash) or possibly execute arbitrary code via a long glyph string that triggers a heap-based buffer overflow, as demonstrated by a long document.location value in Firefox.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 492773 [RESOLVED / FIXED], 522109 [RESOLVED / FIXED], 534701 [RESOLVED / FIXED], 586526 [VERIFIED / FIXED], 648732 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • mozilla-xulrunner190 >= 1.9.0.19-0.1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.19-0.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.19-0.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.19-0.1.1
  • mozilla-xulrunner190-x86 >= 1.9.0.19-0.1.1
SUSE Linux Enterprise Server 11
SUSE Linux Enterprise Server for SAP Applications 11
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-branding-SLED >= 3.5-1.1.5
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • gconf2 >= 2.24.0-7.5
  • gconf2-32bit >= 2.24.0-7.5
  • gconf2-x86 >= 2.24.0-7.5
  • libfreebl3 >= 3.12.3.1-1.2.1
  • libfreebl3-32bit >= 3.12.3.1-1.2.1
  • libfreebl3-x86 >= 3.12.3.1-1.2.1
  • libidl >= 0.8.11-2.14
  • libidl-32bit >= 0.8.11-2.14
  • libidl-x86 >= 0.8.11-2.14
  • mozilla-nspr >= 4.8-1.3.1
  • mozilla-nspr-32bit >= 4.8-1.3.1
  • mozilla-nspr-x86 >= 4.8-1.3.1
  • mozilla-nss >= 3.12.3.1-1.2.1
  • mozilla-nss-32bit >= 3.12.3.1-1.2.1
  • mozilla-nss-tools >= 3.12.3.1-1.2.1
  • mozilla-nss-x86 >= 3.12.3.1-1.2.1
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-x86 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner191 >= 1.9.1.11-0.1.1
  • mozilla-xulrunner191-32bit >= 1.9.1.11-0.1.1
  • mozilla-xulrunner191-gnomevfs >= 1.9.1.11-0.1.1
  • mozilla-xulrunner191-translations >= 1.9.1.11-0.1.1
  • mozilla-xulrunner191-x86 >= 1.9.1.11-0.1.1
  • mozilla-xulrunner192 >= 1.9.2.12-0.6.1
  • mozilla-xulrunner192-32bit >= 1.9.2.12-0.6.1
  • mozilla-xulrunner192-gnome >= 1.9.2.12-0.6.1
  • mozilla-xulrunner192-translations >= 1.9.2.12-0.6.1
  • mozilla-xulrunner192-x86 >= 1.9.2.12-0.6.1
  • orbit2 >= 2.14.16-2.16
  • orbit2-32bit >= 2.14.16-2.16
  • orbit2-x86 >= 2.14.16-2.16
  • pango >= 1.22.1-3.18.1
  • pango-32bit >= 1.22.1-3.18.1
  • pango-doc >= 1.22.1-3.18.1
  • pango-x86 >= 1.22.1-3.18.1
Patchnames:
slessp0-MozillaFirefox
slessp0-pango
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • firefox3-pango >= 1.14.5-0.10.1
Builds
ZYPP Patch Nr: 7097
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • firefox3-pango >= 1.14.5-0.10.1
  • firefox3-pango-32bit >= 1.14.5-0.10.1
Builds
ZYPP Patch Nr: 7097
SUSE Linux Enterprise SDK 10 SP3
  • firefox3-pango-devel >= 1.14.5-0.10.1
  • firefox3-pango-doc >= 1.14.5-0.10.1
Builds
ZYPP Patch Nr: 7097
Open Enterprise Server
  • pango >= 1.2.5-174.7
  • pango-devel >= 1.2.5-174.7
  • pango-doc >= 1.2.5-174.7
Builds
YOU Patch Nr: 12575
openSUSE 11.0
  • MozillaFirefox-debuginfo >= 3.0.12-0.1
  • MozillaFirefox-debugsource >= 3.0.12-0.1
  • mozilla-xulrunner190-debuginfo >= 1.9.0.12-1.1
  • mozilla-xulrunner190-debugsource >= 1.9.0.12-1.1
openSUSE 11.0
  • MozillaFirefox >= 3.0.12-0.1
  • MozillaFirefox-translations >= 3.0.12-0.1
  • mozilla-xulrunner190 >= 1.9.0.12-1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.12-1.1
  • mozilla-xulrunner190-64bit >= 1.9.0.12-1.1
  • mozilla-xulrunner190-devel >= 1.9.0.12-1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.12-1.1
  • mozilla-xulrunner190-gnomevfs-64bit >= 1.9.0.12-1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.12-1.1
  • mozilla-xulrunner190-translations-64bit >= 1.9.0.12-1.1
openSUSE 11.1
  • MozillaFirefox-debuginfo >= 3.0.12-0.1.2
  • MozillaFirefox-debugsource >= 3.0.12-0.1.2
  • mozilla-xulrunner190-debuginfo >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-debuginfo-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-debugsource >= 1.9.0.12-1.1.1
openSUSE 11.1
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-branding-upstream >= 3.0.12-0.1.2
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-devel >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.12-1.1.1
  • python-xpcom190 >= 1.9.0.12-1.1.1
SUSE Linux Enterprise Server for SAP 10 SP2
  • pango >= 1.10.2-23.8.1
  • pango-32bit >= 1.10.2-23.8.1
  • pango-devel >= 1.10.2-23.8.1
  • pango-doc >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6801
SUSE Linux Enterprise SDK 10 SP2
  • pango-devel-64bit >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6801
openSUSE 11.0
  • pango-debuginfo >= 1.20.1-20.2
  • pango-debugsource >= 1.20.1-20.2
openSUSE 11.0
  • pango >= 1.20.1-20.2
  • pango-32bit >= 1.20.1-20.2
  • pango-64bit >= 1.20.1-20.2
  • pango-devel >= 1.20.1-20.2
  • pango-devel-64bit >= 1.20.1-20.2
  • pango-doc >= 1.20.1-20.2
  • pango-module-thai-lang >= 1.20.1-20.2
openSUSE 11.1
  • pango-debuginfo >= 1.22.1-2.13.1
  • pango-debuginfo-32bit >= 1.22.1-2.13.1
  • pango-debuginfo-64bit >= 1.22.1-2.13.1
  • pango-debugsource >= 1.22.1-2.13.1
openSUSE 11.1
  • pango >= 1.22.1-2.13.1
  • pango-32bit >= 1.22.1-2.13.1
  • pango-64bit >= 1.22.1-2.13.1
  • pango-devel >= 1.22.1-2.13.1
  • pango-doc >= 1.22.1-2.13.1
  • pango-module-thai-lang >= 1.22.1-2.13.1
SUSE Linux Enterprise Desktop 10 SP3 for x86
SUSE Linux Enterprise Server 10 SP3
  • pango >= 1.10.2-23.8.1
  • pango-devel >= 1.10.2-23.8.1
  • pango-doc >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6800
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
  • pango >= 1.10.2-23.8.1
  • pango-32bit >= 1.10.2-23.8.1
  • pango-devel >= 1.10.2-23.8.1
  • pango-doc >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6800
SUSE Linux Enterprise SDK 10 SP3
  • pango-devel-64bit >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6800
SUSE Linux Enterprise Server 10 SP3
  • pango >= 1.10.2-23.8.1
  • pango-devel >= 1.10.2-23.8.1
  • pango-doc >= 1.10.2-23.8.1
  • pango-x86 >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6800
SUSE Linux Enterprise Server 10 SP3
  • pango >= 1.10.2-23.8.1
  • pango-64bit >= 1.10.2-23.8.1
  • pango-devel >= 1.10.2-23.8.1
  • pango-devel-64bit >= 1.10.2-23.8.1
  • pango-doc >= 1.10.2-23.8.1
Builds
ZYPP Patch Nr: 6800
openSUSE 11.1
  • pango-debuginfo >= 1.22.1-2.12.2
  • pango-debuginfo-32bit >= 1.22.1-2.12.2
  • pango-debuginfo-64bit >= 1.22.1-2.12.2
  • pango-debugsource >= 1.22.1-2.12.2
openSUSE 11.1
  • pango >= 1.22.1-2.12.2
  • pango-32bit >= 1.22.1-2.12.2
  • pango-64bit >= 1.22.1-2.12.2
  • pango-devel >= 1.22.1-2.12.2
  • pango-doc >= 1.22.1-2.12.2
  • pango-module-thai-lang >= 1.22.1-2.12.2
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.17.3
  • pango-doc >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.17.3
  • pango-devel-32bit >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise Desktop 11 GA
  • pango >= 1.22.1-3.17.3
  • pango-devel >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise Desktop 11 GA
  • pango >= 1.22.1-3.17.3
  • pango-32bit >= 1.22.1-3.17.3
  • pango-devel >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.17.3
  • pango-doc >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.17.3
  • pango-doc >= 1.22.1-3.17.3
  • pango-x86 >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.17.3
  • pango-32bit >= 1.22.1-3.17.3
  • pango-doc >= 1.22.1-3.17.3
Builds
SAT Patch Nr: 825
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.18.1
  • pango-doc >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise SDK 11 GA
  • pango-devel >= 1.22.1-3.18.1
  • pango-devel-32bit >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise Desktop 11 GA
  • pango >= 1.22.1-3.18.1
  • pango-devel >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise Desktop 11 GA
  • pango >= 1.22.1-3.18.1
  • pango-32bit >= 1.22.1-3.18.1
  • pango-devel >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.18.1
  • pango-doc >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.18.1
  • pango-doc >= 1.22.1-3.18.1
  • pango-x86 >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise Server 11 GA
  • pango >= 1.22.1-3.18.1
  • pango-32bit >= 1.22.1-3.18.1
  • pango-doc >= 1.22.1-3.18.1
Builds
SAT Patch Nr: 1880
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner190-devel >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner190-devel >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs-x86 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations-x86 >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise SDK 11 GA
  • mozilla-xulrunner190-devel >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise Desktop 11 GA
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-x86 >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134
SUSE Linux Enterprise Server 11 GA
  • MozillaFirefox >= 3.0.12-0.1.2
  • MozillaFirefox-translations >= 3.0.12-0.1.2
  • mozilla-xulrunner190 >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-32bit >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.12-1.1.1
  • mozilla-xulrunner190-translations >= 1.9.0.12-1.1.1
Builds
SAT Patch Nr: 1134


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SLED-10-SP3 pango Released
SLES-10-SP3 pango Released
SUSE Linux Enterprise Desktop 11 MozillaFirefox Released
SUSE Linux Enterprise Desktop 11 pango Released
SUSE Linux Enterprise Server 11 MozillaFirefox Released
SUSE Linux Enterprise Server 11 pango Released
SUSE Linux Enterprise Software Development Kit 11 pango Released