Upstream information

CVE-2009-1185 at MITRE

Description

udev before 1.4.1 does not verify whether a NETLINK message originates from kernel space, which allows local users to gain privileges by sending a NETLINK message from user space.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.2
Vector AV:L/AC:L/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 1034330 [RESOLVED / DUPLICATE], 493158 [RESOLVED / FIXED], 550249 [RESOLVED / FIXED], 776925 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • libvolume_id1 >= 128-13.2.1
  • udev >= 128-13.2.1
Patchnames:
slessp0-libudev-devel
SUSE Linux Enterprise Server for SAP Applications 11
  • libvolume_id1 >= 128-13.2.1
  • udev >= 128-13.2.1
Patchnames:
slessp0-libudev-devel
SUSE Linux Enterprise 11 Moblin 2.0
  • udev-debuginfo >= 137-1.3.1
  • udev-debugsource >= 137-1.3.1
SAT Patch Nr: 1910
SUSE Linux Enterprise 11 Moblin 2.0
  • libudev0 >= 137-1.3.1
  • libvolume_id1 >= 137-1.3.1
  • udev >= 137-1.3.1
SAT Patch Nr: 1910
openSUSE 11.0
  • udev-debuginfo >= 120-13.2
  • udev-debugsource >= 120-13.2
openSUSE 11.0
  • libvolume_id >= 120-13.2
  • libvolume_id-devel >= 120-13.2
  • udev >= 120-13.2
openSUSE 11.1
  • udev-debuginfo >= 128-9.7.1
  • udev-debugsource >= 128-9.7.1
openSUSE 11.1
  • libudev-devel >= 128-9.7.1
  • libudev0 >= 128-9.7.1
  • libvolume_id >= 126-17.38.1
  • libvolume_id-devel >= 128-9.7.1
  • libvolume_id1 >= 128-9.7.1
  • udev >= 128-9.7.1
SUSE Linux Enterprise SDK 11 GA
  • libudev-devel >= 128-13.2.1
  • libudev0 >= 128-13.2.1
  • libvolume_id-devel >= 128-13.2.1
sle11-sdk.s390x
sle11-debuginfo.ia64
sled11.x86
sles11.x86-64
sle11-debuginfo.x86
sle11-sdk.ppc
sles11.ia64
sled11.x86-64
sle11-sdk.ia64
sles11.x86
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sle11-debuginfo.ppc
sle11-sdk.x86
sles11.ppc
sle11-debuginfo.s390x
sles11.s390x
SAT Patch Nr: 766
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • libvolume_id1 >= 128-13.2.1
  • udev >= 128-13.2.1
sle11-sdk.s390x
sle11-debuginfo.ia64
sled11.x86
sles11.x86-64
sle11-debuginfo.x86
sle11-sdk.ppc
sles11.ia64
sled11.x86-64
sle11-sdk.ia64
sles11.x86
sle11-debuginfo.x86-64
sle11-sdk.x86-64
sle11-debuginfo.ppc
sle11-sdk.x86
sles11.ppc
sle11-debuginfo.s390x
sles11.s390x
SAT Patch Nr: 766


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA udev Released
SUSE Linux Enterprise SDK 11 GA udev Released
SUSE Linux Enterprise Server 11 GA udev Released