Upstream information

CVE-2009-0585 at MITRE

Description

Integer overflow in the soup_base64_encode function in soup-misc.c in libsoup 2.x.x before 2.2.x, and 2.x before 2.24, allows context-dependent attackers to execute arbitrary code via a long string that is converted to a base64 representation.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 481483 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • libsoup >= 2.2.3-0.23
  • libsoup-devel >= 2.2.3-0.23
sles9-oes.x86
core9.x86
core9.x86-64
sles9-nld.x86
sles9-nlpos.x86
core9.ia64
core9.ppc
sles9-nld.x86-64
core9.s390x
core9.s390
YOU Patch Nr: 12411
Novell Linux Desktop 9 for x86_64
  • libsoup >= 2.2.3-0.23
  • libsoup-32bit >= 9-200904292143
  • libsoup-devel >= 2.2.3-0.23
  • libsoup-devel-32bit >= 9-200904292143
sles9-oes.x86
core9.x86
core9.x86-64
sles9-nld.x86
sles9-nlpos.x86
core9.ia64
core9.ppc
sles9-nld.x86-64
core9.s390x
core9.s390
YOU Patch Nr: 12411