Upstream information

CVE-2009-0582 at MITRE

Description

The ntlm_challenge function in the NTLM SASL authentication mechanism in camel/camel-sasl-ntlm.c in Camel in Evolution Data Server (aka evolution-data-server) 2.24.5 and earlier, and 2.25.92 and earlier 2.25.x versions, does not validate whether a certain length value is consistent with the amount of data in a challenge packet, which allows remote mail servers to read information from the process memory of a client, or cause a denial of service (client crash), via an NTLM authentication type 2 packet with a length value that exceeds the amount of packet data.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5.8
Vector AV:N/AC:M/Au:N/C:P/I:N/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 475541 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-32bit >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • evolution-data-server-x86 >= 2.24.1.1-11.8.1
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
Patchnames:
slessp0-evolution
SUSE Linux Enterprise Server for SAP Applications 11
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-32bit >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • evolution-data-server-x86 >= 2.24.1.1-11.8.1
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
Patchnames:
slessp0-evolution
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
  • evolution >= 2.0.4-0.17
  • evolution-devel >= 2.0.4-0.17
  • evolution-pilot >= 2.0.4-0.17
sles9-nld.x86
sles9-nld.x86-64
YOU Patch Nr: 12392
openSUSE 11.1
  • evolution-data-server-debuginfo >= 2.24.1.1-5.12.1
  • evolution-data-server-debuginfo-32bit >= 2.24.1.1-5.12.1
  • evolution-data-server-debugsource >= 2.24.1.1-5.12.1
  • evolution-debuginfo >= 2.24.1.1-4.14.1
  • evolution-debugsource >= 2.24.1.1-4.14.1
  • evolution-mono-providers-debuginfo >= 0.1.1-2.18.1
  • evolution-mono-providers-debugsource >= 0.1.1-2.18.1
  • gtkhtml2-debuginfo >= 3.24.1.1-1.17.1
  • gtkhtml2-debugsource >= 3.24.1.1-1.17.1
openSUSE 11.1
  • evolution >= 2.24.1.1-4.14.1
  • evolution-data-server >= 2.24.1.1-5.12.1
  • evolution-data-server-32bit >= 2.24.1.1-5.12.1
  • evolution-data-server-devel >= 2.24.1.1-5.12.1
  • evolution-data-server-doc >= 2.24.1.1-5.12.1
  • evolution-data-server-lang >= 2.24.1.1-5.12.1
  • evolution-devel >= 2.24.1.1-4.14.1
  • evolution-lang >= 2.24.1.1-4.14.1
  • evolution-mono-providers >= 0.1.1-2.18.1
  • evolution-pilot >= 2.24.1.1-4.14.1
  • gtkhtml2 >= 3.24.1.1-1.17.1
  • gtkhtml2-devel >= 3.24.1.1-1.17.1
  • gtkhtml2-lang >= 3.24.1.1-1.17.1
openSUSE 11.0
  • evolution-data-server-debuginfo >= 2.22.1.1-11.4
  • evolution-data-server-debugsource >= 2.22.1.1-11.4
openSUSE 11.0
  • evolution-data-server >= 2.22.1.1-11.4
  • evolution-data-server-32bit >= 2.22.1.1-11.4
  • evolution-data-server-64bit >= 2.22.1.1-11.4
  • evolution-data-server-devel >= 2.22.1.1-11.4
  • evolution-data-server-doc >= 2.22.1.1-11.4
SUSE Linux Enterprise SDK 11 GA
  • evolution >= 2.24.1.1-15.8.4
  • evolution-data-server-devel >= 2.24.1.1-11.8.1
  • evolution-devel >= 2.24.1.1-15.8.4
  • evolution-lang >= 2.24.1.1-15.8.4
  • gtkhtml2-devel >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778
SUSE Linux Enterprise Desktop 11 GA
  • evolution >= 2.24.1.1-15.8.4
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • evolution-lang >= 2.24.1.1-15.8.4
  • evolution-pilot >= 2.24.1.1-15.8.4
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778
SUSE Linux Enterprise Desktop 11 GA
  • evolution >= 2.24.1.1-15.8.4
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-32bit >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • evolution-lang >= 2.24.1.1-15.8.4
  • evolution-pilot >= 2.24.1.1-15.8.4
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778
SUSE Linux Enterprise Server 11 GA
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778
SUSE Linux Enterprise Server 11 GA
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • evolution-data-server-x86 >= 2.24.1.1-11.8.1
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778
SUSE Linux Enterprise Server 11 GA
  • evolution-data-server >= 2.24.1.1-11.8.1
  • evolution-data-server-32bit >= 2.24.1.1-11.8.1
  • evolution-data-server-lang >= 2.24.1.1-11.8.1
  • gtkhtml2 >= 3.24.1.1-3.23.2
  • gtkhtml2-lang >= 3.24.1.1-3.23.2
sles11.s390x
sle11-debuginfo.x86-64
sle11-debuginfo.ppc
sles11.x86-64
sle11-sdk.x86
sle11-sdk.ia64
sle11-sdk.ppc
sles11.x86
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.s390x
sle11-debuginfo.x86
sle11-sdk.s390x
sle11-sdk.x86-64
sles11.ia64
sled11.x86
sled11.x86-64
SAT Patch Nr: 778


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA evolution-data-server Released
SUSE Linux Enterprise SDK 11 GA evolution-data-server Released
SUSE Linux Enterprise Server 11 GA evolution-data-server Released