Upstream information

CVE-2009-0580 at MITRE

Description

Apache Tomcat 4.1.0 through 4.1.39, 5.5.0 through 5.5.27, and 6.0.0 through 6.0.18, when FORM authentication is used, allows remote attackers to enumerate valid usernames via requests to /j_security_check with malformed URL encoding of passwords, related to improper error checking in the (1) MemoryRealm, (2) DataSourceRealm, and (3) JDBCRealm authentication realms, as demonstrated by a % (percent) value for the j_password parameter.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entry: 509839 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP2
  • tomcat6 >= 6.0.18-20.35.36.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.36.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.36.1
  • tomcat6-javadoc >= 6.0.18-20.35.36.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.36.1
  • tomcat6-lib >= 6.0.18-20.35.36.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.36.1
  • tomcat6-webapps >= 6.0.18-20.35.36.1
SUSE Linux Enterprise Server 11 SP3
  • tomcat6 >= 6.0.18-20.35.40.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.40.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.40.1
  • tomcat6-javadoc >= 6.0.18-20.35.40.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.40.1
  • tomcat6-lib >= 6.0.18-20.35.40.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.40.1
  • tomcat6-webapps >= 6.0.18-20.35.40.1
SUSE Linux Enterprise Server 11 SP4
  • tomcat6 >= 6.0.41-0.43.1
  • tomcat6-admin-webapps >= 6.0.41-0.43.1
  • tomcat6-docs-webapp >= 6.0.41-0.43.1
  • tomcat6-javadoc >= 6.0.41-0.43.1
  • tomcat6-jsp-2_1-api >= 6.0.41-0.43.1
  • tomcat6-lib >= 6.0.41-0.43.1
  • tomcat6-servlet-2_5-api >= 6.0.41-0.43.1
  • tomcat6-webapps >= 6.0.41-0.43.1
SUSE Linux Enterprise SDK 11 GA
  • tomcat6 >= 6.0.18-20.1.1
  • tomcat6-admin-webapps >= 6.0.18-20.1.1
  • tomcat6-docs-webapp >= 6.0.18-20.1.1
  • tomcat6-javadoc >= 6.0.18-20.1.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.1.1
  • tomcat6-lib >= 6.0.18-20.1.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.1.1
  • tomcat6-webapps >= 6.0.18-20.1.1
SAT Patch Nr: 997
Open Enterprise Server
  • apache-jakarta-tomcat-connectors >= 5.0.19-29.23
  • apache2-jakarta-tomcat-connectors >= 5.0.19-29.23
  • jakarta-tomcat >= 5.0.19-29.23
  • jakarta-tomcat-doc >= 5.0.19-29.23
  • jakarta-tomcat-examples >= 5.0.19-29.23
Builds
YOU Patch Nr: 12460
openSUSE 11.0
  • tomcat6 >= 6.0.16-6.5
  • tomcat6-admin-webapps >= 6.0.16-6.5
  • tomcat6-docs-webapp >= 6.0.16-6.5
  • tomcat6-javadoc >= 6.0.16-6.5
  • tomcat6-jsp-2_1-api >= 6.0.16-6.5
  • tomcat6-lib >= 6.0.16-6.5
  • tomcat6-servlet-2_5-api >= 6.0.16-6.5
  • tomcat6-webapps >= 6.0.16-6.5
openSUSE 11.1
  • tomcat6 >= 6.0.18-16.2.1
  • tomcat6-admin-webapps >= 6.0.18-16.2.1
  • tomcat6-docs-webapp >= 6.0.18-16.2.1
  • tomcat6-javadoc >= 6.0.18-16.2.1
  • tomcat6-jsp-2_1-api >= 6.0.18-16.2.1
  • tomcat6-lib >= 6.0.18-16.2.1
  • tomcat6-servlet-2_5-api >= 6.0.18-16.2.1
  • tomcat6-webapps >= 6.0.18-16.2.1
SUSE Linux Enterprise SDK 10 SP2
  • tomcat5 >= 5.0.30-27.40
  • tomcat5-admin-webapps >= 5.0.30-27.40
  • tomcat5-webapps >= 5.0.30-27.40
ZYPP Patch Nr: 6352