Upstream information

CVE-2009-0579 at MITRE

Description

Linux-PAM before 1.0.4 does not enforce the minimum password age (MINDAYS) as specified in /etc/shadow, which allows local users to bypass intended security policy and change their passwords sooner than specified.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.6
Vector AV:L/AC:L/Au:N/C:P/I:P/A:P
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 481814 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • pam >= 1.0.4-0.5.12
  • pam-32bit >= 1.0.4-0.5.12
  • pam-doc >= 1.0.4-0.5.12
  • pam-x86 >= 1.0.4-0.5.12
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA pam
SUSE Linux Enterprise Server 11 SP2
  • pam >= 1.1.5-0.10.17
  • pam-32bit >= 1.1.5-0.10.17
  • pam-doc >= 1.1.5-0.10.17
  • pam-x86 >= 1.1.5-0.10.17
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA pam
SUSE Linux Enterprise Server 11 SP3
  • pam >= 1.1.5-0.10.17
  • pam-32bit >= 1.1.5-0.10.17
  • pam-doc >= 1.1.5-0.10.17
  • pam-x86 >= 1.1.5-0.10.17
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA pam
SUSE Linux Enterprise Server 11 SP4
  • pam >= 1.1.5-0.15.9
  • pam-32bit >= 1.1.5-0.15.9
  • pam-doc >= 1.1.5-0.15.9
  • pam-x86 >= 1.1.5-0.15.9
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA pam
SUSE Linux Enterprise Software Development Kit 11 SP4
  • pam-devel >= 1.1.5-0.15.9
  • pam-devel-32bit >= 1.1.5-0.15.9
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA pam-devel