Upstream information

CVE-2009-0543 at MITRE

Description

ProFTPD Server 1.3.1, with NLS support enabled, allows remote attackers to bypass SQL injection protection mechanisms via invalid, encoded multibyte characters, which are not properly handled in (1) mod_sql_mysql and (2) mod_sql_postgres.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 475316 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE Tumbleweed
  • proftpd >= 1.3.5b-2.5
  • proftpd-devel >= 1.3.5b-2.5
  • proftpd-doc >= 1.3.5b-2.5
  • proftpd-lang >= 1.3.5b-2.5
  • proftpd-ldap >= 1.3.5b-2.5
  • proftpd-mysql >= 1.3.5b-2.5
  • proftpd-pgsql >= 1.3.5b-2.5
  • proftpd-radius >= 1.3.5b-2.5
  • proftpd-sqlite >= 1.3.5b-2.5
Patchnames:
openSUSE Tumbleweed GA proftpd