Upstream information

CVE-2009-0478 at MITRE

Description

Squid 2.7 to 2.7.STABLE5, 3.0 to 3.0.STABLE12, and 3.1 to 3.1.0.4 allows remote attackers to cause a denial of service via an HTTP request with an invalid version number, which triggers a reachable assertion in (1) HttpMsg.c and (2) HttpStatusLine.c.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:N/I:N/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Partial
SUSE Bugzilla entry: 472834 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • squid >= 2.7.STABLE5-2.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA squid
SUSE Linux Enterprise Server 11 SP2
  • squid >= 2.7.STABLE5-2.10.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA squid
SUSE Linux Enterprise Server 11 SP3
  • squid >= 2.7.STABLE5-2.12.12.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA squid
SUSE Linux Enterprise Server 11 SP4
  • squid >= 2.7.STABLE5-2.12.16.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA squid
openSUSE 11.1
  • squid-debuginfo >= 2.7.STABLE5-1.20.1
  • squid-debugsource >= 2.7.STABLE5-1.20.1
openSUSE 11.1
  • squid >= 2.7.STABLE5-1.20.1