Upstream information

CVE-2009-0037 at MITRE

Description

The redirect implementation in curl and libcurl 5.11 through 7.19.3, when CURLOPT_FOLLOWLOCATION is enabled, accepts arbitrary Location values, which might allow remote HTTP servers to (1) trigger arbitrary requests to intranet servers, (2) read or overwrite arbitrary files via a redirect to a file: URL, or (3) execute arbitrary commands via a redirect to an scp: URL.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.8
Vector AV:N/AC:M/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 475103 [RESOLVED / FIXED], 527990 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 12
  • curl >= 7.37.0-2.5
  • libcurl4 >= 7.37.0-2.5
  • libcurl4-32bit >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Desktop 12 GA curl
SUSE Linux Enterprise Desktop 12 SP1
  • curl >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
  • libcurl4-32bit >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP1 GA curl
SUSE Linux Enterprise Desktop 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
  • libcurl4-32bit >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP2 GA curl
SUSE Linux Enterprise Desktop 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Desktop 12 SP3 GA curl
SUSE Linux Enterprise Module for Basesystem 15
  • curl >= 7.60.0-1.1
  • libcurl-devel >= 7.60.0-1.1
  • libcurl4 >= 7.60.0-1.1
  • libcurl4-32bit >= 7.60.0-1.1
Patchnames:
SUSE Linux Enterprise Module for Basesystem 15 GA curl
SUSE Linux Enterprise Server 11
  • curl >= 7.19.0-11.21.1
  • keyutils-libs >= 1.2-107.22
  • keyutils-libs-32bit >= 1.2-107.22
  • keyutils-libs-x86 >= 1.2-107.22
  • libcurl4 >= 7.19.0-11.21.1
  • libcurl4-32bit >= 7.19.0-11.21.1
  • libcurl4-x86 >= 7.19.0-11.21.1
  • libidn >= 1.10-3.18
  • libidn-32bit >= 1.10-3.18
  • libidn-x86 >= 1.10-3.18
Patchnames:
slessp0-curl
SUSE Linux Enterprise Server 11 SP1
  • curl >= 7.19.0-11.24.25
  • libcurl4 >= 7.19.0-11.24.25
  • libcurl4-32bit >= 7.19.0-11.24.25
  • libcurl4-x86 >= 7.19.0-11.24.25
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA curl
SUSE Linux Enterprise Server 11 SP2
  • curl >= 7.19.7-1.18.1
  • libcurl4 >= 7.19.7-1.18.1
  • libcurl4-32bit >= 7.19.7-1.18.1
  • libcurl4-x86 >= 7.19.7-1.18.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA curl
SUSE Linux Enterprise Server 11 SP3
  • curl >= 7.19.7-1.26.8
  • libcurl4 >= 7.19.7-1.26.8
  • libcurl4-32bit >= 7.19.7-1.26.8
  • libcurl4-x86 >= 7.19.7-1.26.8
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA curl
SUSE Linux Enterprise Server 11 SP4
  • curl >= 7.19.7-1.42.1
  • libcurl4 >= 7.19.7-1.42.1
  • libcurl4-32bit >= 7.19.7-1.42.1
  • libcurl4-x86 >= 7.19.7-1.42.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA curl
SUSE Linux Enterprise Server 11-SECURITY
  • curl-openssl1 >= 7.19.7-1.55.1
  • libcurl4-openssl1 >= 7.19.7-0.38.1
  • libcurl4-openssl1-32bit >= 7.19.7-0.38.1
Patchnames:
SUSE Linux Enterprise Server 11-SECURITY GA curl-openssl1
SUSE Linux Enterprise Server 11-SECURITY GA libcurl4-openssl1-32bit
SUSE Linux Enterprise Server 12
  • curl >= 7.37.0-2.5
  • libcurl4 >= 7.37.0-2.5
  • libcurl4-32bit >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Server 12 GA curl
SUSE Linux Enterprise Server 12 SP1
  • curl >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
  • libcurl4-32bit >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Server 12 SP1 GA curl
SUSE Linux Enterprise Server 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
  • libcurl4-32bit >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Server 12 SP2 GA curl
SUSE Linux Enterprise Server 12 SP3
  • curl >= 7.37.0-36.1
  • libcurl4 >= 7.37.0-36.1
  • libcurl4-32bit >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Server 12 SP3 GA curl
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2
  • curl >= 7.37.0-28.1
  • libcurl4 >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Server for Raspberry Pi 12 SP2 GA curl
SUSE Linux Enterprise Server for SAP Applications 11
  • curl >= 7.19.0-11.21.1
  • keyutils-libs >= 1.2-107.22
  • keyutils-libs-32bit >= 1.2-107.22
  • keyutils-libs-x86 >= 1.2-107.22
  • libcurl4 >= 7.19.0-11.21.1
  • libcurl4-32bit >= 7.19.0-11.21.1
  • libcurl4-x86 >= 7.19.0-11.21.1
  • libidn >= 1.10-3.18
  • libidn-32bit >= 1.10-3.18
  • libidn-x86 >= 1.10-3.18
Patchnames:
slessp0-curl
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libcurl-devel >= 7.19.7-1.42.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12
  • libcurl-devel >= 7.37.0-2.5
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP1
  • libcurl-devel >= 7.37.0-15.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP1 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP2
  • libcurl-devel >= 7.37.0-28.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP2 GA libcurl-devel
SUSE Linux Enterprise Software Development Kit 12 SP3
  • libcurl-devel >= 7.37.0-36.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 12 SP3 GA libcurl-devel
openSUSE 11.0
  • curl-debuginfo >= 7.18.1-18.2
  • curl-debugsource >= 7.18.1-18.2
openSUSE 11.0
  • curl >= 7.18.1-18.2
  • libcurl-devel >= 7.18.1-18.2
  • libcurl4 >= 7.18.1-18.2
  • libcurl4-32bit >= 7.18.1-18.2
  • libcurl4-64bit >= 7.18.1-18.2
openSUSE 11.1
  • curl-debuginfo >= 7.19.0-11.2.2
  • curl-debugsource >= 7.19.0-11.2.2
openSUSE 11.1
  • curl >= 7.19.0-11.2.2
  • libcurl-devel >= 7.19.0-11.2.2
  • libcurl4 >= 7.19.0-11.2.2
  • libcurl4-32bit >= 7.19.0-11.2.2
  • libcurl4-64bit >= 7.19.0-11.2.2
SUSE Linux Enterprise SDK 10 SP2
  • curl-devel >= 7.15.1-19.11
sles10-sp2.ia64
sled10-sp2.x86-64
sles10-sp2.x86
sled10-sp2.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.s390x
sle10-sp2-sdk.ppc
sle10-sp2-sdk.x86
sles10-sp2.ppc
sle10-sp2-sdk.x86-64
sles10-sp2.s390x
ZYPP Patch Nr: 6015
SUSE Linux Enterprise SDK 11 GA
  • libcurl-devel >= 7.19.0-11.21.1
sle11-debuginfo.x86
sles11.s390x
sle11-sdk.x86-64
sle11-sdk.s390x
sles11.x86-64
sle11-debuginfo.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ppc
sle11-sdk.ia64
sle11-sdk.x86
sled11.x86-64
sled11.x86
sle11-debuginfo.s390x
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 634
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • curl >= 7.19.0-11.21.1
  • libcurl4 >= 7.19.0-11.21.1
sle11-debuginfo.x86
sles11.s390x
sle11-sdk.x86-64
sle11-sdk.s390x
sles11.x86-64
sle11-debuginfo.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ppc
sle11-sdk.ia64
sle11-sdk.x86
sled11.x86-64
sled11.x86
sle11-debuginfo.s390x
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 634
SUSE Linux Enterprise Desktop 11 GA
SUSE Linux Enterprise Server 11 GA
  • curl >= 7.19.0-11.21.1
  • libcurl4 >= 7.19.0-11.21.1
  • libcurl4-32bit >= 7.19.0-11.21.1
sle11-debuginfo.x86
sles11.s390x
sle11-sdk.x86-64
sle11-sdk.s390x
sles11.x86-64
sle11-debuginfo.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ppc
sle11-sdk.ia64
sle11-sdk.x86
sled11.x86-64
sled11.x86
sle11-debuginfo.s390x
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 634
SUSE Linux Enterprise Server 11 GA
  • curl >= 7.19.0-11.21.1
  • libcurl4 >= 7.19.0-11.21.1
  • libcurl4-x86 >= 7.19.0-11.21.1
sle11-debuginfo.x86
sles11.s390x
sle11-sdk.x86-64
sle11-sdk.s390x
sles11.x86-64
sle11-debuginfo.x86-64
sles11.x86
sles11.ia64
sle11-sdk.ppc
sle11-sdk.ia64
sle11-sdk.x86
sled11.x86-64
sled11.x86
sle11-debuginfo.s390x
sles11.ppc
sle11-debuginfo.ia64
sle11-debuginfo.ppc
SAT Patch Nr: 634
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • curl >= 7.11.0-39.18
  • curl-devel >= 7.11.0-39.18
sles9-nld.x86-64
core9.ia64
sles9-nld.x86
core9.s390
core9.ppc
core9.x86-64
core9.x86
sles9-oes.x86
core9.s390x
sles9-nlpos.x86
YOU Patch Nr: 12356
Novell Linux Desktop 9 for x86_64
  • curl >= 7.11.0-39.18
  • curl-32bit >= 9-200902201554
  • curl-devel >= 7.11.0-39.18
sles9-nld.x86-64
core9.ia64
sles9-nld.x86
core9.s390
core9.ppc
core9.x86-64
core9.x86
sles9-oes.x86
core9.s390x
sles9-nlpos.x86
YOU Patch Nr: 12356
openSUSE Leap 15.0
  • curl >= 7.59.0-lp150.1.1
  • libcurl4 >= 7.59.0-lp150.1.1
  • libcurl4-32bit >= 7.59.0-lp150.1.1
Patchnames:
openSUSE Leap 15.0 GA curl
openSUSE Leap 42.1
  • curl >= 7.37.0-5.2
  • libcurl-devel >= 7.37.0-5.2
  • libcurl4 >= 7.37.0-5.2
Patchnames:
openSUSE Leap 42.1 GA curl
openSUSE Leap 42.2
  • curl >= 7.37.0-15.1
  • libcurl-devel >= 7.37.0-15.1
  • libcurl4 >= 7.37.0-15.1
Patchnames:
openSUSE Leap 42.2 GA curl
openSUSE Leap 42.3
  • curl >= 7.37.0-18.5
  • libcurl-devel >= 7.37.0-18.5
  • libcurl4 >= 7.37.0-18.5
Patchnames:
openSUSE Leap 42.3 GA curl
openSUSE Tumbleweed
  • curl >= 7.51.0-1.1
  • libcurl-devel >= 7.51.0-1.1
  • libcurl-devel-32bit >= 7.51.0-1.1
  • libcurl4 >= 7.51.0-1.1
  • libcurl4-32bit >= 7.51.0-1.1
Patchnames:
openSUSE Tumbleweed GA curl


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 11 GA curl Released
SUSE Linux Enterprise SDK 11 GA curl Released
SUSE Linux Enterprise Server 11 GA curl Released