Upstream information

CVE-2009-0034 at MITRE

Description

parse.c in sudo 1.6.9p17 through 1.6.9p19 does not properly interpret a system group (aka %group) in the sudoers file during authorization decisions for a user who belongs to that group, which allows local users to leverage an applicable sudoers file and gain root privileges via a sudo command.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 6.9
Vector AV:L/AC:M/Au:N/C:C/I:C/A:C
Access Vector Local
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 468923 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • sudo-debuginfo >= 1.6.9p15-13.4
  • sudo-debugsource >= 1.6.9p15-13.4
openSUSE 11.0
  • sudo >= 1.6.9p15-13.4
openSUSE 11.1
  • sudo-debuginfo >= 1.6.9p17-10.36.1
  • sudo-debugsource >= 1.6.9p17-10.36.1
openSUSE 11.1
  • sudo >= 1.6.9p17-10.36.1