Upstream information

CVE-2008-7270 at MITRE

Description

OpenSSL before 0.9.8j, when SSL_OP_NETSCAPE_REUSE_CIPHER_CHANGE_BUG is enabled, does not prevent modification of the ciphersuite in the session cache, which allows remote attackers to force the use of a disabled cipher via vectors involving sniffing network traffic to discover a session identifier, a different vulnerability than CVE-2010-4180.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:N/I:P/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact None
Integrity Impact Partial
Availability Impact None
SUSE Bugzilla entries: 608666 [RESOLVED / FIXED], 724729 [RESOLVED / INVALID]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Desktop 10 SP3 for x86
  • openssl >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise Desktop 10 SP3 for AMD64 and Intel EM64T
  • openssl >= 0.9.8a-18.43.1
  • openssl-32bit >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
  • openssl-devel-32bit >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise SDK 10 SP3
SUSE Linux Enterprise Server 10 SP3
SUSE Linux Enterprise Server for SAP 10 SP3
  • openssl >= 0.9.8a-18.43.1
  • openssl-32bit >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
  • openssl-devel-32bit >= 0.9.8a-18.43.1
  • openssl-doc >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise SDK 10 SP3
  • openssl-doc >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
  • openssl-doc >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
  • openssl-doc >= 0.9.8a-18.43.1
  • openssl-x86 >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise Server 10 SP3
  • openssl >= 0.9.8a-18.43.1
  • openssl-64bit >= 0.9.8a-18.43.1
  • openssl-devel >= 0.9.8a-18.43.1
  • openssl-devel-64bit >= 0.9.8a-18.43.1
  • openssl-doc >= 0.9.8a-18.43.1
sles10-sp3-debuginfo.s390x
sles10-sp3-debuginfo.x86-64
sle10-sp3-sdk.x86
sled10-sp3.x86
sles10-sp3.ppc
sles10-sp3.x86
sle10-sp3-sdk.ia64
sles10-sp3-debuginfo.x86
sle10-sp3-sdk.x86-64
sles10-sp3.x86-64
sles10-sp3.s390x
sles10-sp3-debuginfo.ppc
sles10-sp3-debuginfo.ia64
sle10-sp3-sdk.ppc
sled10-sp3.x86-64
sles10-sp3.ia64
sle10-sp3-sdk.s390x
ZYPP Patch Nr: 7174
SUSE Linux Enterprise SDK 11 GA
  • libopenssl-devel >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.22.22.1
  • openssl >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Desktop 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.22.22.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.22.22.1
  • openssl >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.22.22.1
  • openssl >= 0.9.8h-30.22.22.1
  • openssl-doc >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.22.22.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.22.22.1
  • openssl >= 0.9.8h-30.22.22.1
  • openssl-doc >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Server 11 GA
  • libopenssl0_9_8 >= 0.9.8h-30.22.22.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.22.22.1
  • openssl >= 0.9.8h-30.22.22.1
  • openssl-doc >= 0.9.8h-30.22.22.1
sle11-sdk.ia64
sles11.s390x
sles11.x86-64
sle11-sdk.x86-64
sles11.ppc
sles11.x86
sle11-sdk.x86
sled11.x86
sled11.x86-64
sles11.ia64
sle11-sdk.s390x
sle11-sdk.ppc
SAT Patch Nr: 3208
SUSE Linux Enterprise Software Development Kit 11 SP1
  • libopenssl-devel >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209
SUSE Linux Enterprise Desktop 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.28.1
  • openssl >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209
SUSE Linux Enterprise Desktop 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.28.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.28.1
  • openssl >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libopenssl0_9_8 >= 0.9.8h-30.28.1
  • openssl >= 0.9.8h-30.28.1
  • openssl-doc >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209
SUSE Linux Enterprise Server 11 SP1
SUSE Linux Enterprise Server 11 SP1 for VMware
  • libopenssl0_9_8 >= 0.9.8h-30.28.1
  • libopenssl0_9_8-32bit >= 0.9.8h-30.28.1
  • openssl >= 0.9.8h-30.28.1
  • openssl-doc >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209
SUSE Linux Enterprise Server 11 SP1
  • libopenssl0_9_8 >= 0.9.8h-30.28.1
  • libopenssl0_9_8-x86 >= 0.9.8h-30.28.1
  • openssl >= 0.9.8h-30.28.1
  • openssl-doc >= 0.9.8h-30.28.1
sle11-sp1-sdk.x86
sles11-sp1.s390x
sles11-sp1-vmware.x86
sled11-sp1.x86
sles11-sp1.x86
sles11-sp1.x86-64
sle11-sp1-sdk.x86-64
sle11-sp1-sdk.ppc
sles11-sp1.ia64
sles11-sp1-vmware.x86-64
sles11-sp1.ppc
sle11-sp1-sdk.ia64
sled11-sp1.x86-64
sle11-sp1-sdk.s390x
SAT Patch Nr: 3209


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Desktop 10 SP3 openssl Released
SUSE Linux Enterprise Desktop 11 GA openssl Released
SUSE Linux Enterprise Desktop 11 SP1 openssl Released
SUSE Linux Enterprise Desktop 11 SP2 openssl Released
SUSE Linux Enterprise Desktop 11 SP3 openssl Released
SUSE Linux Enterprise Desktop 11 SP4 openssl Released
SUSE Linux Enterprise SDK 11 GA openssl Released
SUSE Linux Enterprise SDK 11 SP1 openssl Released
SUSE Linux Enterprise SDK 11 SP2 openssl Released
SUSE Linux Enterprise SDK 11 SP3 openssl Released
SUSE Linux Enterprise SDK 11 SP4 openssl Released
SUSE Linux Enterprise Server 10 SP3 openssl Released
SUSE Linux Enterprise Server 11 GA openssl Released
SUSE Linux Enterprise Server 11 SP1 openssl Released
SUSE Linux Enterprise Server 11 SP1 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP2 openssl Released
SUSE Linux Enterprise Server 11 SP2 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP3 openssl Released
SUSE Linux Enterprise Server 11 SP3 LTSS openssl Released
SUSE Linux Enterprise Server 11 SP4 openssl Released
SUSE Linux Enterprise Server for SAP AIO 11 SP1 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP2 openssl Released
SUSE Linux Enterprise Server for SAP Applications 11 SP3 openssl Released
SUSE Linux Enterprise Server for SAP ES 11 SP1 openssl Released
SUSE Linux Enterprise Server for VMWare 11 SP2 openssl Released
SUSE Linux Enterprise Server for VMWare 11 SP3 openssl Released
SUSE Studio Onsite 1.3 openssl Released