Upstream information

CVE-2008-5658 at MITRE

Description

Directory traversal vulnerability in the ZipArchive::extractTo function in PHP 5.2.6 and earlier allows context-dependent attackers to write arbitrary files via a ZIP file with a file whose name contains .. (dot dot) sequences.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entries: 464048 [RESOLVED / FIXED], 480948 [RESOLVED / FIXED], 493122 [RESOLVED / FIXED], 568527 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • php5-debuginfo >= 5.2.6-0.8
  • php5-debugsource >= 5.2.6-0.8
openSUSE 11.0
  • apache2-mod_php5 >= 5.2.6-0.8
  • php5 >= 5.2.6-0.8
  • php5-bcmath >= 5.2.6-0.8
  • php5-bz2 >= 5.2.6-0.8
  • php5-calendar >= 5.2.6-0.8
  • php5-ctype >= 5.2.6-0.8
  • php5-curl >= 5.2.6-0.8
  • php5-dba >= 5.2.6-0.8
  • php5-dbase >= 5.2.6-0.8
  • php5-devel >= 5.2.6-0.8
  • php5-dom >= 5.2.6-0.8
  • php5-exif >= 5.2.6-0.8
  • php5-fastcgi >= 5.2.6-0.8
  • php5-ftp >= 5.2.6-0.8
  • php5-gd >= 5.2.6-0.8
  • php5-gettext >= 5.2.6-0.8
  • php5-gmp >= 5.2.6-0.8
  • php5-hash >= 5.2.6-0.8
  • php5-iconv >= 5.2.6-0.8
  • php5-imap >= 5.2.6-0.8
  • php5-json >= 5.2.6-0.8
  • php5-ldap >= 5.2.6-0.8
  • php5-mbstring >= 5.2.6-0.8
  • php5-mcrypt >= 5.2.6-0.8
  • php5-mysql >= 5.2.6-0.8
  • php5-ncurses >= 5.2.6-0.8
  • php5-odbc >= 5.2.6-0.8
  • php5-openssl >= 5.2.6-0.8
  • php5-pcntl >= 5.2.6-0.8
  • php5-pdo >= 5.2.6-0.8
  • php5-pear >= 5.2.6-0.8
  • php5-pgsql >= 5.2.6-0.8
  • php5-posix >= 5.2.6-0.8
  • php5-pspell >= 5.2.6-0.8
  • php5-readline >= 5.2.6-0.8
  • php5-shmop >= 5.2.6-0.8
  • php5-snmp >= 5.2.6-0.8
  • php5-soap >= 5.2.6-0.8
  • php5-sockets >= 5.2.6-0.8
  • php5-sqlite >= 5.2.6-0.8
  • php5-suhosin >= 5.2.6-0.8
  • php5-sysvmsg >= 5.2.6-0.8
  • php5-sysvsem >= 5.2.6-0.8
  • php5-sysvshm >= 5.2.6-0.8
  • php5-tidy >= 5.2.6-0.8
  • php5-tokenizer >= 5.2.6-0.8
  • php5-wddx >= 5.2.6-0.8
  • php5-xmlreader >= 5.2.6-0.8
  • php5-xmlrpc >= 5.2.6-0.8
  • php5-xmlwriter >= 5.2.6-0.8
  • php5-xsl >= 5.2.6-0.8
  • php5-zip >= 5.2.6-0.8
  • php5-zlib >= 5.2.6-0.8
openSUSE 11.1
  • php5-debuginfo >= 5.2.6-49.14.3
  • php5-debugsource >= 5.2.6-49.14.3
openSUSE 11.1
  • apache2-mod_php5 >= 5.2.6-49.14.3
  • php5 >= 5.2.6-49.14.3
  • php5-bcmath >= 5.2.6-49.14.3
  • php5-bz2 >= 5.2.6-49.14.3
  • php5-calendar >= 5.2.6-49.14.3
  • php5-ctype >= 5.2.6-49.14.3
  • php5-curl >= 5.2.6-49.14.3
  • php5-dba >= 5.2.6-49.14.3
  • php5-dbase >= 5.2.6-49.14.3
  • php5-devel >= 5.2.6-49.14.3
  • php5-dom >= 5.2.6-49.14.3
  • php5-exif >= 5.2.6-49.14.3
  • php5-fastcgi >= 5.2.6-49.14.3
  • php5-ftp >= 5.2.6-49.14.3
  • php5-gd >= 5.2.6-49.14.3
  • php5-gettext >= 5.2.6-49.14.3
  • php5-gmp >= 5.2.6-49.14.3
  • php5-hash >= 5.2.6-49.14.3
  • php5-iconv >= 5.2.6-49.14.3
  • php5-imap >= 5.2.6-49.14.3
  • php5-json >= 5.2.6-49.14.3
  • php5-ldap >= 5.2.6-49.14.3
  • php5-mbstring >= 5.2.6-49.14.3
  • php5-mcrypt >= 5.2.6-49.14.3
  • php5-mysql >= 5.2.6-49.14.3
  • php5-ncurses >= 5.2.6-49.14.3
  • php5-odbc >= 5.2.6-49.14.3
  • php5-openssl >= 5.2.6-49.14.3
  • php5-pcntl >= 5.2.6-49.14.3
  • php5-pdo >= 5.2.6-49.14.3
  • php5-pear >= 5.2.6-49.14.3
  • php5-pgsql >= 5.2.6-49.14.3
  • php5-posix >= 5.2.6-49.14.3
  • php5-pspell >= 5.2.6-49.14.3
  • php5-readline >= 5.2.6-49.14.3
  • php5-shmop >= 5.2.6-49.14.3
  • php5-snmp >= 5.2.6-49.14.3
  • php5-soap >= 5.2.6-49.14.3
  • php5-sockets >= 5.2.6-49.14.3
  • php5-sqlite >= 5.2.6-49.14.3
  • php5-suhosin >= 5.2.6-49.14.3
  • php5-sysvmsg >= 5.2.6-49.14.3
  • php5-sysvsem >= 5.2.6-49.14.3
  • php5-sysvshm >= 5.2.6-49.14.3
  • php5-tidy >= 5.2.6-49.14.3
  • php5-tokenizer >= 5.2.6-49.14.3
  • php5-wddx >= 5.2.6-49.14.3
  • php5-xmlreader >= 5.2.6-49.14.3
  • php5-xmlrpc >= 5.2.6-49.14.3
  • php5-xmlwriter >= 5.2.6-49.14.3
  • php5-xsl >= 5.2.6-49.14.3
  • php5-zip >= 5.2.6-49.14.3
  • php5-zlib >= 5.2.6-49.14.3
SUSE Linux Enterprise SDK 10 SP2
  • apache2-mod_php5 >= 5.2.5-9.12
  • php5 >= 5.2.5-9.12
  • php5-bcmath >= 5.2.5-9.12
  • php5-bz2 >= 5.2.5-9.12
  • php5-calendar >= 5.2.5-9.12
  • php5-ctype >= 5.2.5-9.12
  • php5-curl >= 5.2.5-9.12
  • php5-dba >= 5.2.5-9.12
  • php5-dbase >= 5.2.5-9.12
  • php5-devel >= 5.2.5-9.12
  • php5-dom >= 5.2.5-9.12
  • php5-exif >= 5.2.5-9.12
  • php5-fastcgi >= 5.2.5-9.12
  • php5-ftp >= 5.2.5-9.12
  • php5-gd >= 5.2.5-9.12
  • php5-gettext >= 5.2.5-9.12
  • php5-gmp >= 5.2.5-9.12
  • php5-iconv >= 5.2.5-9.12
  • php5-imap >= 5.2.5-9.12
  • php5-ldap >= 5.2.5-9.12
  • php5-mbstring >= 5.2.5-9.12
  • php5-mcrypt >= 5.2.5-9.12
  • php5-mhash >= 5.2.5-9.12
  • php5-mysql >= 5.2.5-9.12
  • php5-ncurses >= 5.2.5-9.12
  • php5-odbc >= 5.2.5-9.12
  • php5-openssl >= 5.2.5-9.12
  • php5-pcntl >= 5.2.5-9.12
  • php5-pdo >= 5.2.5-9.12
  • php5-pear >= 5.2.5-9.12
  • php5-pgsql >= 5.2.5-9.12
  • php5-posix >= 5.2.5-9.12
  • php5-pspell >= 5.2.5-9.12
  • php5-shmop >= 5.2.5-9.12
  • php5-snmp >= 5.2.5-9.12
  • php5-soap >= 5.2.5-9.12
  • php5-sockets >= 5.2.5-9.12
  • php5-sqlite >= 5.2.5-9.12
  • php5-suhosin >= 5.2.5-9.12
  • php5-sysvmsg >= 5.2.5-9.12
  • php5-sysvsem >= 5.2.5-9.12
  • php5-sysvshm >= 5.2.5-9.12
  • php5-tidy >= 5.2.5-9.12
  • php5-tokenizer >= 5.2.5-9.12
  • php5-wddx >= 5.2.5-9.12
  • php5-xmlreader >= 5.2.5-9.12
  • php5-xmlrpc >= 5.2.5-9.12
  • php5-xsl >= 5.2.5-9.12
  • php5-zlib >= 5.2.5-9.12
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.ia64
sles10-sp2-debuginfo.ppc
sle10-sp2-sdk.x86-64
sles10-sp2.x86-64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.x86
sles10-sp2-debuginfo.s390x
sles10-sp2.x86
sles10-sp2.ppc
sles10-sp2.ia64
sles10-sp2-debuginfo.x86
sles10-sp2.s390x
sle10-sp2-sdk.s390x
sles10-sp2-debuginfo.x86-64
ZYPP Patch Nr: 5909


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise SDK 11 GA php5 Affected