Upstream information

CVE-2008-4864 at MITRE

Description

Multiple integer overflows in imageop.c in the imageop module in Python 1.5.2 through 2.5.1 allow context-dependent attackers to break out of the Python VM and execute arbitrary code via large integer values in certain arguments to the crop function, leading to a buffer overflow, a different vulnerability than CVE-2007-4965 and CVE-2008-1679.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 444989 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • python >= 2.3.3-88.26
  • python-curses >= 2.3.3-88.26
  • python-demo >= 2.3.3-88.26
  • python-devel >= 2.3.3-88.26
  • python-doc >= 2.3.3-88.26
  • python-doc-pdf >= 2.3.3-88.26
  • python-gdbm >= 2.3.3-88.26
  • python-idle >= 2.3.3-88.26
  • python-mpz >= 2.3.3-88.26
  • python-tk >= 2.3.3-88.26
  • python-xml >= 2.3.3-88.26
sles9-oes.x86
core9.x86
sles9-nld.x86-64
core9.ppc
core9.s390
core9.ia64
sles9-nld.x86
core9.x86-64
sles9-nlpos.x86
core9.s390x
YOU Patch Nr: 12316
Novell Linux Desktop 9 for x86_64
  • python >= 2.3.3-88.26
  • python-32bit >= 9-200812011728
  • python-curses >= 2.3.3-88.26
  • python-demo >= 2.3.3-88.26
  • python-devel >= 2.3.3-88.26
  • python-doc >= 2.3.3-88.26
  • python-doc-pdf >= 2.3.3-88.26
  • python-gdbm >= 2.3.3-88.26
  • python-idle >= 2.3.3-88.26
  • python-mpz >= 2.3.3-88.26
  • python-tk >= 2.3.3-88.26
  • python-xml >= 2.3.3-88.26
sles9-oes.x86
core9.x86
sles9-nld.x86-64
core9.ppc
core9.s390
core9.ia64
sles9-nld.x86
core9.x86-64
sles9-nlpos.x86
core9.s390x
YOU Patch Nr: 12316
openSUSE 11.0
  • python-debuginfo >= 2.5.2-26.4
  • python-debugsource >= 2.5.2-26.4
openSUSE 11.0
  • python >= 2.5.2-26.4
  • python-32bit >= 2.5.2-26.4
  • python-64bit >= 2.5.2-26.4
  • python-curses >= 2.5.2-26.4
  • python-demo >= 2.5.2-26.4
  • python-devel >= 2.5.2-26.4
  • python-gdbm >= 2.5.2-26.4
  • python-idle >= 2.5.2-26.4
  • python-tk >= 2.5.2-26.4
  • python-xml >= 2.5.2-26.4
SUSE Linux Enterprise SDK 10 SP2
  • python-demo >= 2.4.2-18.25
  • python-devel >= 2.4.2-18.25
  • python-idle >= 2.4.2-18.25
sled10-sp2.x86
sles10-sp2.ia64
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.x86-64
sles10-sp2.s390x
sles10-sp2.ppc
sles10-sp2.x86
sle10-sp2-sdk.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
ZYPP Patch Nr: 5837