Upstream information

CVE-2008-4094 at MITRE

Description

Multiple SQL injection vulnerabilities in Ruby on Rails before 2.1.1 allow remote attackers to execute arbitrary SQL commands via the (1) :limit and (2) :offset parameters, related to ActiveRecord, ActiveSupport, ActiveResource, ActionPack, and ActionMailer.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 426198 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • rubygem-activerecord >= 1.15.5-71.2
SUSE Linux Enterprise SDK 10 SP2
  • rubygem-activerecord >= 2.0.2-0.4
  • rubygem-activerecord-1_14 >= 1.14.4-0.4
  • rubygem-activerecord-2_0 >= 2.0.2-0.4
sle10-sp2-sdk.x86
sle10-sp2-sdk.s390x
sle10-sp2-sdk.ia64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.x86-64
ZYPP Patch Nr: 5822