Upstream information

CVE-2008-3652 at MITRE

Description

src/racoon/handler.c in racoon in ipsec-tools does not remove an "orphaned ph1" (phase 1) handle when it has been initiated remotely, which allows remote attackers to cause a denial of service (resource consumption).

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having important severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.8
Vector AV:N/AC:L/Au:N/C:N/I:N/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact None
Availability Impact Complete
SUSE Bugzilla entries: 416906 [RESOLVED / FIXED], 434748 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP2
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP3
  • ipsec-tools >= 0.7.3-1.1.93
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA ipsec-tools
SUSE Linux Enterprise Server 11 SP4
  • ipsec-tools >= 0.7.3-1.4.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA ipsec-tools
SUSE Linux Enterprise SDK 10 SP2
  • ipsec-tools >= 0.6.5-10.10
sles10-sp2.ia64
core9.ia64
core9.ppc
sles9-nld.x86
sles9-nlpos.x86
sles10.s390x
core9.s390x
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.ppc
sles10-sp2.x86
sles10.ia64
sles10-sp2-debuginfo.ppc
core9.x86
core9.s390
sles10-sp2-debuginfo.x86
sles10-sp2-debuginfo.ia64
sle10-sp1-sdk.x86-64
sles9-nld.x86-64
sles10-sp2.x86-64
sle10-sp1-sdk.s390x
sle10-sp2-sdk.ia64
sles10.ppc
sles9-oes.x86
sles10.x86
sle10-sp1-sdk.ppc
core9.x86-64
sles10.x86-64
sles10-sp2-debuginfo.x86-64
sles10-sp2.s390x
sle10-sp1-sdk.x86
sle10-sp2-sdk.x86
sle10-sp2-sdk.s390x
sles10-sp2-debuginfo.s390x
sle10-sp1-sdk.ia64
ZYPP Patch Nr: 5638
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • ipsec-tools >= 0.3.3-1.15
sles10-sp2.ia64
core9.ia64
core9.ppc
sles9-nld.x86
sles9-nlpos.x86
sles10.s390x
core9.s390x
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.ppc
sles10-sp2.x86
sles10.ia64
sles10-sp2-debuginfo.ppc
core9.x86
core9.s390
sles10-sp2-debuginfo.x86
sles10-sp2-debuginfo.ia64
sle10-sp1-sdk.x86-64
sles9-nld.x86-64
sles10-sp2.x86-64
sle10-sp1-sdk.s390x
sle10-sp2-sdk.ia64
sles10.ppc
sles9-oes.x86
sles10.x86
sle10-sp1-sdk.ppc
core9.x86-64
sles10.x86-64
sles10-sp2-debuginfo.x86-64
sles10-sp2.s390x
sle10-sp1-sdk.x86
sle10-sp2-sdk.x86
sle10-sp2-sdk.s390x
sles10-sp2-debuginfo.s390x
sle10-sp1-sdk.ia64
ZYPP Patch Nr: 5638
openSUSE 11.0
  • novell-ipsec-tools-debuginfo >= 0.6.3-183.2
  • novell-ipsec-tools-debugsource >= 0.6.3-183.2
openSUSE 11.0
  • novell-ipsec-tools >= 0.6.3-183.2
  • novell-ipsec-tools-devel >= 0.6.3-183.2
openSUSE 11.0
  • ipsec-tools-debuginfo >= 0.7-61.3
  • ipsec-tools-debugsource >= 0.7-61.3
openSUSE 11.0
  • ipsec-tools >= 0.7-61.3
SUSE Linux Enterprise SDK 10 SP2
  • novell-ipsec-tools >= 0.6.3-26.23
  • novell-ipsec-tools-devel >= 0.6.3-26.23
sles10-sp2-debuginfo.ppc
sles10-sp2-debuginfo.x86
sled10-sp2.x86
sle10-sp2-sdk.ppc
sles10-sp2-debuginfo.ia64
sle10-sp2-sdk.s390x
sled10-sp2.x86-64
sles10-sp2-debuginfo.x86-64
sle10-sp2-sdk.ia64
sle10-sp2-sdk.x86
sles10-sp2-debuginfo.s390x
sle10-sp2-sdk.x86-64
ZYPP Patch Nr: 5888