Upstream information

CVE-2008-3639 at MITRE

Description

Heap-based buffer overflow in the read_rle16 function in imagetops in CUPS before 1.3.9 allows remote attackers to execute arbitrary code via an SGI image with malformed Run Length Encoded (RLE) data containing a small image and a large row count.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 7.5
Vector AV:N/AC:L/Au:N/C:P/I:P/A:P
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact Partial
Availability Impact Partial
SUSE Bugzilla entry: 430543 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • cups-debuginfo >= 1.3.7-25.2
  • cups-debugsource >= 1.3.7-25.2
openSUSE 11.0
  • cups >= 1.3.7-25.2
  • cups-client >= 1.3.7-25.2
  • cups-devel >= 1.3.7-25.2
  • cups-libs >= 1.3.7-25.2
  • cups-libs-32bit >= 1.3.7-25.2
  • cups-libs-64bit >= 1.3.7-25.2
Novell Linux Desktop 9 for x86
Open Enterprise Server
  • cups >= 1.1.20-108.54
  • cups-client >= 1.1.20-108.54
  • cups-devel >= 1.1.20-108.54
  • cups-libs >= 1.1.20-108.54
core9.ppc
core9.ia64
sles9-nld.x86
sles9-nld.x86-64
core9.s390x
core9.s390
sles9-oes.x86
sles9-nlpos.x86
core9.x86
core9.x86-64
YOU Patch Nr: 12261
Novell Linux Desktop 9 for x86_64
  • cups >= 1.1.20-108.54
  • cups-client >= 1.1.20-108.54
  • cups-devel >= 1.1.20-108.54
  • cups-libs >= 1.1.20-108.54
  • cups-libs-32bit >= 9-200810021549
core9.ppc
core9.ia64
sles9-nld.x86
sles9-nld.x86-64
core9.s390x
core9.s390
sles9-oes.x86
sles9-nlpos.x86
core9.x86
core9.x86-64
YOU Patch Nr: 12261