Upstream information

CVE-2008-3632 at MITRE

Description

Use-after-free vulnerability in WebKit in Apple iPod touch 1.1 through 2.0.2, and iPhone 1.0 through 2.0.2, allows remote attackers to execute arbitrary code or cause a denial of service (application crash) via a web page with crafted Cascading Style Sheets (CSS) import statements.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 426919 [RESOLVED / FIXED], 427349 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Software Development Kit 11 SP4
  • libwebkit-1_0-1 >= 1.0.1-0.1.141
  • libwebkit-1_0-2 >= 1.2.7-0.17.1
  • libwebkit-devel >= 1.2.7-0.17.1
  • libwebkit-lang >= 1.2.7-0.17.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libwebkit-1_0-1
SUSE Linux Enterprise Software Development Kit 11 SP4 GA libwebkit-1_0-2
openSUSE 11.0
  • WebKitGtk-debuginfo >= 1.0.29509-49.2
  • WebKitGtk-debugsource >= 1.0.29509-49.2
openSUSE 11.0
  • WebKitGtk >= 1.0.29509-49.2
  • WebKitGtk-devel >= 1.0.29509-49.2
  • libWebKitGtk0 >= 1.0.29509-49.2
openSUSE 11.0
  • libqt4-debuginfo >= 4.4.0-12.4
  • libqt4-debugsource >= 4.4.0-12.4
openSUSE 11.0
  • libQtWebKit-devel >= 4.4.0-12.3
  • libQtWebKit4 >= 4.4.0-12.3
  • libqt4 >= 4.4.0-12.4
  • libqt4-32bit >= 4.4.0-12.4
  • libqt4-64bit >= 4.4.0-12.4
  • libqt4-devel >= 4.4.0-12.4
  • libqt4-devel-doc >= 4.4.0-12.3
  • libqt4-qt3support >= 4.4.0-12.4
  • libqt4-qt3support-32bit >= 4.4.0-12.4
  • libqt4-qt3support-64bit >= 4.4.0-12.4
  • libqt4-sql >= 4.4.0-12.4
  • libqt4-sql-32bit >= 4.4.0-12.4
  • libqt4-sql-64bit >= 4.4.0-12.4
  • libqt4-sql-sqlite >= 4.4.0-12.4
  • libqt4-x11 >= 4.4.0-12.4
  • libqt4-x11-32bit >= 4.4.0-12.4
  • libqt4-x11-64bit >= 4.4.0-12.4
  • qt4-x11-tools >= 4.4.0-12.3