Upstream information

CVE-2008-3529 at MITRE

Description

Heap-based buffer overflow in the xmlParseAttValueComplex function in parser.c in libxml2 before 2.7.0 allows context-dependent attackers to cause a denial of service (crash) or execute arbitrary code via a long XML entity name.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 422636 [RESOLVED / FIXED], 441368 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
SLES SDK 9 for IBM S/390 and IBM zSeries
SLES SDK 9 for IBM iSeries and IBM pSeries
SLES SDK 9 for IBM zSeries
SLES SDK 9 for IPF
SLES SDK 9 for X86-64
SLES SDK 9 for x86
  • libxml2-python >= 2.6.7-46.14
sles10.ia64
core9.ia64
core9.x86
core9.s390x
sles10.s390x
core9.x86-64
sles10.ppc
sled10-sp2.x86
sles9-nld.x86
sled10.x86-64
core9.ppc
sles10-sp2-debuginfo.x86
sles9-oes.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.x86
core9.ppc
core9.s390
core9.x86-64
sles10-sp2.x86-64
sles9-nlpos.x86
sles9-nld.x86-64
sles9-nld.x86
sled10.x86
sles10-sp2.s390x
sles10-sp2.ppc
core9.s390x
sles9-nld.x86-64
sles10-sp2.ia64
sles10.x86
sles10.x86-64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.ia64
core9.x86
sled10-sp2.x86-64
core9.s390
sles10-sp2-debuginfo.ppc
core9.ia64
ZYPP Patch Nr: 5583
Novell Linux Desktop 9 for x86
  • libxml2 >= 2.6.7-28.14
  • libxml2-devel >= 2.6.7-28.14
  • libxml2-python >= 2.6.7-46.14
sles10.ia64
core9.ia64
core9.x86
core9.s390x
sles10.s390x
core9.x86-64
sles10.ppc
sled10-sp2.x86
sles9-nld.x86
sled10.x86-64
core9.ppc
sles10-sp2-debuginfo.x86
sles9-oes.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.x86
core9.ppc
core9.s390
core9.x86-64
sles10-sp2.x86-64
sles9-nlpos.x86
sles9-nld.x86-64
sles9-nld.x86
sled10.x86
sles10-sp2.s390x
sles10-sp2.ppc
core9.s390x
sles9-nld.x86-64
sles10-sp2.ia64
sles10.x86
sles10.x86-64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.ia64
core9.x86
sled10-sp2.x86-64
core9.s390
sles10-sp2-debuginfo.ppc
core9.ia64
ZYPP Patch Nr: 5583
Novell Linux Desktop 9 for x86_64
  • libxml2 >= 2.6.7-28.14
  • libxml2-32bit >= 9-200809051309
  • libxml2-devel >= 2.6.7-28.14
  • libxml2-python >= 2.6.7-46.14
sles10.ia64
core9.ia64
core9.x86
core9.s390x
sles10.s390x
core9.x86-64
sles10.ppc
sled10-sp2.x86
sles9-nld.x86
sled10.x86-64
core9.ppc
sles10-sp2-debuginfo.x86
sles9-oes.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.x86
core9.ppc
core9.s390
core9.x86-64
sles10-sp2.x86-64
sles9-nlpos.x86
sles9-nld.x86-64
sles9-nld.x86
sled10.x86
sles10-sp2.s390x
sles10-sp2.ppc
core9.s390x
sles9-nld.x86-64
sles10-sp2.ia64
sles10.x86
sles10.x86-64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.ia64
core9.x86
sled10-sp2.x86-64
core9.s390
sles10-sp2-debuginfo.ppc
core9.ia64
ZYPP Patch Nr: 5583
Open Enterprise Server
  • libxml2 >= 2.6.7-28.14
  • libxml2-devel >= 2.6.7-28.14
sles10.ia64
core9.ia64
core9.x86
core9.s390x
sles10.s390x
core9.x86-64
sles10.ppc
sled10-sp2.x86
sles9-nld.x86
sled10.x86-64
core9.ppc
sles10-sp2-debuginfo.x86
sles9-oes.x86
sles10-sp2-debuginfo.x86-64
sles10-sp2.x86
core9.ppc
core9.s390
core9.x86-64
sles10-sp2.x86-64
sles9-nlpos.x86
sles9-nld.x86-64
sles9-nld.x86
sled10.x86
sles10-sp2.s390x
sles10-sp2.ppc
core9.s390x
sles9-nld.x86-64
sles10-sp2.ia64
sles10.x86
sles10.x86-64
sles10-sp2-debuginfo.s390x
sles10-sp2-debuginfo.ia64
core9.x86
sled10-sp2.x86-64
core9.s390
sles10-sp2-debuginfo.ppc
core9.ia64
ZYPP Patch Nr: 5583
openSUSE 11.0
  • libxml2-debuginfo >= 2.6.32-11.3
  • libxml2-debugsource >= 2.6.32-11.3
openSUSE 11.0
  • libxml2 >= 2.6.32-11.3
  • libxml2-32bit >= 2.6.32-11.3
  • libxml2-64bit >= 2.6.32-11.3
  • libxml2-devel >= 2.6.32-11.3
  • libxml2-devel-32bit >= 2.6.32-11.3
  • libxml2-devel-64bit >= 2.6.32-11.3
  • libxml2-doc >= 2.6.32-11.3