Upstream information

CVE-2008-3520 at MITRE

Description

Multiple integer overflows in JasPer 1.900.1 might allow context-dependent attackers to have an unknown impact via a crafted image file, related to integer multiplication for memory allocation.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 392410 [RESOLVED / FIXED]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • jasper-debuginfo >= 1.900.1-98.3
  • jasper-debugsource >= 1.900.1-98.3
openSUSE 11.0
  • jasper >= 1.900.1-98.3
  • libjasper >= 1.900.1-98.3
  • libjasper-32bit >= 1.900.1-98.3
  • libjasper-64bit >= 1.900.1-98.3
  • libjasper-devel >= 1.900.1-98.3
SUSE Linux Enterprise SDK 10 SP2
  • jasper >= 1.701.0-16.10
sle10-sp1-sdk.x86-64
sles10.x86-64
sles10.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sles9-oes.x86
sle10-sp1-sdk.ppc
sles10.ia64
sles9-nld.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.ia64
sle10-sp2-sdk.s390x
sles10-sp2.ppc
sles9-nld.x86
core9.x86
sled10.x86-64
sles10.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles9-nlpos.x86
sle10-sp2-sdk.x86
core9.x86-64
core9.ppc
sle10-sp1-sdk.ia64
core9.s390x
sles10-sp2.x86
core9.s390
sled10.x86
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sled10-sp2.x86
sles10.ppc
sles10-sp2.s390x
core9.ia64
ZYPP Patch Nr: 5782
Novell Linux Desktop 9 for x86
  • libjasper >= 1.701.0-1.10
sle10-sp1-sdk.x86-64
sles10.x86-64
sles10.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sles9-oes.x86
sle10-sp1-sdk.ppc
sles10.ia64
sles9-nld.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.ia64
sle10-sp2-sdk.s390x
sles10-sp2.ppc
sles9-nld.x86
core9.x86
sled10.x86-64
sles10.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles9-nlpos.x86
sle10-sp2-sdk.x86
core9.x86-64
core9.ppc
sle10-sp1-sdk.ia64
core9.s390x
sles10-sp2.x86
core9.s390
sled10.x86
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sled10-sp2.x86
sles10.ppc
sles10-sp2.s390x
core9.ia64
ZYPP Patch Nr: 5782
Novell Linux Desktop 9 for x86_64
  • libjasper >= 1.701.0-1.10
  • libjasper-32bit >= 9-200811141502
sle10-sp1-sdk.x86-64
sles10.x86-64
sles10.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sles9-oes.x86
sle10-sp1-sdk.ppc
sles10.ia64
sles9-nld.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.ia64
sle10-sp2-sdk.s390x
sles10-sp2.ppc
sles9-nld.x86
core9.x86
sled10.x86-64
sles10.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles9-nlpos.x86
sle10-sp2-sdk.x86
core9.x86-64
core9.ppc
sle10-sp1-sdk.ia64
core9.s390x
sles10-sp2.x86
core9.s390
sled10.x86
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sled10-sp2.x86
sles10.ppc
sles10-sp2.s390x
core9.ia64
ZYPP Patch Nr: 5782
Open Enterprise Server
  • jasper >= 1.701.0-1.10
  • libjasper >= 1.701.0-1.10
sle10-sp1-sdk.x86-64
sles10.x86-64
sles10.x86
sles10-sp2.x86-64
sle10-sp2-sdk.ia64
sles9-oes.x86
sle10-sp1-sdk.ppc
sles10.ia64
sles9-nld.x86-64
sle10-sp2-sdk.x86-64
sles10-sp2.ia64
sle10-sp2-sdk.s390x
sles10-sp2.ppc
sles9-nld.x86
core9.x86
sled10.x86-64
sles10.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles9-nlpos.x86
sle10-sp2-sdk.x86
core9.x86-64
core9.ppc
sle10-sp1-sdk.ia64
core9.s390x
sles10-sp2.x86
core9.s390
sled10.x86
sle10-sp1-sdk.x86
sle10-sp1-sdk.s390x
sled10-sp2.x86
sles10.ppc
sles10-sp2.s390x
core9.ia64
ZYPP Patch Nr: 5782