Upstream information

CVE-2008-3107 at MITRE

Description

Unspecified vulnerability in the Virtual Machine in Sun Java Runtime Environment (JRE) in JDK and JRE 6 before Update 7, JDK and JRE 5.0 before Update 16, and SDK and JRE 1.4.x before 1.4.2_18 allows context-dependent attackers to gain privileges via an untrusted (1) application or (2) applet, as demonstrated by an application or applet that grants itself privileges to (a) read local files, (b) write to local files, or (c) execute local programs.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 10
Vector AV:N/AC:L/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 407935 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • java2 >= 1.4.2-129.43
  • java2-jre >= 1.4.2-129.43
sles9-nld.x86-64
core9.ia64
core9.x86-64
core9.x86
sles9-oes.x86
sles9-nld.x86
sles9-nlpos.x86
YOU Patch Nr: 12206
openSUSE 11.0
  • java-1_6_0-sun >= 1.6.0.u7-1.1
  • java-1_6_0-sun-alsa >= 1.6.0.u7-1.1
  • java-1_6_0-sun-debuginfo >= 1.6.0.u7-1.1
  • java-1_6_0-sun-demo >= 1.6.0.u7-1.1
  • java-1_6_0-sun-devel >= 1.6.0.u7-1.1
  • java-1_6_0-sun-jdbc >= 1.6.0.u7-1.1
  • java-1_6_0-sun-plugin >= 1.6.0.u7-1.1
openSUSE 11.0
  • java-1_5_0-sun >= 1.5.0_update16-1.1
  • java-1_5_0-sun-alsa >= 1.5.0_update16-1.1
  • java-1_5_0-sun-demo >= 1.5.0_update16-1.1
  • java-1_5_0-sun-devel >= 1.5.0_update16-1.1
  • java-1_5_0-sun-jdbc >= 1.5.0_update16-1.1
  • java-1_5_0-sun-plugin >= 1.5.0_update16-1.1
  • java-1_5_0-sun-src >= 1.5.0_update16-1.1