Upstream information

CVE-2008-3074 at MITRE

Description

The shellescape function in Vim 7.0 through 7.2, including 7.2a.10, allows user-assisted attackers to execute arbitrary code via the "!" (exclamation point) shell metacharacter in (1) the filename of a tar archive and possibly (2) the filename of the first file in a tar archive, which is not properly handled by the VIM TAR plugin (tar.vim) v.10 through v.22, as demonstrated by the shellescape, tarplugin.v2, tarplugin, and tarplugin.updated test cases. NOTE: this issue reportedly exists because of an incomplete fix for CVE-2008-2712. NOTE: this issue has the same root cause as CVE-2008-3075. NOTE: due to the complexity of the associated disclosures and the incomplete information related to them, there may be inaccuracies in this CVE description and in external mappings to this identifier.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entry: 406693 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • vim-debuginfo >= 7.2-9.1
  • vim-debugsource >= 7.2-9.1
openSUSE 11.0
  • gvim >= 7.2-9.1
  • vim >= 7.2-9.1
  • vim-base >= 7.2-9.1
  • vim-data >= 7.2-9.1
  • vim-enhanced >= 7.2-9.1
openSUSE 11.1
  • vim-debuginfo >= 7.2-7.4.1
  • vim-debugsource >= 7.2-7.4.1
openSUSE 11.1
  • gvim >= 7.2-7.4.1
  • vim >= 7.2-7.4.1
  • vim-base >= 7.2-7.4.1
  • vim-data >= 7.2-7.4.1
  • vim-enhanced >= 7.2-7.4.1