Upstream information

CVE-2008-2938 at MITRE

Description

Directory traversal vulnerability in Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when allowLinking and UTF-8 are enabled, allows remote attackers to read arbitrary files via encoded directory traversal sequences in the URI, a different vulnerability than CVE-2008-2370. NOTE: versions earlier than 6.0.18 were reported affected, but the vendor advisory lists 6.0.16 as the last affected version.

SUSE information

Overall state of this security issue: Does not affect SUSE products

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.3
Vector AV:N/AC:M/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 417217 [RESOLVED / FIXED], 427726 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP2
  • tomcat6 >= 6.0.18-20.35.36.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.36.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.36.1
  • tomcat6-javadoc >= 6.0.18-20.35.36.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.36.1
  • tomcat6-lib >= 6.0.18-20.35.36.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.36.1
  • tomcat6-webapps >= 6.0.18-20.35.36.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA tomcat6
SUSE Linux Enterprise Server 11 SP3
  • tomcat6 >= 6.0.18-20.35.40.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.40.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.40.1
  • tomcat6-javadoc >= 6.0.18-20.35.40.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.40.1
  • tomcat6-lib >= 6.0.18-20.35.40.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.40.1
  • tomcat6-webapps >= 6.0.18-20.35.40.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA tomcat6
SUSE Linux Enterprise Server 11 SP4
  • tomcat6 >= 6.0.41-0.43.1
  • tomcat6-admin-webapps >= 6.0.41-0.43.1
  • tomcat6-docs-webapp >= 6.0.41-0.43.1
  • tomcat6-javadoc >= 6.0.41-0.43.1
  • tomcat6-jsp-2_1-api >= 6.0.41-0.43.1
  • tomcat6-lib >= 6.0.41-0.43.1
  • tomcat6-servlet-2_5-api >= 6.0.41-0.43.1
  • tomcat6-webapps >= 6.0.41-0.43.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA tomcat6
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
  • jakarta-tomcat >= 5.0.19-29.16
core9.ia64
core9.ppc
core9.x86
core9.x86-64
core9.s390x
sles9-oes.x86
sles9-nld.x86
core9.s390
sles9-nlpos.x86
sles9-nld.x86-64
YOU Patch Nr: 12232
Open Enterprise Server
  • apache-jakarta-tomcat-connectors >= 5.0.19-29.16
  • apache2-jakarta-tomcat-connectors >= 5.0.19-29.16
  • jakarta-tomcat >= 5.0.19-29.16
  • jakarta-tomcat-doc >= 5.0.19-29.16
  • jakarta-tomcat-examples >= 5.0.19-29.16
core9.ia64
core9.ppc
core9.x86
core9.x86-64
core9.s390x
sles9-oes.x86
sles9-nld.x86
core9.s390
sles9-nlpos.x86
sles9-nld.x86-64
YOU Patch Nr: 12232
openSUSE 11.0
  • tomcat6 >= 6.0.16-6.4
  • tomcat6-admin-webapps >= 6.0.16-6.4
  • tomcat6-docs-webapp >= 6.0.16-6.4
  • tomcat6-javadoc >= 6.0.16-6.4
  • tomcat6-jsp-2_1-api >= 6.0.16-6.4
  • tomcat6-lib >= 6.0.16-6.4
  • tomcat6-servlet-2_5-api >= 6.0.16-6.4
  • tomcat6-webapps >= 6.0.16-6.4
SUSE Linux Enterprise SDK 10 SP2
  • tomcat5 >= 5.0.30-27.30
  • tomcat5-admin-webapps >= 5.0.30-27.30
  • tomcat5-webapps >= 5.0.30-27.30
sles10-sp2.ppc
sle10-sp1-sdk.ia64
sles10-sp2.x86-64
sle10-sp2-sdk.s390x
sles10.ppc
sles10.ia64
sles10.x86
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.x86
sle10-sp1-sdk.x86
sles10.s390x
sle10-sp2-sdk.ia64
sles10-sp2.ia64
sles10-sp2.s390x
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ppc
sle10-sp2-sdk.x86-64
sles10.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.x86
ZYPP Patch Nr: 5539


Status of this issue by product and package

Please note that this evaluation state might be work in progress, incomplete or outdated. Also information for service packs in the LTSS phase is only included for issues meeting the LTSS criteria. If in doubt, feel free to contact us for clarification.

Product(s) Source package State
SUSE Linux Enterprise Server 12 SP2 tomcat Not affected
SUSE Linux Enterprise Server 12 SP3 tomcat Not affected