Upstream information

CVE-2008-2933 at MITRE

Description

Mozilla Firefox before 2.0.0.16, and 3.x before 3.0.1, interprets '|' (pipe) characters in a command-line URI as requests to open multiple tabs, which allows remote attackers to access chrome:i URIs, or read arbitrary local files via manipulations involving a series of URIs that is not entirely handled by a vector application, as exploited in conjunction with CVE-2008-2540. NOTE: this issue exists because of an insufficient fix for CVE-2005-2267.

SUSE information

Overall state of this security issue: Ignore

This issue is currently rated as having low severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 2.6
Vector AV:N/AC:H/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity High
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 407573 [RESOLVED / FIXED], 410782 [RESOLVED / DUPLICATE]

No SUSE Security Announcements cross referenced.

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • MozillaFirefox-debuginfo >= 3.0.1-0.1
  • MozillaFirefox-debugsource >= 3.0.1-0.1
  • mozilla-xulrunner190-debuginfo >= 1.9.0.1-0.1
  • mozilla-xulrunner190-debugsource >= 1.9.0.1-0.1
openSUSE 11.0
  • MozillaFirefox >= 3.0.1-0.1
  • MozillaFirefox-translations >= 3.0.1-0.1
  • mozilla-xulrunner190 >= 1.9.0.1-0.1
  • mozilla-xulrunner190-32bit >= 1.9.0.1-0.1
  • mozilla-xulrunner190-64bit >= 1.9.0.1-0.1
  • mozilla-xulrunner190-devel >= 1.9.0.1-0.1
  • mozilla-xulrunner190-gnomevfs >= 1.9.0.1-0.1
  • mozilla-xulrunner190-gnomevfs-32bit >= 1.9.0.1-0.1
  • mozilla-xulrunner190-gnomevfs-64bit >= 1.9.0.1-0.1
  • mozilla-xulrunner190-translations >= 1.9.0.1-0.1
  • mozilla-xulrunner190-translations-32bit >= 1.9.0.1-0.1
  • mozilla-xulrunner190-translations-64bit >= 1.9.0.1-0.1