Upstream information

CVE-2008-2712 at MITRE

Description

Vim 7.1.314, 6.4, and other versions allows user-assisted remote attackers to execute arbitrary commands via Vim scripts that do not properly sanitize inputs before invoking the execute or system functions, as demonstrated using (1) filetype.vim, (3) xpm.vim, (4) gzip_vim, and (5) netrw. NOTE: the originally reported version was 7.1.314, but the researcher actually found this set of issues in 7.1.298. NOTE: the zipplugin issue (originally vector 2 in this identifier) has been subsumed by CVE-2008-3075.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having critical severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 9.3
Vector AV:N/AC:M/Au:N/C:C/I:C/A:C
Access Vector Network
Access Complexity Medium
Authentication None
Confidentiality Impact Complete
Integrity Impact Complete
Availability Impact Complete
SUSE Bugzilla entries: 400508 [RESOLVED / FIXED], 406693 [RESOLVED / FIXED], 427627 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
openSUSE 11.0
  • vim-debuginfo >= 7.2-9.1
  • vim-debugsource >= 7.2-9.1
openSUSE 11.0
  • gvim >= 7.2-9.1
  • vim >= 7.2-9.1
  • vim-base >= 7.2-9.1
  • vim-data >= 7.2-9.1
  • vim-enhanced >= 7.2-9.1
openSUSE 11.1
  • vim-debuginfo >= 7.2-7.4.1
  • vim-debugsource >= 7.2-7.4.1
openSUSE 11.1
  • gvim >= 7.2-7.4.1
  • vim >= 7.2-7.4.1
  • vim-base >= 7.2-7.4.1
  • vim-data >= 7.2-7.4.1
  • vim-enhanced >= 7.2-7.4.1
SUSE Linux Enterprise SDK 10 SP2
  • gvim >= 6.4.6-19.15
sles10-sp2.x86-64
sles10-sp2.x86
sles10-sp2.ia64
sle10-sp2-sdk.x86
sles10-sp2.ppc
sle10-sp2-sdk.ia64
sled10-sp2.x86
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.s390x
sled10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.s390x
ZYPP Patch Nr: 6025
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • gvim >= 6.2-235.8
  • vim >= 6.2-235.8
core9.x86
core9.s390x
sles9-nld.x86
sles9-nlpos.x86
core9.ppc
sles9-nld.x86-64
core9.s390
core9.x86-64
sles9-oes.x86
core9.ia64
YOU Patch Nr: 12360