Upstream information

CVE-2008-2370 at MITRE

Description

Apache Tomcat 4.1.0 through 4.1.37, 5.5.0 through 5.5.26, and 6.0.0 through 6.0.16, when a RequestDispatcher is used, performs path normalization before removing the query string from the URI, which allows remote attackers to conduct directory traversal attacks and read arbitrary files via a .. (dot dot) in a request parameter.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 5
Vector AV:N/AC:L/Au:N/C:P/I:N/A:N
Access Vector Network
Access Complexity Low
Authentication None
Confidentiality Impact Partial
Integrity Impact None
Availability Impact None
SUSE Bugzilla entries: 414657 [RESOLVED / FIXED], 415697 [RESOLVED / DUPLICATE], 417217 [RESOLVED / FIXED], 427726 [RESOLVED / FIXED], 509839 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP2
  • tomcat6 >= 6.0.18-20.35.36.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.36.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.36.1
  • tomcat6-javadoc >= 6.0.18-20.35.36.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.36.1
  • tomcat6-lib >= 6.0.18-20.35.36.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.36.1
  • tomcat6-webapps >= 6.0.18-20.35.36.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA tomcat6
SUSE Linux Enterprise Server 11 SP3
  • tomcat6 >= 6.0.18-20.35.40.1
  • tomcat6-admin-webapps >= 6.0.18-20.35.40.1
  • tomcat6-docs-webapp >= 6.0.18-20.35.40.1
  • tomcat6-javadoc >= 6.0.18-20.35.40.1
  • tomcat6-jsp-2_1-api >= 6.0.18-20.35.40.1
  • tomcat6-lib >= 6.0.18-20.35.40.1
  • tomcat6-servlet-2_5-api >= 6.0.18-20.35.40.1
  • tomcat6-webapps >= 6.0.18-20.35.40.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA tomcat6
SUSE Linux Enterprise Server 11 SP4
  • tomcat6 >= 6.0.41-0.43.1
  • tomcat6-admin-webapps >= 6.0.41-0.43.1
  • tomcat6-docs-webapp >= 6.0.41-0.43.1
  • tomcat6-javadoc >= 6.0.41-0.43.1
  • tomcat6-jsp-2_1-api >= 6.0.41-0.43.1
  • tomcat6-lib >= 6.0.41-0.43.1
  • tomcat6-servlet-2_5-api >= 6.0.41-0.43.1
  • tomcat6-webapps >= 6.0.41-0.43.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA tomcat6
Novell Linux Desktop 9 SDK for x86
Novell Linux Desktop 9 SDK for x86_64
  • jakarta-tomcat >= 5.0.19-29.16
core9.ia64
core9.ppc
core9.x86
core9.x86-64
core9.s390x
sles9-oes.x86
sles9-nld.x86
core9.s390
sles9-nlpos.x86
sles9-nld.x86-64
YOU Patch Nr: 12232
Open Enterprise Server
  • apache-jakarta-tomcat-connectors >= 5.0.19-29.16
  • apache2-jakarta-tomcat-connectors >= 5.0.19-29.16
  • jakarta-tomcat >= 5.0.19-29.16
  • jakarta-tomcat-doc >= 5.0.19-29.16
  • jakarta-tomcat-examples >= 5.0.19-29.16
core9.ia64
core9.ppc
core9.x86
core9.x86-64
core9.s390x
sles9-oes.x86
sles9-nld.x86
core9.s390
sles9-nlpos.x86
sles9-nld.x86-64
YOU Patch Nr: 12232
openSUSE 11.0
  • tomcat6 >= 6.0.16-6.4
  • tomcat6-admin-webapps >= 6.0.16-6.4
  • tomcat6-docs-webapp >= 6.0.16-6.4
  • tomcat6-javadoc >= 6.0.16-6.4
  • tomcat6-jsp-2_1-api >= 6.0.16-6.4
  • tomcat6-lib >= 6.0.16-6.4
  • tomcat6-servlet-2_5-api >= 6.0.16-6.4
  • tomcat6-webapps >= 6.0.16-6.4
SUSE Linux Enterprise SDK 10 SP2
  • tomcat5 >= 5.0.30-27.30
  • tomcat5-admin-webapps >= 5.0.30-27.30
  • tomcat5-webapps >= 5.0.30-27.30
sles10-sp2.ppc
sle10-sp1-sdk.ia64
sles10-sp2.x86-64
sle10-sp2-sdk.s390x
sles10.ppc
sles10.ia64
sles10.x86
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.x86
sle10-sp1-sdk.x86
sles10.s390x
sle10-sp2-sdk.ia64
sles10-sp2.ia64
sles10-sp2.s390x
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ppc
sle10-sp2-sdk.x86-64
sles10.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.x86
ZYPP Patch Nr: 5539