Upstream information

CVE-2008-2235 at MITRE

Description

OpenSC before 0.11.5 uses weak permissions (ADMIN file control information of 00) for the 5015 directory on smart cards and USB crypto tokens running Siemens CardOS M4, which allows physically proximate attackers to change the PIN.

SUSE information

Overall state of this security issue: Resolved

This issue is currently rated as having moderate severity.

CVSS v2 Scores
  National Vulnerability Database
Base Score 4.9
Vector AV:L/AC:L/Au:N/C:N/I:C/A:N
Access Vector Local
Access Complexity Low
Authentication None
Confidentiality Impact None
Integrity Impact Complete
Availability Impact None
SUSE Bugzilla entry: 413496 [RESOLVED / FIXED]

SUSE Security Advisories:

List of released packages

Product(s) Fixed package version(s) References
SUSE Linux Enterprise Server 11 SP1
  • libopensc2 >= 0.11.6-5.25.1
  • libopensc2-32bit >= 0.11.6-5.25.1
  • libopensc2-x86 >= 0.11.6-5.25.1
  • opensc >= 0.11.6-5.25.1
  • opensc-32bit >= 0.11.6-5.25.1
  • opensc-x86 >= 0.11.6-5.25.1
Patchnames:
SUSE Linux Enterprise Server 11 SP1 GA libopensc2
SUSE Linux Enterprise Server 11 SP2
  • libopensc2 >= 0.11.6-5.27.1
  • libopensc2-32bit >= 0.11.6-5.27.1
  • libopensc2-x86 >= 0.11.6-5.27.1
  • opensc >= 0.11.6-5.27.1
  • opensc-32bit >= 0.11.6-5.27.1
  • opensc-x86 >= 0.11.6-5.27.1
Patchnames:
SUSE Linux Enterprise Server 11 SP2 GA libopensc2
SUSE Linux Enterprise Server 11 SP3
  • libopensc2 >= 0.11.6-5.27.1
  • libopensc2-32bit >= 0.11.6-5.27.1
  • libopensc2-x86 >= 0.11.6-5.27.1
  • opensc >= 0.11.6-5.27.1
  • opensc-32bit >= 0.11.6-5.27.1
  • opensc-x86 >= 0.11.6-5.27.1
Patchnames:
SUSE Linux Enterprise Server 11 SP3 GA libopensc2
SUSE Linux Enterprise Server 11 SP4
  • libopensc2 >= 0.11.6-5.27.1
  • libopensc2-32bit >= 0.11.6-5.27.1
  • libopensc2-x86 >= 0.11.6-5.27.1
  • opensc >= 0.11.6-5.27.1
  • opensc-32bit >= 0.11.6-5.27.1
  • opensc-x86 >= 0.11.6-5.27.1
Patchnames:
SUSE Linux Enterprise Server 11 SP4 GA libopensc2
SUSE Linux Enterprise Software Development Kit 11 SP4
  • opensc-devel >= 0.11.6-5.27.1
Patchnames:
SUSE Linux Enterprise Software Development Kit 11 SP4 GA opensc-devel
SUSE Linux Enterprise SDK 10 SP2
  • opensc-devel >= 0.9.6-17.7
sled10.x86
sles10-sp2.s390x
sled10-sp2.x86
sle10-sp1-sdk.x86
sled10-sp2.x86-64
sled10.x86-64
sles10.s390x
sles10-sp2.ia64
core9.x86-64
sle10-sp2-sdk.ia64
sles10.ia64
sles9-nld.x86
sles10-sp2.x86-64
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ia64
core9.x86
sles10.x86-64
sles10.ppc
sle10-sp2-sdk.s390x
sles9-nlpos.x86
core9.ia64
sle10-sp1-sdk.ppc
sles10-sp2.x86
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.ppc
core9.ppc
sles10.x86
sles9-nld.x86-64
sles9-oes.x86
sle10-sp2-sdk.x86
sles10-sp2.ppc
ZYPP Patch Nr: 5493
SUSE Linux Enterprise SDK 10 SP2
  • opensc-32bit >= 0.9.6-17.7
  • opensc-devel >= 0.9.6-17.7
sled10.x86
sles10-sp2.s390x
sled10-sp2.x86
sle10-sp1-sdk.x86
sled10-sp2.x86-64
sled10.x86-64
sles10.s390x
sles10-sp2.ia64
core9.x86-64
sle10-sp2-sdk.ia64
sles10.ia64
sles9-nld.x86
sles10-sp2.x86-64
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ia64
core9.x86
sles10.x86-64
sles10.ppc
sle10-sp2-sdk.s390x
sles9-nlpos.x86
core9.ia64
sle10-sp1-sdk.ppc
sles10-sp2.x86
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.ppc
core9.ppc
sles10.x86
sles9-nld.x86-64
sles9-oes.x86
sle10-sp2-sdk.x86
sles10-sp2.ppc
ZYPP Patch Nr: 5493
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • opensc >= 0.8.0-194.4
  • opensc-devel >= 0.8.0-194.4
sled10.x86
sles10-sp2.s390x
sled10-sp2.x86
sle10-sp1-sdk.x86
sled10-sp2.x86-64
sled10.x86-64
sles10.s390x
sles10-sp2.ia64
core9.x86-64
sle10-sp2-sdk.ia64
sles10.ia64
sles9-nld.x86
sles10-sp2.x86-64
sle10-sp1-sdk.s390x
sle10-sp1-sdk.ia64
core9.x86
sles10.x86-64
sles10.ppc
sle10-sp2-sdk.s390x
sles9-nlpos.x86
core9.ia64
sle10-sp1-sdk.ppc
sles10-sp2.x86
sle10-sp1-sdk.x86-64
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.ppc
core9.ppc
sles10.x86
sles9-nld.x86-64
sles9-oes.x86
sle10-sp2-sdk.x86
sles10-sp2.ppc
ZYPP Patch Nr: 5493
SUSE Linux Enterprise SDK 10 SP2
  • opensc-devel >= 0.9.6-17.9
sle10-sp2-sdk.ia64
sle10-sp2-sdk.x86
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.s390x
sles10-sp2.x86
sles10-sp2.s390x
sles10-sp2.ppc
sled10-sp2.x86-64
sles10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.ia64
sled10-sp2.x86
ZYPP Patch Nr: 5910
SUSE Linux Enterprise SDK 10 SP2
  • opensc-32bit >= 0.9.6-17.9
  • opensc-devel >= 0.9.6-17.9
sle10-sp2-sdk.ia64
sle10-sp2-sdk.x86
sle10-sp2-sdk.x86-64
sle10-sp2-sdk.s390x
sles10-sp2.x86
sles10-sp2.s390x
sles10-sp2.ppc
sled10-sp2.x86-64
sles10-sp2.x86-64
sle10-sp2-sdk.ppc
sles10-sp2.ia64
sled10-sp2.x86
ZYPP Patch Nr: 5910
openSUSE 11.0
  • opensc-debuginfo >= 0.11.4-37.2
  • opensc-debugsource >= 0.11.4-37.2
openSUSE 11.0
  • libopensc2 >= 0.11.4-37.2
  • libopensc2-32bit >= 0.11.4-37.2
  • libopensc2-64bit >= 0.11.4-37.2
  • opensc >= 0.11.4-37.2
  • opensc-32bit >= 0.11.4-37.2
  • opensc-64bit >= 0.11.4-37.2
  • opensc-devel >= 0.11.4-37.2
SUSE Linux Enterprise SDK 10 SP2
  • opensc-devel >= 0.9.6-17.9
sles10-sp2.s390x
sle10-sp2-sdk.x86-64
sled10.x86-64
sles9-nlpos.x86
sled10.x86
sle10-sp1-sdk.x86
core9.x86
sles9-nld.x86
sle10-sp1-sdk.x86-64
sled10-sp2.x86-64
core9.ppc
sles10-sp2.x86
sle10-sp2-sdk.s390x
sles10.x86
sle10-sp1-sdk.s390x
sles9-nld.x86-64
sles10-sp2.ppc
core9.ia64
sle10-sp1-sdk.ppc
sles9-oes.x86
sles10.ppc
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sled10-sp2.x86
sles10.ia64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.ia64
sle10-sp1-sdk.ia64
core9.x86-64
sles10-sp2.ia64
sles10.s390x
sles10.x86-64
ZYPP Patch Nr: 5588
SUSE Linux Enterprise SDK 10 SP2
  • opensc-32bit >= 0.9.6-17.9
  • opensc-devel >= 0.9.6-17.9
sles10-sp2.s390x
sle10-sp2-sdk.x86-64
sled10.x86-64
sles9-nlpos.x86
sled10.x86
sle10-sp1-sdk.x86
core9.x86
sles9-nld.x86
sle10-sp1-sdk.x86-64
sled10-sp2.x86-64
core9.ppc
sles10-sp2.x86
sle10-sp2-sdk.s390x
sles10.x86
sle10-sp1-sdk.s390x
sles9-nld.x86-64
sles10-sp2.ppc
core9.ia64
sle10-sp1-sdk.ppc
sles9-oes.x86
sles10.ppc
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sled10-sp2.x86
sles10.ia64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.ia64
sle10-sp1-sdk.ia64
core9.x86-64
sles10-sp2.ia64
sles10.s390x
sles10.x86-64
ZYPP Patch Nr: 5588
Novell Linux Desktop 9 for x86
Novell Linux Desktop 9 for x86_64
Open Enterprise Server
  • opensc >= 0.8.0-194.6
  • opensc-devel >= 0.8.0-194.6
sles10-sp2.s390x
sle10-sp2-sdk.x86-64
sled10.x86-64
sles9-nlpos.x86
sled10.x86
sle10-sp1-sdk.x86
core9.x86
sles9-nld.x86
sle10-sp1-sdk.x86-64
sled10-sp2.x86-64
core9.ppc
sles10-sp2.x86
sle10-sp2-sdk.s390x
sles10.x86
sle10-sp1-sdk.s390x
sles9-nld.x86-64
sles10-sp2.ppc
core9.ia64
sle10-sp1-sdk.ppc
sles9-oes.x86
sles10.ppc
sle10-sp2-sdk.x86
sles10-sp2.x86-64
sled10-sp2.x86
sles10.ia64
sle10-sp2-sdk.ppc
sle10-sp2-sdk.ia64
sle10-sp1-sdk.ia64
core9.x86-64
sles10-sp2.ia64
sles10.s390x
sles10.x86-64
ZYPP Patch Nr: 5588
openSUSE 11.0
  • opensc-debuginfo >= 0.11.4-37.4
  • opensc-debugsource >= 0.11.4-37.4
openSUSE 11.0
  • libopensc2 >= 0.11.4-37.4
  • libopensc2-32bit >= 0.11.4-37.4
  • libopensc2-64bit >= 0.11.4-37.4
  • opensc >= 0.11.4-37.4
  • opensc-32bit >= 0.11.4-37.4
  • opensc-64bit >= 0.11.4-37.4
  • opensc-devel >= 0.11.4-37.4